diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2017-01-10 17:39:24 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-01-11 10:56:36 -0200 |
commit | 59885ab98339c11e4144e07f98f7e1d578d3f740 (patch) | |
tree | fd6a3c89f772d7fc9138775d5dcffd3777597b7c /dynamic-layers | |
parent | 1c0104b699a183ac3212d436fae4a7b7297124ca (diff) | |
download | meta-freescale-59885ab98339c11e4144e07f98f7e1d578d3f740.tar.gz |
qtbase: Reimplement i.MX configuration changes with patches
Changing source should be done during the patch phase, not
the configure stage.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
3 files changed, 32 insertions, 23 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0014-Add-IMX-GPU-support.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0014-Add-IMX-GPU-support.patch new file mode 100644 index 00000000..beeb92c2 --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0014-Add-IMX-GPU-support.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: git/mkspecs/linux-oe-g++/qmake.conf | ||
2 | =================================================================== | ||
3 | --- git.orig/mkspecs/linux-oe-g++/qmake.conf 2016-12-14 16:51:48.468955533 -0600 | ||
4 | +++ git/mkspecs/linux-oe-g++/qmake.conf 2016-12-14 17:03:17.000000000 -0600 | ||
5 | @@ -39,4 +39,8 @@ | ||
6 | |||
7 | include(../oe-device-extra.pri) | ||
8 | |||
9 | +QMAKE_LIBS_EGL += -lEGL | ||
10 | +QMAKE_LIBS_OPENGL_ES2 += -lEGL -lGLESv2 | ||
11 | +QMAKE_LIBS_OPENVG += -lEGL -lOpenVG | ||
12 | + | ||
13 | load(qt_config) | ||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch new file mode 100644 index 00000000..794fa622 --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/0015-Add-eglfs-to-IMX-GPU.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Index: git/mkspecs/linux-oe-g++/qmake.conf | ||
2 | =================================================================== | ||
3 | --- git.orig/mkspecs/linux-oe-g++/qmake.conf 2016-12-14 17:03:17.000000000 -0600 | ||
4 | +++ git/mkspecs/linux-oe-g++/qmake.conf 2016-12-14 17:06:23.000000000 -0600 | ||
5 | @@ -39,6 +39,8 @@ | ||
6 | |||
7 | include(../oe-device-extra.pri) | ||
8 | |||
9 | +EGLFS_DEVICE_INTEGRATION = eglfs_viv | ||
10 | + | ||
11 | QMAKE_LIBS_EGL += -lEGL | ||
12 | QMAKE_LIBS_OPENGL_ES2 += -lEGL -lGLESv2 | ||
13 | QMAKE_LIBS_OPENVG += -lEGL -lOpenVG | ||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index 19dd991a..03748711 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -1,10 +1,13 @@ | |||
1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique | 1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique |
2 | # Copyright (C) 2016 O.S. Systems Software LTDA. | 2 | # Copyright (C) 2016 O.S. Systems Software LTDA. |
3 | # Copyright (C) 2016 Freescale Semiconductor | ||
3 | 4 | ||
4 | HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" | 5 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
5 | 6 | ||
6 | IMXGPU_imxgpu3d = "3d" | 7 | SRC_URI_append_imxgpu2d = "file://0014-Add-IMX-GPU-support.patch" |
7 | IMXGPU_imxgpu2d = "2d" | 8 | SRC_URI_append_imxgpu3d = " \ |
9 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'file://0015-Add-eglfs-to-IMX-GPU.patch', d)} \ | ||
10 | " | ||
8 | 11 | ||
9 | PACKAGECONFIG_GL_imxpxp = "gles2" | 12 | PACKAGECONFIG_GL_imxpxp = "gles2" |
10 | PACKAGECONFIG_GL_imxgpu3d = "gles2" | 13 | PACKAGECONFIG_GL_imxgpu3d = "gles2" |
@@ -15,23 +18,3 @@ QT_CONFIG_FLAGS_APPEND_imxpxp = "${@base_contains('DISTRO_FEATURES', 'x11', ' -n | |||
15 | QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" | 18 | QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" |
16 | QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 19 | QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
17 | QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" | 20 | QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" |
18 | |||
19 | do_configure_prepend_mx6() { | ||
20 | # adapt qmake.conf to our needs | ||
21 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | ||
22 | if test ${HAS_X11} -eq 0; then | ||
23 | if [ "${IMXGPU}" = "3d" ]; then | ||
24 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
25 | EGLFS_DEVICE_INTEGRATION = eglfs_viv | ||
26 | EOF | ||
27 | fi | ||
28 | fi | ||
29 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
30 | QMAKE_LIBS_EGL += -lEGL | ||
31 | QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL | ||
32 | QMAKE_LIBS_OPENVG += -lOpenVG -lEGL | ||
33 | |||
34 | load(qt_config) | ||
35 | |||
36 | EOF | ||
37 | } | ||