diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-23 16:48:28 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:14 -0300 |
commit | b9fd2a72b8703def084ce655b436e93330aedbc4 (patch) | |
tree | fe55765768372c5f39536547066f7c6a01cc40ff /dynamic-layers | |
parent | 32de02c23fb5b7f7fb95caac481d888c4894d52a (diff) | |
download | meta-freescale-b9fd2a72b8703def084ce655b436e93330aedbc4.tar.gz |
qtbase: Fix indentation of recipe
The recipe had a mix of indentation styles which makes it hard to
read. Those are changed to avoid tabs and rely on spaces only.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 33 |
1 files changed, 16 insertions, 17 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index a376a838..e0979bf5 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -15,13 +15,12 @@ QT_CONFIG_FLAGS_append_mx5 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-e | |||
15 | PACKAGECONFIG_GL_mx6q = "gles2" | 15 | PACKAGECONFIG_GL_mx6q = "gles2" |
16 | PACKAGECONFIG_GL_mx6dl = "gles2" | 16 | PACKAGECONFIG_GL_mx6dl = "gles2" |
17 | PACKAGECONFIG_GL_mx6sx = "gles2" | 17 | PACKAGECONFIG_GL_mx6sx = "gles2" |
18 | PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ | 18 | PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" |
19 | ' gl', '', d)}" | ||
20 | QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 19 | QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
21 | QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 20 | QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
22 | QT_CONFIG_FLAGS_append_mx6sx = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 21 | QT_CONFIG_FLAGS_append_mx6sx = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
23 | QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ | 22 | QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \ |
24 | ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" | 23 | ' -no-opengl -linuxfb -no-eglfs', d)}" |
25 | 24 | ||
26 | do_configure_prepend_mx5() { | 25 | do_configure_prepend_mx5() { |
27 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | 26 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf |
@@ -43,28 +42,28 @@ EOF | |||
43 | } | 42 | } |
44 | 43 | ||
45 | do_configure_prepend_mx6() { | 44 | do_configure_prepend_mx6() { |
46 | # adapt qmake.conf to our needs | 45 | # adapt qmake.conf to our needs |
47 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | 46 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf |
48 | if test ${HAS_X11} -eq 0; then | 47 | if test ${HAS_X11} -eq 0; then |
49 | if test ${IS_MX6SL} -eq 0; then | 48 | if test ${IS_MX6SL} -eq 0; then |
50 | 49 | ||
51 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 50 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
52 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp | 51 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp |
53 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 | 52 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 |
54 | EOF | 53 | EOF |
55 | else | 54 | else |
56 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 55 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
57 | IMX6_CFLAGS = -DLINUX=1 | 56 | IMX6_CFLAGS = -DLINUX=1 |
58 | EOF | 57 | EOF |
59 | fi | 58 | fi |
60 | # copy the hook in the mkspecs directory OE is using | 59 | # copy the hook in the mkspecs directory OE is using |
61 | cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ | 60 | cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ |
62 | else | 61 | else |
63 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 62 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
64 | IMX6_CFLAGS = -DLINUX=1 | 63 | IMX6_CFLAGS = -DLINUX=1 |
65 | EOF | 64 | EOF |
66 | fi | 65 | fi |
67 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 66 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
68 | QMAKE_LIBS_EGL += -lEGL | 67 | QMAKE_LIBS_EGL += -lEGL |
69 | QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL | 68 | QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL |
70 | QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL | 69 | QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL |