diff options
author | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-12-20 20:18:54 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2017-01-11 10:53:43 -0200 |
commit | 4a013ebf2e7e83cfabc127ad1008d475f60d8361 (patch) | |
tree | f560435f610f97bfe36b3a6387535abafbfa25b8 /dynamic-layers | |
parent | 8f2a95e1215656f7e54a156d7b41752d1244eb3d (diff) | |
download | meta-freescale-4a013ebf2e7e83cfabc127ad1008d475f60d8361.tar.gz |
usdpaa-apps: upgrade to SDK 2.0 GA-1611 release
The following changes are included:
* 8fe2e96 usdpaa_apps: Patch to add ipsecfwd config script for perf.
* 9d7f0fe usdpaa_apps: Patch to add lpm ipfwd config scripts for perf.
* f03552a Merge pull request #27 in SDK/usdpaa-apps from ~B06830/usdpaa-apps:bugfix/QUSDPA-869 to sdk-v2.0.x
* 88c1539 ipsecfwd, simple_proto: use DKP for MDHA split key generation
* 41d9630 usdpaa_apps: Patch to fix next header protocol in esp header
* a889294 usdpaa_apps: Patch to add ipfwd_config file for perf.
* 1ef1d53 Merge pull request #18 in SDK/usdpaa-apps from ~B06830/usdpaa-apps:bugfix/QUSDPA-838 to sdk-v2.0.x
* 6172983 usdpaa_apps: Patch to use default queue for functionality
* b992189 usdpa_app: Patch to add ls1046a support in standalone-env.
* 53851fb usdpaa_app: Patch to add fmc config for LS1046ARDB
* 1c7a501 simple_proto: add supplementary MBMS test vectors
* 2536748 simple_proto: MBMS test vector fixes
Signed-off-by: Ting Liu <ting.liu@nxp.com
Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb | 8 |
1 files changed, 5 insertions, 3 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb index 19edd4a3..c8de6932 100644 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb | |||
@@ -13,12 +13,12 @@ RDEPENDS_${PN}_append_b4860qds = " ipc-ust" | |||
13 | RDEPENDS_${PN}_append_b4420qds = " ipc-ust" | 13 | RDEPENDS_${PN}_append_b4420qds = " ipc-ust" |
14 | 14 | ||
15 | SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v2.0.x" | 15 | SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v2.0.x" |
16 | SRCREV = "835cbceb4f76de1b493fea5dbe43a90f516b6f35" | 16 | SRCREV = "8fe2e9669650d2f7ed26b43d860228ca0f7211a9" |
17 | 17 | ||
18 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |
19 | 19 | ||
20 | WRAP_ARCH ?= "${TARGET_ARCH}" | 20 | WRAP_ARCH ?= "${TARGET_ARCH}" |
21 | WRAP_ARCH_ls1043a = "arm64" | 21 | WRAP_ARCH_fsl-lsch2 = "arm64" |
22 | EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}" ARCH="${WRAP_ARCH}" EXTRA_LDFLAGS="${LDFLAGS}"' | 22 | EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}" ARCH="${WRAP_ARCH}" EXTRA_LDFLAGS="${LDFLAGS}"' |
23 | 23 | ||
24 | SOC ?= "P4080" | 24 | SOC ?= "P4080" |
@@ -27,6 +27,7 @@ SOC_t1 = "T1040" | |||
27 | SOC_t2 = "T2080" | 27 | SOC_t2 = "T2080" |
28 | SOC_t4 = "T4240" | 28 | SOC_t4 = "T4240" |
29 | SOC_ls1043a = "LS1043" | 29 | SOC_ls1043a = "LS1043" |
30 | SOC_ls1046a = "LS1043" | ||
30 | 31 | ||
31 | FMAN_VARIANT ?= "P4080" | 32 | FMAN_VARIANT ?= "P4080" |
32 | FMAN_VARIANT_b4 = "FMAN_V3H" | 33 | FMAN_VARIANT_b4 = "FMAN_V3H" |
@@ -34,6 +35,7 @@ FMAN_VARIANT_t1 = "FMAN_V3L" | |||
34 | FMAN_VARIANT_t2 = "FMAN_V3H" | 35 | FMAN_VARIANT_t2 = "FMAN_V3H" |
35 | FMAN_VARIANT_t4 = "FMAN_V3H" | 36 | FMAN_VARIANT_t4 = "FMAN_V3H" |
36 | FMAN_VARIANT_ls1043a = "LS1043" | 37 | FMAN_VARIANT_ls1043a = "LS1043" |
38 | FMAN_VARIANT_ls1046a = "LS1043" | ||
37 | 39 | ||
38 | do_compile_prepend () { | 40 | do_compile_prepend () { |
39 | export SOC=${SOC} | 41 | export SOC=${SOC} |
@@ -60,6 +62,6 @@ do_install () { | |||
60 | PARALLEL_MAKE_pn-${PN} = "" | 62 | PARALLEL_MAKE_pn-${PN} = "" |
61 | FILES_${PN} += "/root/SOURCE_THIS /usr/etc/" | 63 | FILES_${PN} += "/root/SOURCE_THIS /usr/etc/" |
62 | 64 | ||
63 | COMPATIBLE_MACHINE = "(qoriq-ppc|ls1043a)" | 65 | COMPATIBLE_MACHINE = "(qoriq-ppc|fsl-lsch2)" |
64 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" | 66 | PACKAGE_ARCH = "${MACHINE_SOCARCH}" |
65 | 67 | ||