diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2016-07-01 15:37:06 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-09-08 11:24:25 -0300 |
commit | 20a0f69f16d1b77ad65397c2197790af1701e6f1 (patch) | |
tree | 5f086ced04dfbd8caf18a3496b65edf8e03ae635 /dynamic-layers | |
parent | 6d5896ca62a5bdde057f9d50396c77bc9aedf123 (diff) | |
download | meta-freescale-20a0f69f16d1b77ad65397c2197790af1701e6f1.tar.gz |
qtbase: Refactor code to use the new overrides
The recipe has been reworked to use the 'imxgpu2d' and 'imxgpu3d'
feature overrides. While on that, the i.MX6SL specific code has been
reworked to used when only 2D GPU support is available.
Change-Id: I8fade08f54bd74e1dfd46b59711f6896c0bc7e6e
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers')
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 23 |
1 files changed, 11 insertions, 12 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index d336c0f9..3b998867 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -1,25 +1,24 @@ | |||
1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique | 1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique |
2 | # Copyright (C) 2016 O.S. Systems Software LTDA. | ||
2 | 3 | ||
3 | HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" | 4 | HAS_X11 = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" |
4 | 5 | ||
5 | IS_MX6SL = "0" | 6 | IMXGPU_imxgpu3d = "3d" |
6 | IS_MX6SL_mx6sl = "1" | 7 | IMXGPU_imxgpu2d = "2d" |
7 | 8 | ||
8 | PACKAGECONFIG_GL_mx6q = "gles2" | 9 | PACKAGECONFIG_GL_imxgpu3d = "gles2" |
9 | PACKAGECONFIG_GL_mx6dl = "gles2" | 10 | PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" |
10 | PACKAGECONFIG_GL_mx6sx = "gles2" | 11 | |
11 | PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' gl', '', d)}" | 12 | QT_CONFIG_FLAGS_APPEND = "" |
12 | QT_CONFIG_FLAGS_append_mx6q = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 13 | QT_CONFIG_FLAGS_APPEND_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" |
13 | QT_CONFIG_FLAGS_append_mx6dl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 14 | QT_CONFIG_FLAGS_APPEND_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
14 | QT_CONFIG_FLAGS_append_mx6sx = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 15 | QT_CONFIG_FLAGS_append = " ${QT_CONFIG_FLAGS_APPEND}" |
15 | QT_CONFIG_FLAGS_append_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', \ | ||
16 | ' -no-opengl -linuxfb -no-eglfs', d)}" | ||
17 | 16 | ||
18 | do_configure_prepend_mx6() { | 17 | do_configure_prepend_mx6() { |
19 | # adapt qmake.conf to our needs | 18 | # adapt qmake.conf to our needs |
20 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | 19 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf |
21 | if test ${HAS_X11} -eq 0; then | 20 | if test ${HAS_X11} -eq 0; then |
22 | if test ${IS_MX6SL} -eq 0; then | 21 | if [ "${IMXGPU}" = "3d"; then |
23 | 22 | ||
24 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 23 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
25 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 | 24 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 |