diff options
author | Ting Liu <ting.liu@nxp.com> | 2016-06-14 11:56:57 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-08-12 11:41:02 -0300 |
commit | 653c7b53dd8b9c6f5519fae1b4bc3c54fb2f94e9 (patch) | |
tree | 1a5050f4a000e6fd4e75e4546562da956cf104c6 /dynamic-layers | |
parent | 0f4fa5d14f8e0f27c73330ea5a2278e284a668ce (diff) | |
download | meta-freescale-653c7b53dd8b9c6f5519fae1b4bc3c54fb2f94e9.tar.gz |
usdpaa-apps: update to 835cbce
Changelog:
835cbce classifier_demo: Fix IPv4 table entry removal on LE platforms
2806cdc classifier_demo: Replace obsolete platform flags with FMan version flags
aca81f7 classifier_demo: Avoid using compile time symbols
abae100 IPSECFWD:Using correct SEC ERA version check for split key generation
5d8452a IPSECFWD: RTA changes for Authentication Key
d314b64 USDPAA-APPS: Ipsecfwd for ls1043 for sdk2.0
b3b078b ipsec_offload: Add debug tools
424fcbe reassembly_demo: Add support for running on LS1043A
ee4a5d2 fragmentation_demo: Add support for running on LS1043A
1dc24e8 classifier_demo: Add support for running on LS1043A
d3928a6 simple_crypto: remove unused variable
57131aa ls1043_config: Adding config for ls1043 fmc.
3cc1bbc USDPAA-APPS:reflector,ipfwd and lpm-ipfwd support for LS1043
e47d4d2 USDPAA-APPS support for LS1043(makefile and standalone-env)
9cd4030 libfslcrypto: enable apps compilation in out-of-tree mode
2c57883 simple_proto: fix AEAD descriptor creation function order of parameters
42f4d02 ipsecfwd: sync with FLIB
f80d93b simple_proto: add endianness support for protocols
9228309 simple_proto: fix IPSec test vector
028e14e libfslcrypto: workaround for CPU frequency
98d949e simple_crypto: fix SNOW_F8_F9 processing
23ce7f6 qman, libfslcrypto: export SG transformation functions
75a2010 simple_crypto: add swap option for block cipher descriptors
146c4e1 simple_crypto: fix endianness for preheader
8800996 libfslcrypto: support for dumping extended SG entries
49dd54f libfslcrypto: fix comparison for results < 4B
b54325f libfslcrypto: fix SGT handling endianness
97d3eb5 libfslcrypto: fix preheader bitfields
c5c35f8 Revert "ipsecfwd, simple_proto, simple_crypto: sync with FLIB"
07ed016 Revert "libfslcrypto: support for dumping extended SG entries"
2c9cd79 ipsecfwd, simple_proto, simple_crypto: sync with FLIB
126a441 ipsecfwd, simple_proto: flib sync - IPsec - fix PDB endianness
5493443 fix the inline function definition with gcc 5.x
9e08876 xfrm_km.c: use in6_* macros from glibc instead of kernel
Signed-off-by: Marian Chereji <marian.chereji@freescale.com>
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'dynamic-layers')
3 files changed, 9 insertions, 142 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch deleted file mode 100644 index 9f3d22cc..00000000 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch +++ /dev/null | |||
@@ -1,80 +0,0 @@ | |||
1 | From 2b308217d2811e5d1420d7ce6e18f77a992f52e9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <ting.liu@freescale.com> | ||
3 | Date: Tue, 22 Dec 2015 13:16:33 +0800 | ||
4 | Subject: [PATCH] fix the inline function definition with gcc 5.x | ||
5 | |||
6 | There are different semantics for inline functions for gcc-5.x compared to | ||
7 | previous gcc. Fix the following build error: | ||
8 | | dpa_classif_demo.c:(.text+0xeae): undefined reference to `crc64_hash_function' | ||
9 | | simple_crypto.c:(.text+0x5b8e): undefined reference to `get_num_of_buffers' | ||
10 | | simple_crypto.c:(.text+0x5b9a): undefined reference to `get_test_mode' | ||
11 | | simple_crypto.c:(.text+0x5baa): undefined reference to `get_num_of_cpus' | ||
12 | | simple_crypto.c:(.text+0x5bb2): undefined reference to `requires_authentication' | ||
13 | | simple_crypto.c:(.text+0x5bbe): undefined reference to `get_thread_barrier' | ||
14 | |||
15 | Upstream-Status: Pending | ||
16 | |||
17 | Signed-off-by: Ting Liu <ting.liu@freescale.com> | ||
18 | --- | ||
19 | lib/hash_table/fman_crc64_hash_func.h | 2 +- | ||
20 | src/simple_crypto/include/simple_crypto.h | 10 +++++----- | ||
21 | src/simple_proto/include/simple_proto.h | 10 +++++----- | ||
22 | 3 files changed, 11 insertions(+), 11 deletions(-) | ||
23 | |||
24 | diff --git a/lib/hash_table/fman_crc64_hash_func.h b/lib/hash_table/fman_crc64_hash_func.h | ||
25 | index 5095203..bdcf12b 100644 | ||
26 | --- a/lib/hash_table/fman_crc64_hash_func.h | ||
27 | +++ b/lib/hash_table/fman_crc64_hash_func.h | ||
28 | @@ -36,7 +36,7 @@ | ||
29 | #include <fsl_fman.h> | ||
30 | |||
31 | /* Hash function used by the hash table based on FMan CRC64 */ | ||
32 | -inline uint32_t crc64_hash_function(uint8_t *key, uint32_t size) | ||
33 | +static inline uint32_t crc64_hash_function(uint8_t *key, uint32_t size) | ||
34 | { | ||
35 | uint64_t hashval = 0; | ||
36 | hashval = fman_crc64_init(); | ||
37 | diff --git a/src/simple_crypto/include/simple_crypto.h b/src/simple_crypto/include/simple_crypto.h | ||
38 | index bae3460..46ea176 100644 | ||
39 | --- a/src/simple_crypto/include/simple_crypto.h | ||
40 | +++ b/src/simple_crypto/include/simple_crypto.h | ||
41 | @@ -123,10 +123,10 @@ static int validate_test_set(struct test_param crypto_info); | ||
42 | void set_crypto_cbs(struct test_cb *crypto_cb, struct test_param crypto_info); | ||
43 | inline int get_num_of_iterations(void *stuff); | ||
44 | void set_num_of_iterations(void *stuff, unsigned int itr_num); | ||
45 | -inline int get_num_of_buffers(void *stuff); | ||
46 | -inline enum test_mode get_test_mode(void *stuff); | ||
47 | -inline uint8_t requires_authentication(void *); | ||
48 | -inline long get_num_of_cpus(void); | ||
49 | -inline pthread_barrier_t *get_thread_barrier(void); | ||
50 | +static inline int get_num_of_buffers(void *stuff); | ||
51 | +static inline enum test_mode get_test_mode(void *stuff); | ||
52 | +static inline uint8_t requires_authentication(void *); | ||
53 | +static inline long get_num_of_cpus(void); | ||
54 | +static inline pthread_barrier_t *get_thread_barrier(void); | ||
55 | |||
56 | #endif /* __SIMPLE_CRYPTO_H */ | ||
57 | diff --git a/src/simple_proto/include/simple_proto.h b/src/simple_proto/include/simple_proto.h | ||
58 | index d413e70..ce0e842 100644 | ||
59 | --- a/src/simple_proto/include/simple_proto.h | ||
60 | +++ b/src/simple_proto/include/simple_proto.h | ||
61 | @@ -83,11 +83,11 @@ struct protocol_info *(*register_protocol[])(void) = { | ||
62 | static void set_crypto_cbs(struct test_cb *crypto_cb); | ||
63 | int get_num_of_iterations(void *params); | ||
64 | void set_num_of_iterations(void *params, unsigned int itr_num); | ||
65 | -inline int get_num_of_buffers(void *params); | ||
66 | -inline enum test_mode get_test_mode(void *params); | ||
67 | -inline uint8_t requires_authentication(void *); | ||
68 | -inline long get_num_of_cpus(void); | ||
69 | -inline pthread_barrier_t *get_thread_barrier(void); | ||
70 | +static inline int get_num_of_buffers(void *params); | ||
71 | +static inline enum test_mode get_test_mode(void *params); | ||
72 | +static inline uint8_t requires_authentication(void *); | ||
73 | +static inline long get_num_of_cpus(void); | ||
74 | +static inline pthread_barrier_t *get_thread_barrier(void); | ||
75 | int register_modules(void); | ||
76 | void unregister_modules(void); | ||
77 | |||
78 | -- | ||
79 | 1.9.2 | ||
80 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch deleted file mode 100644 index c6d35f00..00000000 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch +++ /dev/null | |||
@@ -1,49 +0,0 @@ | |||
1 | From 1e1e8d74db98faed57a5a62788e1226801661e0e Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <ting.liu@freescale.com> | ||
3 | Date: Tue, 22 Dec 2015 23:37:49 +0800 | ||
4 | Subject: [PATCH] xfrm_km.c: use in6_* macros from glibc instead of kernel | ||
5 | |||
6 | Both glibc and the kernel have in6_* macros definition. Use the one from glibc. | ||
7 | Kernel headers will check for previous libc definitions by including | ||
8 | include/linux/libc-compat.h. | ||
9 | |||
10 | Fix the below build error: | ||
11 | | [CC] xfrm_km.c (bin:srio_ipsec_offload) | ||
12 | | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0, | ||
13 | | from src/srio_ipsec_offload/xfrm_km.c:46: | ||
14 | | .../usr/include/netinet/in.h:99:5: error: expected identifier before numeric constant | ||
15 | | IPPROTO_HOPOPTS = 0, /* IPv6 Hop-by-Hop options. */ | ||
16 | | ^ | ||
17 | | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/netinet/ip.h:24:0, | ||
18 | | from src/srio_ipsec_offload/xfrm_km.c:52: | ||
19 | | .../tmp/sysroots/b4860qds-64b/usr/include/netinet/in.h:209:8: error: redefinition of 'struct in6_addr' | ||
20 | | struct in6_addr | ||
21 | | ^ | ||
22 | | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0, | ||
23 | | from src/srio_ipsec_offload/xfrm_km.c:46: | ||
24 | | .../tmp/sysroots/b4860qds-64b/usr/include/linux/in6.h:32:8: note: originally defined here | ||
25 | | struct in6_addr { | ||
26 | | ^ | ||
27 | |||
28 | Upstream-Status: Pending | ||
29 | |||
30 | Signed-off-by: Ting Liu <ting.liu@freescale.com> | ||
31 | --- | ||
32 | src/srio_ipsec_offload/xfrm_km.c | 1 + | ||
33 | 1 file changed, 1 insertion(+) | ||
34 | |||
35 | diff --git a/src/srio_ipsec_offload/xfrm_km.c b/src/srio_ipsec_offload/xfrm_km.c | ||
36 | index df23fd1..d69aafa 100644 | ||
37 | --- a/src/srio_ipsec_offload/xfrm_km.c | ||
38 | +++ b/src/srio_ipsec_offload/xfrm_km.c | ||
39 | @@ -42,6 +42,7 @@ | ||
40 | #include <linux/types.h> | ||
41 | #include <sys/socket.h> | ||
42 | #include <sys/ioctl.h> | ||
43 | +#include <netinet/in.h> | ||
44 | #include <linux/netlink.h> | ||
45 | #include <linux/xfrm.h> | ||
46 | #include <sched.h> | ||
47 | -- | ||
48 | 1.9.2 | ||
49 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb index 1a19d1e8..d9673128 100644 --- a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb | |||
@@ -14,30 +14,28 @@ RDEPENDS_${PN} = "libgcc bash" | |||
14 | RDEPENDS_${PN}_append_b4860qds = " ipc-ust" | 14 | RDEPENDS_${PN}_append_b4860qds = " ipc-ust" |
15 | RDEPENDS_${PN}_append_b4420qds = " ipc-ust" | 15 | RDEPENDS_${PN}_append_b4420qds = " ipc-ust" |
16 | 16 | ||
17 | SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v1.9.x \ | 17 | SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v2.0.x" |
18 | file://fix-the-inline-function-definition-with-gcc-5.x.patch \ | 18 | SRCREV = "835cbceb4f76de1b493fea5dbe43a90f516b6f35" |
19 | file://xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch \ | ||
20 | " | ||
21 | SRCREV = "1d9418af04990289bec72cd43a9385690523fcdb" | ||
22 | 19 | ||
23 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
24 | 21 | ||
25 | EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"' | 22 | WRAP_ARCH ?= "${TARGET_ARCH}" |
26 | export ARCH="${TARGET_ARCH}" | 23 | WRAP_ARCH_ls1043ardb = "arm64" |
24 | EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}" ARCH="${WRAP_ARCH}"' | ||
27 | 25 | ||
28 | SOC ?= "P4080" | 26 | SOC ?= "P4080" |
29 | SOC_b4 = "B4860" | 27 | SOC_b4 = "B4860" |
30 | SOC_t1 = "T1040" | 28 | SOC_t1 = "T1040" |
31 | SOC_t2 = "T2080" | 29 | SOC_t2 = "T2080" |
32 | SOC_t4 = "T4240" | 30 | SOC_t4 = "T4240" |
33 | SOC_p1023rdb = "P1023" | 31 | SOC_ls1043ardb = "LS1043" |
34 | 32 | ||
35 | FMAN_VARIANT ?= "P4080" | 33 | FMAN_VARIANT ?= "P4080" |
36 | FMAN_VARIANT_b4 = "FMAN_V3H" | 34 | FMAN_VARIANT_b4 = "FMAN_V3H" |
37 | FMAN_VARIANT_t1 = "FMAN_V3L" | 35 | FMAN_VARIANT_t1 = "FMAN_V3L" |
38 | FMAN_VARIANT_t2 = "FMAN_V3H" | 36 | FMAN_VARIANT_t2 = "FMAN_V3H" |
39 | FMAN_VARIANT_t4 = "FMAN_V3H" | 37 | FMAN_VARIANT_t4 = "FMAN_V3H" |
40 | FMAN_VARIANT_p1023rdb = "P1023" | 38 | FMAN_VARIANT_ls1043ardb = "LS1043" |
41 | 39 | ||
42 | do_compile_prepend () { | 40 | do_compile_prepend () { |
43 | export SOC=${SOC} | 41 | export SOC=${SOC} |
@@ -58,11 +56,9 @@ do_compile_prepend () { | |||
58 | 56 | ||
59 | do_install () { | 57 | do_install () { |
60 | export SOC=${SOC} | 58 | export SOC=${SOC} |
61 | oe_runmake install DESTDIR=${D} | 59 | oe_runmake install LIBDIR=${BASELIB} DESTDIR=${D} |
62 | } | 60 | } |
63 | 61 | ||
64 | PARALLEL_MAKE_pn-${PN} = "" | 62 | PARALLEL_MAKE_pn-${PN} = "" |
65 | FILES_${PN} += "/root/SOURCE_THIS /usr/etc/" | 63 | FILES_${PN} += "/root/SOURCE_THIS /usr/etc/" |
66 | 64 | COMPATIBLE_MACHINE = "(qoriq-ppc|ls1043a)" | |
67 | COMPATIBLE_HOST_qoriq-ppc = ".*" | ||
68 | COMPATIBLE_HOST ?= "(none)" | ||