diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-15 17:21:16 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2015-07-16 15:01:29 -0300 |
commit | ca38cdc4de1143cf6b7af76e9426ecf31f0922f0 (patch) | |
tree | 01db34465457c4b22036f27dba53d55f01ef6d03 /dynamic-layers/qt5-layer/recipes-qt | |
parent | b6e2300960729d67720e1e626051999ca7a7009f (diff) | |
download | meta-freescale-ca38cdc4de1143cf6b7af76e9426ecf31f0922f0.tar.gz |
Move external layer's specific changes for 'dynamic-layers' subdir
The external layer's specific changes are now in the 'dynamic-layers'
subdirectory. This approach ease the identification of layer specific
recipes and extensions as all those are more visible isolated of the
main layer components.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/qt5-layer/recipes-qt')
4 files changed, 148 insertions, 0 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch new file mode 100644 index 00000000..b0be292d --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase/Force_egl_visual_ID_33.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Workaround EGL initialization failure due visual mismatch | ||
2 | |||
3 | Error: | ||
4 | |||
5 | Warning: EGL suggested using X Visual ID 33 (RGB888) for EGL config 28 (RGB444), but this is incompatable | ||
6 | Unable to find an X11 visual which matches EGL config 28 | ||
7 | Could not initialize EGL | ||
8 | Aborted | ||
9 | |||
10 | Upstream-Status: Inappropriate [workaround] | ||
11 | |||
12 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
13 | |||
14 | diff -Naur qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp | ||
15 | --- qtbase-opensource-src-5.1.1_original/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:08:42.163895341 -0800 | ||
16 | +++ qtbase-opensource-src-5.1.1/src/platformsupport/eglconvenience/qxlibeglintegration.cpp 2013-12-25 19:09:37.207893799 -0800 | ||
17 | @@ -180,5 +180,5 @@ | ||
18 | } | ||
19 | |||
20 | qWarning("Unable to find an X11 visual which matches EGL config %d", configId); | ||
21 | - return (VisualID)0; | ||
22 | + return (VisualID)33; | ||
23 | } | ||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend new file mode 100644 index 00000000..a376a838 --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -0,0 +1,79 @@ | |||
1 | # Copyright (C) 2013 Eric Bénard - Eukréa Electromatique | ||
2 | |||
3 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
4 | |||
5 | SRC_URI += "file://Force_egl_visual_ID_33.patch" | ||
6 | |||
7 | HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" | ||
8 | |||
9 | IS_MX6SL = "0" | ||
10 | IS_MX6SL_mx6sl = "1" | ||
11 | |||
12 | PACKAGECONFIG_GL_mx5 = "gles2" | ||
13 | QT_CONFIG_FLAGS_append_mx5 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | ||
14 | |||
15 | PACKAGECONFIG_GL_mx6q = "gles2" | ||
16 | PACKAGECONFIG_GL_mx6dl = "gles2" | ||
17 | PACKAGECONFIG_GL_mx6sx = "gles2" | ||
18 | PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
19 | ' gl', '', d)}" | ||
20 | QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | ||
21 | QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | ||
22 | QT_CONFIG_FLAGS_append_mx6sx = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | ||
23 | QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
24 | ' -no-eglfs', ' -no-opengl -linuxfb -no-eglfs', d)}" | ||
25 | |||
26 | do_configure_prepend_mx5() { | ||
27 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | ||
28 | |||
29 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
30 | IMX5_CFLAGS = -D_LINUX=1 | ||
31 | QMAKE_LIBS_EGL += -lEGL | ||
32 | QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL | ||
33 | QMAKE_LIBS_OPENVG += -lOpenVG -lEGL | ||
34 | |||
35 | QMAKE_CFLAGS_RELEASE += \$\$IMX5_CFLAGS | ||
36 | QMAKE_CXXFLAGS_RELEASE += \$\$IMX5_CFLAGS | ||
37 | QMAKE_CFLAGS_DEBUG += \$\$IMX5_CFLAGS | ||
38 | QMAKE_CXXFLAGS_DEBUG += \$\$IMX5_CFLAGS | ||
39 | |||
40 | load(qt_config) | ||
41 | |||
42 | EOF | ||
43 | } | ||
44 | |||
45 | do_configure_prepend_mx6() { | ||
46 | # adapt qmake.conf to our needs | ||
47 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | ||
48 | if test ${HAS_X11} -eq 0; then | ||
49 | if test ${IS_MX6SL} -eq 0; then | ||
50 | |||
51 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
52 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp | ||
53 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 | ||
54 | EOF | ||
55 | else | ||
56 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
57 | IMX6_CFLAGS = -DLINUX=1 | ||
58 | EOF | ||
59 | fi | ||
60 | # copy the hook in the mkspecs directory OE is using | ||
61 | cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ | ||
62 | else | ||
63 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
64 | IMX6_CFLAGS = -DLINUX=1 | ||
65 | EOF | ||
66 | fi | ||
67 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
68 | QMAKE_LIBS_EGL += -lEGL | ||
69 | QMAKE_LIBS_OPENGL_ES2 += -lGLESv2 -lEGL -lGAL | ||
70 | QMAKE_LIBS_OPENVG += -lOpenVG -lEGL -lGAL | ||
71 | QMAKE_CFLAGS_RELEASE += \$\$IMX6_CFLAGS | ||
72 | QMAKE_CXXFLAGS_RELEASE += \$\$IMX6_CFLAGS | ||
73 | QMAKE_CFLAGS_DEBUG += \$\$IMX6_CFLAGS | ||
74 | QMAKE_CXXFLAGS_DEBUG += \$\$IMX6_CFLAGS | ||
75 | |||
76 | load(qt_config) | ||
77 | |||
78 | EOF | ||
79 | } | ||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch new file mode 100644 index 00000000..80e55c7f --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit/0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 66dab98c3f42eb70a4c6761a8694e374b8578e99 Mon Sep 17 00:00:00 2001 | ||
2 | From: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
3 | Date: Thu, 8 May 2014 09:27:04 -0700 | ||
4 | Subject: [PATCH] Fix to match the uniform precision qualifiers in vertex and | ||
5 | fragment shaders | ||
6 | |||
7 | When the vertex and fragment shaders are linked together, then they will | ||
8 | share a single global uniform name space. Hence, types and precisions of | ||
9 | uniforms with the same name must match across all shaders that are linked | ||
10 | into a single executable. | ||
11 | |||
12 | As per GLSL_ES_Specification_3.00.3.pdf | ||
13 | Page 124 12.3 Numeric Precision | ||
14 | The fragment language has no default precision qualifier for floating point types. | ||
15 | Hence for float, floating point vector and matrix variable declarations, either | ||
16 | the declaration must include a precision qualifier or the default float | ||
17 | precision must have been previously declared. | ||
18 | |||
19 | Upstream-Status: Submitted [https://bugs.webkit.org/show_bug.cgi?id=124653#c9] | ||
20 | |||
21 | Change-Id: I4eb3363b3bca8bc3c839212ec7c966201a3e65e2 | ||
22 | Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@freescale.com> | ||
23 | --- | ||
24 | Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | 2 +- | ||
25 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
26 | |||
27 | diff --git a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | ||
28 | index f4b9a7e..7e991bf 100644 | ||
29 | --- a/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | ||
30 | +++ b/Source/WebCore/platform/graphics/texmap/TextureMapperShaderProgram.cpp | ||
31 | @@ -208,7 +208,7 @@ static const char* fragmentTemplate = | ||
32 | ANTIALIASING_TEX_COORD_DIRECTIVE | ||
33 | BLUR_CONSTANTS | ||
34 | STRINGIFY( | ||
35 | - precision mediump float; | ||
36 | + precision highp float; | ||
37 | uniform SamplerType s_sampler; | ||
38 | uniform sampler2D s_contentTexture; | ||
39 | uniform float u_opacity; | ||
40 | -- | ||
41 | 1.9.1 | ||
42 | |||
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend new file mode 100644 index 00000000..5d961e64 --- /dev/null +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwebkit_%.bbappend | |||
@@ -0,0 +1,4 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | SRC_URI += "file://0001-Fix-to-match-the-uniform-precision-qualifiers-in-ver.patch" | ||
4 | |||