diff options
author | Andreas Müller <schnitzeltony@googlemail.com> | 2015-09-13 22:36:21 +0200 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-04-19 15:03:19 -0300 |
commit | 574898eb75e55aaaf87157e4ca12e81cbc85cd81 (patch) | |
tree | bdb1c95365f832091f41ed1cef826f0b7fbcb8f7 /dynamic-layers/qt5-layer/recipes-qt/qt5 | |
parent | 0f0e7777efba2e2ac8d89d2c26e1155cb5a3cb48 (diff) | |
download | meta-freescale-574898eb75e55aaaf87157e4ca12e81cbc85cd81.tar.gz |
qtbase: follow 5.5 platform configuration style
This one comes up when building for non-x11 / wayland.
for further details see qtbase
commit d04c3d2079e0df79592128a67e115ecb90b08454
Author: Laszlo Agocs <laszlo.agocs@theqtcompany.com>
Date: Mon Mar 2 16:09:22 2015 +0100
eglfs: Pluginize RPi, iMX6 and Mali backends
eglfs does not depend on the device makespecs anymore when it comes to these device
integration backends (hooks). Instead, backends are autodetected by configure.
The name of the preferred plugin is still set in the device makespecs. This
is optional. When not set and there is more than one plugin present in the system,
the environment variable QT_QPA_EGLFS_INTEGRATION will have to be set at runtime.
In the absence of that, the order is undefined.
Change-Id: Ie1ced2c9aa1beff2adb13b4fdea7c499cb5a6aab
Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@theqtcompany.com>
Reviewed-by: Andy Nichols <andy.nichols@theqtcompany.com>
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/qt5-layer/recipes-qt/qt5')
-rw-r--r-- | dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 4 |
1 files changed, 1 insertions, 3 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index 6570702d..f157c4dc 100644 --- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -22,16 +22,14 @@ do_configure_prepend_mx6() { | |||
22 | if test ${IS_MX6SL} -eq 0; then | 22 | if test ${IS_MX6SL} -eq 0; then |
23 | 23 | ||
24 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 24 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
25 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp | ||
26 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 | 25 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 |
26 | EGLFS_DEVICE_INTEGRATION = eglfs_viv | ||
27 | EOF | 27 | EOF |
28 | else | 28 | else |
29 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 29 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
30 | IMX6_CFLAGS = -DLINUX=1 | 30 | IMX6_CFLAGS = -DLINUX=1 |
31 | EOF | 31 | EOF |
32 | fi | 32 | fi |
33 | # copy the hook in the mkspecs directory OE is using | ||
34 | cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ | ||
35 | else | 33 | else |
36 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 34 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
37 | IMX6_CFLAGS = -DLINUX=1 | 35 | IMX6_CFLAGS = -DLINUX=1 |