diff options
author | Zhenhua Luo <zhenhua.luo@nxp.com> | 2016-06-14 11:54:47 +0800 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2016-06-23 10:49:15 -0300 |
commit | 21b9f1e354d9df1b9a7381d4c11de42157eff2c0 (patch) | |
tree | d09472fbe26c75a05893654a2ec530898bc67532 /dynamic-layers/openembedded-layer | |
parent | 84bda66788bb25b9c100c5384ad296450aaabe22 (diff) | |
download | meta-freescale-21b9f1e354d9df1b9a7381d4c11de42157eff2c0.tar.gz |
Move some recipes to dynamic-layers folder
The following packages depend on extend Yocto community layers, move related
recipes to dynamic-layers.
* ipsec-demo asf fmc usdpaa-apps web-sysmon
Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com>
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
5 files changed, 284 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb new file mode 100644 index 00000000..d54b8454 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/fmc/fmc_git.bb | |||
@@ -0,0 +1,52 @@ | |||
1 | DESCRIPTION = "Frame Manager Configuration tool" | ||
2 | SECTION = "fmc" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a504ab5a8ff235e67c7301214749346c" | ||
5 | |||
6 | PR = "r2" | ||
7 | |||
8 | SRC_URI = "git://git.freescale.com/ppc/sdk/fmc.git;branch=sdk-v1.9.x" | ||
9 | SRCREV = "a079d2c844edd85dff85a317a63198e7988bcd09" | ||
10 | |||
11 | DEPENDS = "libxml2 fmlib tclap" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | COMPATIBLE_HOST_qoriq-ppc = ".*" | ||
15 | COMPATIBLE_HOST ?= "(none)" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | EXTRA_OEMAKE = 'FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \ | ||
20 | FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \ | ||
21 | TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' | ||
22 | EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \ | ||
23 | FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \ | ||
24 | TCLAP_HEADER_PATH="${STAGING_INCDIR}" ' | ||
25 | |||
26 | PARALLEL_MAKE = "" | ||
27 | |||
28 | EXTRA_OEMAKE_PLATFORM ?= "" | ||
29 | EXTRA_OEMAKE_PLATFORM_b4 = "b4860qds" | ||
30 | EXTRA_OEMAKE_PLATFORM_t2 = "b4860qds" | ||
31 | EXTRA_OEMAKE_PLATFORM_t4 = "b4860qds" | ||
32 | EXTRA_OEMAKE_PLATFORM_t1 = "t1040qds" | ||
33 | |||
34 | do_compile () { | ||
35 | oe_runmake MACHINE=${EXTRA_OEMAKE_PLATFORM} -C source | ||
36 | } | ||
37 | |||
38 | do_install () { | ||
39 | install -d ${D}/${bindir} | ||
40 | install -m 755 ${S}/source/fmc ${D}/${bindir}/fmc | ||
41 | |||
42 | install -d ${D}/etc/fmc/config | ||
43 | install -m 644 ${S}/etc/fmc/config/hxs_pdl_v3.xml ${D}/etc/fmc/config | ||
44 | |||
45 | install -d ${D}/${includedir}/fmc | ||
46 | install ${S}/source/fmc.h ${D}/${includedir}/fmc | ||
47 | |||
48 | install -d ${D}/${libdir} | ||
49 | install ${S}/source/libfmc.a ${D}/${libdir} | ||
50 | } | ||
51 | |||
52 | BBCLASSEXTEND = "native" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch new file mode 100644 index 00000000..9f3d22cc --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/fix-the-inline-function-definition-with-gcc-5.x.patch | |||
@@ -0,0 +1,80 @@ | |||
1 | From 2b308217d2811e5d1420d7ce6e18f77a992f52e9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <ting.liu@freescale.com> | ||
3 | Date: Tue, 22 Dec 2015 13:16:33 +0800 | ||
4 | Subject: [PATCH] fix the inline function definition with gcc 5.x | ||
5 | |||
6 | There are different semantics for inline functions for gcc-5.x compared to | ||
7 | previous gcc. Fix the following build error: | ||
8 | | dpa_classif_demo.c:(.text+0xeae): undefined reference to `crc64_hash_function' | ||
9 | | simple_crypto.c:(.text+0x5b8e): undefined reference to `get_num_of_buffers' | ||
10 | | simple_crypto.c:(.text+0x5b9a): undefined reference to `get_test_mode' | ||
11 | | simple_crypto.c:(.text+0x5baa): undefined reference to `get_num_of_cpus' | ||
12 | | simple_crypto.c:(.text+0x5bb2): undefined reference to `requires_authentication' | ||
13 | | simple_crypto.c:(.text+0x5bbe): undefined reference to `get_thread_barrier' | ||
14 | |||
15 | Upstream-Status: Pending | ||
16 | |||
17 | Signed-off-by: Ting Liu <ting.liu@freescale.com> | ||
18 | --- | ||
19 | lib/hash_table/fman_crc64_hash_func.h | 2 +- | ||
20 | src/simple_crypto/include/simple_crypto.h | 10 +++++----- | ||
21 | src/simple_proto/include/simple_proto.h | 10 +++++----- | ||
22 | 3 files changed, 11 insertions(+), 11 deletions(-) | ||
23 | |||
24 | diff --git a/lib/hash_table/fman_crc64_hash_func.h b/lib/hash_table/fman_crc64_hash_func.h | ||
25 | index 5095203..bdcf12b 100644 | ||
26 | --- a/lib/hash_table/fman_crc64_hash_func.h | ||
27 | +++ b/lib/hash_table/fman_crc64_hash_func.h | ||
28 | @@ -36,7 +36,7 @@ | ||
29 | #include <fsl_fman.h> | ||
30 | |||
31 | /* Hash function used by the hash table based on FMan CRC64 */ | ||
32 | -inline uint32_t crc64_hash_function(uint8_t *key, uint32_t size) | ||
33 | +static inline uint32_t crc64_hash_function(uint8_t *key, uint32_t size) | ||
34 | { | ||
35 | uint64_t hashval = 0; | ||
36 | hashval = fman_crc64_init(); | ||
37 | diff --git a/src/simple_crypto/include/simple_crypto.h b/src/simple_crypto/include/simple_crypto.h | ||
38 | index bae3460..46ea176 100644 | ||
39 | --- a/src/simple_crypto/include/simple_crypto.h | ||
40 | +++ b/src/simple_crypto/include/simple_crypto.h | ||
41 | @@ -123,10 +123,10 @@ static int validate_test_set(struct test_param crypto_info); | ||
42 | void set_crypto_cbs(struct test_cb *crypto_cb, struct test_param crypto_info); | ||
43 | inline int get_num_of_iterations(void *stuff); | ||
44 | void set_num_of_iterations(void *stuff, unsigned int itr_num); | ||
45 | -inline int get_num_of_buffers(void *stuff); | ||
46 | -inline enum test_mode get_test_mode(void *stuff); | ||
47 | -inline uint8_t requires_authentication(void *); | ||
48 | -inline long get_num_of_cpus(void); | ||
49 | -inline pthread_barrier_t *get_thread_barrier(void); | ||
50 | +static inline int get_num_of_buffers(void *stuff); | ||
51 | +static inline enum test_mode get_test_mode(void *stuff); | ||
52 | +static inline uint8_t requires_authentication(void *); | ||
53 | +static inline long get_num_of_cpus(void); | ||
54 | +static inline pthread_barrier_t *get_thread_barrier(void); | ||
55 | |||
56 | #endif /* __SIMPLE_CRYPTO_H */ | ||
57 | diff --git a/src/simple_proto/include/simple_proto.h b/src/simple_proto/include/simple_proto.h | ||
58 | index d413e70..ce0e842 100644 | ||
59 | --- a/src/simple_proto/include/simple_proto.h | ||
60 | +++ b/src/simple_proto/include/simple_proto.h | ||
61 | @@ -83,11 +83,11 @@ struct protocol_info *(*register_protocol[])(void) = { | ||
62 | static void set_crypto_cbs(struct test_cb *crypto_cb); | ||
63 | int get_num_of_iterations(void *params); | ||
64 | void set_num_of_iterations(void *params, unsigned int itr_num); | ||
65 | -inline int get_num_of_buffers(void *params); | ||
66 | -inline enum test_mode get_test_mode(void *params); | ||
67 | -inline uint8_t requires_authentication(void *); | ||
68 | -inline long get_num_of_cpus(void); | ||
69 | -inline pthread_barrier_t *get_thread_barrier(void); | ||
70 | +static inline int get_num_of_buffers(void *params); | ||
71 | +static inline enum test_mode get_test_mode(void *params); | ||
72 | +static inline uint8_t requires_authentication(void *); | ||
73 | +static inline long get_num_of_cpus(void); | ||
74 | +static inline pthread_barrier_t *get_thread_barrier(void); | ||
75 | int register_modules(void); | ||
76 | void unregister_modules(void); | ||
77 | |||
78 | -- | ||
79 | 1.9.2 | ||
80 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch new file mode 100644 index 00000000..c6d35f00 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps/xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From 1e1e8d74db98faed57a5a62788e1226801661e0e Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <ting.liu@freescale.com> | ||
3 | Date: Tue, 22 Dec 2015 23:37:49 +0800 | ||
4 | Subject: [PATCH] xfrm_km.c: use in6_* macros from glibc instead of kernel | ||
5 | |||
6 | Both glibc and the kernel have in6_* macros definition. Use the one from glibc. | ||
7 | Kernel headers will check for previous libc definitions by including | ||
8 | include/linux/libc-compat.h. | ||
9 | |||
10 | Fix the below build error: | ||
11 | | [CC] xfrm_km.c (bin:srio_ipsec_offload) | ||
12 | | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0, | ||
13 | | from src/srio_ipsec_offload/xfrm_km.c:46: | ||
14 | | .../usr/include/netinet/in.h:99:5: error: expected identifier before numeric constant | ||
15 | | IPPROTO_HOPOPTS = 0, /* IPv6 Hop-by-Hop options. */ | ||
16 | | ^ | ||
17 | | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/netinet/ip.h:24:0, | ||
18 | | from src/srio_ipsec_offload/xfrm_km.c:52: | ||
19 | | .../tmp/sysroots/b4860qds-64b/usr/include/netinet/in.h:209:8: error: redefinition of 'struct in6_addr' | ||
20 | | struct in6_addr | ||
21 | | ^ | ||
22 | | In file included from .../tmp/sysroots/b4860qds-64b/usr/include/linux/xfrm.h:4:0, | ||
23 | | from src/srio_ipsec_offload/xfrm_km.c:46: | ||
24 | | .../tmp/sysroots/b4860qds-64b/usr/include/linux/in6.h:32:8: note: originally defined here | ||
25 | | struct in6_addr { | ||
26 | | ^ | ||
27 | |||
28 | Upstream-Status: Pending | ||
29 | |||
30 | Signed-off-by: Ting Liu <ting.liu@freescale.com> | ||
31 | --- | ||
32 | src/srio_ipsec_offload/xfrm_km.c | 1 + | ||
33 | 1 file changed, 1 insertion(+) | ||
34 | |||
35 | diff --git a/src/srio_ipsec_offload/xfrm_km.c b/src/srio_ipsec_offload/xfrm_km.c | ||
36 | index df23fd1..d69aafa 100644 | ||
37 | --- a/src/srio_ipsec_offload/xfrm_km.c | ||
38 | +++ b/src/srio_ipsec_offload/xfrm_km.c | ||
39 | @@ -42,6 +42,7 @@ | ||
40 | #include <linux/types.h> | ||
41 | #include <sys/socket.h> | ||
42 | #include <sys/ioctl.h> | ||
43 | +#include <netinet/in.h> | ||
44 | #include <linux/netlink.h> | ||
45 | #include <linux/xfrm.h> | ||
46 | #include <sched.h> | ||
47 | -- | ||
48 | 1.9.2 | ||
49 | |||
diff --git a/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb new file mode 100644 index 00000000..1a19d1e8 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-dpaa/usdpaa-apps/usdpaa-apps_git.bb | |||
@@ -0,0 +1,68 @@ | |||
1 | DESCRIPTION = "User-Space Data-Path Acceleration Architecture Demo Applications" | ||
2 | LICENSE = "BSD & GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://Makefile;endline=30;md5=d2a5d894118910d49993347f3f6e0f1e" | ||
4 | |||
5 | inherit pkgconfig | ||
6 | |||
7 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
8 | |||
9 | DEPENDS = "libxml2 libedit ncurses readline fmc usdpaa dpa-offload libnl" | ||
10 | DEPENDS_append_b4860qds = " ipc-ust" | ||
11 | DEPENDS_append_b4420qds = " ipc-ust" | ||
12 | |||
13 | RDEPENDS_${PN} = "libgcc bash" | ||
14 | RDEPENDS_${PN}_append_b4860qds = " ipc-ust" | ||
15 | RDEPENDS_${PN}_append_b4420qds = " ipc-ust" | ||
16 | |||
17 | SRC_URI = "git://git.freescale.com/ppc/sdk/usdpaa/usdpaa-apps.git;branch=sdk-v1.9.x \ | ||
18 | file://fix-the-inline-function-definition-with-gcc-5.x.patch \ | ||
19 | file://xfrm_km.c-use-in6_-macros-from-glibc-instead-of-kern.patch \ | ||
20 | " | ||
21 | SRCREV = "1d9418af04990289bec72cd43a9385690523fcdb" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | EXTRA_OEMAKE = 'CC="${CC}" LD="${LD}" AR="${AR}"' | ||
26 | export ARCH="${TARGET_ARCH}" | ||
27 | |||
28 | SOC ?= "P4080" | ||
29 | SOC_b4 = "B4860" | ||
30 | SOC_t1 = "T1040" | ||
31 | SOC_t2 = "T2080" | ||
32 | SOC_t4 = "T4240" | ||
33 | SOC_p1023rdb = "P1023" | ||
34 | |||
35 | FMAN_VARIANT ?= "P4080" | ||
36 | FMAN_VARIANT_b4 = "FMAN_V3H" | ||
37 | FMAN_VARIANT_t1 = "FMAN_V3L" | ||
38 | FMAN_VARIANT_t2 = "FMAN_V3H" | ||
39 | FMAN_VARIANT_t4 = "FMAN_V3H" | ||
40 | FMAN_VARIANT_p1023rdb = "P1023" | ||
41 | |||
42 | do_compile_prepend () { | ||
43 | export SOC=${SOC} | ||
44 | export FMC_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmc" | ||
45 | export FMLIB_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/fmd \ | ||
46 | -I ${STAGING_INCDIR}/fmd/Peripherals \ | ||
47 | -I ${STAGING_INCDIR}/fmd/integrations \ | ||
48 | -D${FMAN_VARIANT}" | ||
49 | export USDPAA_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/usdpaa" | ||
50 | export DPAOFFLOAD_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/dpa-offload" | ||
51 | export LIBNL_EXTRA_CFLAGS="-I ${STAGING_INCDIR}/libnl3" | ||
52 | export LIBNL_EXTRA_LDFLAGS="-lnl-3 -lnl-route-3" | ||
53 | export LIBXML2_CFLAGS="`pkg-config --cflags libxml-2.0`" | ||
54 | export LIBXML2_LDFLAGS="`pkg-config --libs --static libxml-2.0`" | ||
55 | export LIBEDIT_CFLAGS="`pkg-config --cflags libedit`" | ||
56 | export LIBEDIT_LDFLAGS="`pkg-config --libs --static libedit`" | ||
57 | } | ||
58 | |||
59 | do_install () { | ||
60 | export SOC=${SOC} | ||
61 | oe_runmake install DESTDIR=${D} | ||
62 | } | ||
63 | |||
64 | PARALLEL_MAKE_pn-${PN} = "" | ||
65 | FILES_${PN} += "/root/SOURCE_THIS /usr/etc/" | ||
66 | |||
67 | COMPATIBLE_HOST_qoriq-ppc = ".*" | ||
68 | COMPATIBLE_HOST ?= "(none)" | ||
diff --git a/dynamic-layers/openembedded-layer/recipes-support/web-sysmon/web-sysmon_git.bb b/dynamic-layers/openembedded-layer/recipes-support/web-sysmon/web-sysmon_git.bb new file mode 100644 index 00000000..36a0c209 --- /dev/null +++ b/dynamic-layers/openembedded-layer/recipes-support/web-sysmon/web-sysmon_git.bb | |||
@@ -0,0 +1,35 @@ | |||
1 | DESCRIPTION = "Web System Monitor Files" | ||
2 | SECTION = "web-sysmon" | ||
3 | LICENSE = "GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" | ||
5 | |||
6 | RDEPENDS_${PN} = "\ | ||
7 | bc \ | ||
8 | cairo \ | ||
9 | coreutils \ | ||
10 | cronie \ | ||
11 | liberation-fonts \ | ||
12 | lighttpd \ | ||
13 | lighttpd-module-cgi \ | ||
14 | lmsensors-sensors \ | ||
15 | make \ | ||
16 | rrdtool \ | ||
17 | " | ||
18 | |||
19 | SRC_URI = "git://git.freescale.com/ppc/sdk/web-sysmon-dev.git;nobranch=1" | ||
20 | SRCREV = "8d0c6eca1113832fabe917fd0cb25abe2d4d7157" | ||
21 | |||
22 | inherit update-rc.d | ||
23 | |||
24 | S = "${WORKDIR}/git" | ||
25 | |||
26 | EXTRA_OEMAKE += "D=${D}" | ||
27 | do_install () { | ||
28 | oe_runmake install | ||
29 | } | ||
30 | |||
31 | FILES_${PN} += "/" | ||
32 | |||
33 | INITSCRIPT_NAME = "web-sysmon.sh" | ||
34 | INITSCRIPT_PARAMS = "defaults 99 20" | ||
35 | COMPATIBLE_MACHINE = "(qoriq-ppc)" | ||