summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/openembedded-layer
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-06 17:58:44 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:15 -0300
commit7525c946c2b1475449f0b7821590d5db66ea8b5f (patch)
tree9090bb7cfc50fa326adfa1c11cac36d52b947947 /dynamic-layers/openembedded-layer
parent182366392adb7379f7fb48eaaa8c457672781719 (diff)
downloadmeta-freescale-7525c946c2b1475449f0b7821590d5db66ea8b5f.tar.gz
asf: remove deplicated recipe
The asf recipe already exists in recipes-kernel folder Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'dynamic-layers/openembedded-layer')
-rw-r--r--dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb b/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb
deleted file mode 100644
index 7cf8f57a..00000000
--- a/dynamic-layers/openembedded-layer/recipes-kernel/asf/asf_git.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1DESCRIPTION = "Non-DPAA software Application Specific Fast-path"
2SECTION = "asf"
3LICENSE = "GPLv2 & GPLv2+ & BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287"
5
6SRC_URI = "git://git.freescale.com/ppc/sdk/asf.git;branch=master"
7SRCREV = "62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b"
8
9inherit module
10
11S = "${WORKDIR}/git/asfmodule"
12
13EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
14export KERNEL_PATH = "${STAGING_KERNEL_DIR}"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18do_configure[depends] += "virtual/kernel:do_shared_workdir"
19do_configure_prepend () {
20 find ${S} -name Makefile -exec \
21 sed -i 's,$(KERNEL_PATH)/.config,$(KBUILD_OUTPUT)/.config,' {} \;
22}
23
24do_install(){
25 mkdir -p ${D}/${libexecdir}
26 mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/asf
27 cp -rf ${S}/bin/full ${D}/lib/modules/${KERNEL_VERSION}/asf
28 cp -rf ${S}/bin/min ${D}/lib/modules/${KERNEL_VERSION}/asf
29 cp -rf ${S}/../scripts ${D}/${libexecdir}/
30}
31
32FILES_${PN} += "${libexecdir} /lib/modules/${KERNEL_VERSION}/asf"
33RDEPENDS_${PN} += "ipsec-tools"