diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-31 17:39:35 -0500 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-03-31 19:37:58 -0500 |
commit | d93b387a8740bc5f6e61dac13888e9cc0f1cefa2 (patch) | |
tree | 5111741914b7fcb87aac225fa886c757e782456b /conf/machine/imx8dx-mek.conf | |
parent | 65398605b9f412ac851c945f4cbe36a81b899a8f (diff) | |
download | meta-freescale-d93b387a8740bc5f6e61dac13888e9cc0f1cefa2.tar.gz |
mx8dx: Normalize MACHINEOVERRIDES implementation
The imx8dx-mek machine is similar to imx8qxp-mek and so the mx8qxp override
was included in the MACHINEOVERRIDES hierarchy. This is non-standard, and
the rework of the SOC overrides didn't handle it properly, leading to a
build break:
```
Log data follows:
| DEBUG: Executing shell function do_compile
| NOTE: 8QX boot binary build
| cp: failed to access '/home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin': Not a directory
| WARNING: /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636:179 exit 1 from 'cp /home/aquino/src/ossystems/oel-platform/build/tmp/deploy/images/imx8dx-mek/imx-boot$
tools/scfw_tcm.bin /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/git/iMX8DX/scfw_tcm.bin'
| WARNING: Backtrace (BB generated script):
| #1: compile_mx8x, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 179
| #2: do_compile, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 151
| #3: main, /home/aquino/src/ossystems/oel-platform/build/tmp/work/imx8dx_mek-oel-linux/imx-boot/1.0-r0/temp/run.do_compile.1809636, line 189
ERROR: Task (/home/aquino/src/ossystems/oel-platform/sources/meta-freescale/recipes-bsp/imx-mkimage/imx-boot_1.0.bb:do_compile) failed with exit code '1'
```
Fix the problem by removing mx8qxp from the mx8dx hierarchy and adapting
existing mx8qxp overrides appropriately.
Fixes: #1027
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'conf/machine/imx8dx-mek.conf')
-rw-r--r-- | conf/machine/imx8dx-mek.conf | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/conf/machine/imx8dx-mek.conf b/conf/machine/imx8dx-mek.conf index d1aaa8ee..8e8bdee0 100644 --- a/conf/machine/imx8dx-mek.conf +++ b/conf/machine/imx8dx-mek.conf | |||
@@ -3,7 +3,7 @@ | |||
3 | #@DESCRIPTION: i.MX 8DualXPlus Multisensory Enablement Kit board | 3 | #@DESCRIPTION: i.MX 8DualXPlus Multisensory Enablement Kit board |
4 | #@MAINTAINER: Lauren Post <lauren.post@nxp.com> | 4 | #@MAINTAINER: Lauren Post <lauren.post@nxp.com> |
5 | 5 | ||
6 | MACHINEOVERRIDES =. "mx8qxp:mx8dx:" | 6 | MACHINEOVERRIDES =. "mx8dx:" |
7 | 7 | ||
8 | require include/imx8x-mek.inc | 8 | require include/imx8x-mek.inc |
9 | 9 | ||