summaryrefslogtreecommitdiffstats
path: root/conf/layer.conf
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-15 17:14:27 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-16 15:01:29 -0300
commitf8517afc7a5ada4538b3b7d397fa32586d57ffe5 (patch)
tree79349f091306d1760fd4687e62336ffa8fb8c721 /conf/layer.conf
parentc92b415d653afc55f33b6b93fb9248193bfd4fa0 (diff)
downloadmeta-freescale-f8517afc7a5ada4538b3b7d397fa32586d57ffe5.tar.gz
Move meta-fsl-arm content to layer root
The meta-fsl-arm is going to be used as the base for this layer. It contains a clean history and allowing a more granullar set of changes. This commit is just a rename of all contents of meta-fsl-arm subdirectory to this layer's root, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'conf/layer.conf')
-rw-r--r--conf/layer.conf26
1 files changed, 26 insertions, 0 deletions
diff --git a/conf/layer.conf b/conf/layer.conf
new file mode 100644
index 00000000..81d29f59
--- /dev/null
+++ b/conf/layer.conf
@@ -0,0 +1,26 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "fsl-arm"
9BBFILE_PATTERN_fsl-arm := "^${LAYERDIR}/"
10BBFILE_PRIORITY_fsl-arm = "5"
11
12FSL_EULA_FILE = "${LAYERDIR}/EULA"
13
14FSL_MIRROR ?= "http://www.freescale.com/lgfiles/NMG/MAD/YOCTO/"
15
16MIRRORS += " \
17${FSL_MIRROR} http://download.ossystems.com.br/bsp/freescale/source/ \n \
18"
19
20# Let us add layer-specific bbappends which are only applied when that
21# layer is included in our configuration
22BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
23 for layer in BBFILE_COLLECTIONS.split())}"
24# Add layer-specific bb files too
25BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
26 for layer in BBFILE_COLLECTIONS.split())}"