summaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2018-07-23 22:13:19 +0200
committerFabio Berton <fabio.berton@ossystems.com.br>2018-07-30 10:42:46 -0300
commit040e4f031f2dc581c48253405da9036def035b68 (patch)
tree629f23aa60de7b14bc11af619dfed40d10ff7b86 /classes
parentfd89a85eaafb4f26a11d96db5702eadb83c02813 (diff)
downloadmeta-freescale-040e4f031f2dc581c48253405da9036def035b68.tar.gz
dtc-145: Deploy renamed binary only and add new class
dtc-145-native is used by older U-Boot recipes. U-Boot only depends on the native dtc binary. So, to not clash with files from the regular dtc native build do only install the dtc binary renamed to dtc-145. Also, create a new class to handle with dtc-145 dependency. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br>
Diffstat (limited to 'classes')
-rw-r--r--classes/dtc-145.bbclass7
1 files changed, 7 insertions, 0 deletions
diff --git a/classes/dtc-145.bbclass b/classes/dtc-145.bbclass
new file mode 100644
index 00000000..d4a30711
--- /dev/null
+++ b/classes/dtc-145.bbclass
@@ -0,0 +1,7 @@
1# Use this class for U-Boot 2017.03 or older.
2
3DEPENDS_append = " dtc-145-native"
4
5do_configure_prepend () {
6 sed -i -e 's/^DTC[[:space:]]*=[[:space:]]*dtc[[:space:]]*$/DTC = dtc-145/' ${S}/Makefile
7}