summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2018-10-11 16:28:44 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2018-12-13 10:01:31 -0600
commitfaf35a803439a3d3636eec475d78d97c883477b5 (patch)
treead2126b86dcaae755f24f228a84294688ad31ed2
parent890f86d17b6e0f6f63cbc3a3fbe43e2e8d2b185b (diff)
downloadmeta-freescale-faf35a803439a3d3636eec475d78d97c883477b5.tar.gz
firmware-imx: Update logic for non-rootfs firmware
Certain i.MX 8 firmware packages are included in the boot image via imx-boot recipe, not through rootfs. Clarify the logic that handles this. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx_7.8.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/recipes-bsp/firmware-imx/firmware-imx_7.8.bb b/recipes-bsp/firmware-imx/firmware-imx_7.8.bb
index 0fb2d5dc..bf0fbc3f 100644
--- a/recipes-bsp/firmware-imx/firmware-imx_7.8.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx_7.8.bb
@@ -20,12 +20,19 @@ do_install() {
20 install -d ${D}${base_libdir}/firmware/bcm 20 install -d ${D}${base_libdir}/firmware/bcm
21 install -d ${D}${sysconfdir}/firmware 21 install -d ${D}${sysconfdir}/firmware
22 22
23 cp -rfv firmware/* ${D}${base_libdir}/firmware/ 23 cd firmware
24 24 for d in *; do
25 # FIXME: This need to be removed when iMX8 is integrated. 25 case $d in
26 rm -rf ${D}${base_libdir}/firmware/ddr \ 26 ddr|hdmi|seco)
27 ${D}${base_libdir}/firmware/hdmi \ 27 # These folders are for i.MX 8 and are included in the boot image via imx-boot
28 ${D}${base_libdir}/firmware/seco 28 bbnote Excluding folder $d
29 ;;
30 *)
31 cp -rfv $d ${D}${base_libdir}/firmware
32 ;;
33 esac
34 done
35 cd -
29 36
30 #1BW_BCM43340 37 #1BW_BCM43340
31 install -d ${D}${base_libdir}/firmware/bcm/1BW_BCM43340 38 install -d ${D}${base_libdir}/firmware/bcm/1BW_BCM43340