summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrieder Schrempf <frieder.schrempf@kontron.de>2020-02-13 12:29:29 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-02-15 15:33:36 -0300
commitdd691a76052b761b44832c153a5740d420ffde1d (patch)
tree54081d08d624a53de689699664907e6f1f72afc3
parent0b389774018aba7938cee7a76a5e6d604b208122 (diff)
downloadmeta-freescale-dd691a76052b761b44832c153a5740d420ffde1d.tar.gz
mesa: Use PACKAGECONFIG to enable Gallium drivers
We don't need to manipulate the GALLIUMDRIVERS variable. Setting the correct PACKAGECONFIG options is enough as the main recipe handles the rest. Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de>
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index dbaab89e..e8a9b9a3 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -16,8 +16,8 @@ python () {
16 16
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium"
19GALLIUMDRIVERS_append_use-mainline-bsp_armv7a = ",etnaviv,freedreno,kmsro,vc4" 19PACKAGECONFIG_append_use-mainline-bsp_armv7a = " etnaviv freedreno kmsro vc4"
20GALLIUMDRIVERS_append_use-mainline-bsp_armv7ve = ",etnaviv,freedreno,kmsro,vc4" 20PACKAGECONFIG_append_use-mainline-bsp_armv7ve = " etnaviv freedreno kmsro vc4"
21 21
22# Define the osmesa block in PACKAGECONFIG for target, this block is 22# Define the osmesa block in PACKAGECONFIG for target, this block is
23# not defined in the master recipe, effectively causing the osmesa 23# not defined in the master recipe, effectively causing the osmesa