summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2020-08-31 11:40:32 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2020-08-31 11:46:52 -0300
commitaff5551e5b4c2d8ef5cb0a9dfb7a50bc882bd1b2 (patch)
tree5075805f35aa34dd97cbb5edc74a94efda6543bb
parent34131f21de826030d6fe3af4f25fb291a4b0fdb4 (diff)
downloadmeta-freescale-aff5551e5b4c2d8ef5cb0a9dfb7a50bc882bd1b2.tar.gz
imx-atf: fix build with -fno-common
Backport patch required to fix build with -fno-common. Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch45
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.0.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch
new file mode 100644
index 00000000..000eff41
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf/0001-imx-Fix-multiple-definition-of-ipc_handle.patch
@@ -0,0 +1,45 @@
1From 8c433aa6c6b2eaed4084233beea99ee3fb0b652f Mon Sep 17 00:00:00 2001
2From: Samuel Holland <samuel@sholland.org>
3Date: Wed, 4 Dec 2019 02:45:58 -0600
4Subject: [PATCH] imx: Fix multiple definition of ipc_handle
5
6This is not conforming C and does not compile with -fno-common.
7
8Upstream-Status: Backport
9
10Signed-off-by: Samuel Holland <samuel@sholland.org>
11Change-Id: I6535954cc567d6efa06919069b91e3f50975b073
12---
13 plat/imx/common/include/sci/sci_ipc.h | 2 +-
14 plat/imx/common/sci/ipc.c | 2 ++
15 2 files changed, 3 insertions(+), 1 deletion(-)
16
17diff --git a/plat/imx/common/include/sci/sci_ipc.h b/plat/imx/common/include/sci/sci_ipc.h
18index 7cb109206..d2c3bba1c 100644
19--- a/plat/imx/common/include/sci/sci_ipc.h
20+++ b/plat/imx/common/include/sci/sci_ipc.h
21@@ -63,7 +63,7 @@ void sc_ipc_read(sc_ipc_t ipc, void *data);
22 */
23 void sc_ipc_write(sc_ipc_t ipc, const void *data);
24
25-sc_ipc_t ipc_handle;
26+extern sc_ipc_t ipc_handle;
27
28 #endif /* SC_IPC_H */
29
30diff --git a/plat/imx/common/sci/ipc.c b/plat/imx/common/sci/ipc.c
31index 68b0b8ef0..3169b7e0b 100644
32--- a/plat/imx/common/sci/ipc.c
33+++ b/plat/imx/common/sci/ipc.c
34@@ -11,6 +11,8 @@
35
36 #include "imx8_mu.h"
37
38+sc_ipc_t ipc_handle;
39+
40 #include <bakery_lock.h>
41 DEFINE_BAKERY_LOCK(sc_ipc_bakery_lock);
42 #define sc_ipc_lock_init() bakery_lock_init(&sc_ipc_bakery_lock)
43--
442.28.0
45
diff --git a/recipes-bsp/imx-atf/imx-atf_2.0.bb b/recipes-bsp/imx-atf/imx-atf_2.0.bb
index 33ed6c62..1e1baba3 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.0.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.0.bb
@@ -10,6 +10,7 @@ PV .= "+git${SRCPV}"
10SRCBRANCH = "lf-5.4.y" 10SRCBRANCH = "lf-5.4.y"
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ 11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12 file://0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch \ 12 file://0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch \
13 file://0001-imx-Fix-multiple-definition-of-ipc_handle.patch \
13" 14"
14SRCREV = "7b3389d49815f1e3f7942bd312a27ee665bd2e33" 15SRCREV = "7b3389d49815f1e3f7942bd312a27ee665bd2e33"
15 16