summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-02-22 14:28:49 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-03-03 18:26:17 -0300
commit723deb35baae17006fc029e15ddf6ff55357b580 (patch)
tree6db1044c01139805560a908afed877b699dc7fb5
parentf7608795ce9273090257f47015e367b7efc69989 (diff)
downloadmeta-freescale-723deb35baae17006fc029e15ddf6ff55357b580.tar.gz
gstreamer1.0-plugins-good: Transition to meson based builds
This follows [41c498bded82d3c9216dd3c862e70890f67f2914] from upstream, which transitions gstreamer1.0 plugins from autotools to meson build system. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb94
1 files changed, 45 insertions, 49 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
index d09be8dd..4f750ca9 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.imx.bb
@@ -1,81 +1,77 @@
1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc 1require recipes-multimedia/gstreamer/gstreamer1.0-plugins-common.inc
2 2
3LICENSE = "GPLv2+ & LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
6 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
7 3
8GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https" 4GST1.0-PLUGINS-GOOD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-good.git;protocol=https"
9SRCBRANCH = "MM_04.05.01_1909_L4.19.35" 5SRCBRANCH = "MM_04.05.01_1909_L4.19.35"
10 6
11SRC_URI = " \ 7SRC_URI = " \
12 ${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} \ 8 ${GST1.0-PLUGINS-GOOD_SRC};branch=${SRCBRANCH} \
13 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
14" 9"
15SRCREV = "3bcc85705695ee629ac3fb687411bb196d231918" 10SRCREV = "3bcc85705695ee629ac3fb687411bb196d231918"
16 11
17DEFAULT_PREFERENCE = "-1" 12DEFAULT_PREFERENCE = "-1"
18 13
19EXTRA_AUTORECONF = ""
20
21S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
22 15
23DEPENDS += "gstreamer1.0-plugins-base libcap zlib bzip2" 16LICENSE = "GPLv2+ & LGPLv2.1+"
24RPROVIDES_${PN}-soup += "${PN}-souphttpsrc" 17LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
18 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
19 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
25 20
26inherit gettext 21DEPENDS += "gstreamer1.0-plugins-base libcap zlib"
22RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
23RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
27 24
28PACKAGECONFIG ??= " \ 25PACKAGECONFIG ??= " \
29 ${GSTREAMER_ORC} \ 26 ${GSTREAMER_ORC} \
30 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \ 27 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
31 cairo flac gdk-pixbuf gudev jpeg libpng soup speex taglib v4l2 \ 28 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 \
32" 29"
33 30
34X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage" 31X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
32X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled"
33X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled"
35 34
36PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo" 35PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
37PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394" 36PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
38PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac" 37PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394"
39PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf" 38PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac"
40PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev" 39PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
41PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack" 40PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3"
42PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" 41PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev"
43PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng" 42PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack"
44PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils" 43PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg"
45PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio" 44PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame"
46PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4" 45PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng"
47PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex" 46PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils"
48PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib" 47PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123"
49PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2,libdrm" 48PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio"
50PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx" 49PACKAGECONFIG[soup] = "-Dsoup=enabled,-Dsoup=disabled,libsoup-2.4"
51PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack" 50PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex"
52PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}" 51PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib"
53PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2" 52PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false,libdrm"
54PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3" 53PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx"
55PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame" 54PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack"
56PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123" 55PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
57PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
58 56
59# qt5 support is disabled, because it is not present in OE core, and requires more work than 57# qt5 support is disabled, because it is not present in OE core, and requires more work than
60# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths). 58# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
61# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig 59# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
62# in a gstreamer1.0-plugins-good bbappend). 60# in a gstreamer1.0-plugins-good bbappend).
63EXTRA_OECONF += " \ 61
64 --enable-bz2 \ 62EXTRA_OEMESON += " \
65 --enable-oss \ 63 -Daalib=disabled \
66 --enable-zlib \ 64 -Ddirectsound=disabled \
67 --disable-aalib \ 65 -Ddv=disabled \
68 --disable-aalibtest \ 66 -Dlibcaca=disabled \
69 --disable-directsound \ 67 -Doss=enabled \
70 --disable-libcaca \ 68 -Doss4=disabled \
71 --disable-libdv \ 69 -Dosxaudio=disabled \
72 --disable-oss4 \ 70 -Dosxvideo=disabled \
73 --disable-osx_audio \ 71 -Dqt5=disabled \
74 --disable-osx_video \ 72 -Dshout2=disabled \
75 --disable-shout2 \ 73 -Dtwolame=disabled \
76 --disable-waveform \ 74 -Dwaveform=disabled \
77 --disable-qt \
78 --disable-twolame \
79" 75"
80 76
81FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" 77FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"