summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2020-04-01 07:54:17 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-01 08:48:15 -0300
commit5c33f703510963f5739174dc83afed7dd372750f (patch)
treeded6a735602ba50189b11ace18d1bb5bacec9d05
parent24f414f37128b5c23b93bbe35a2eb20163988325 (diff)
downloadmeta-freescale-5c33f703510963f5739174dc83afed7dd372750f.tar.gz
u-boot-fslc-fw-utils: set correctly make source build dir
This partially revert commit 4e5c7e0d4959b027698e15565df7d3286e6860fa: u-boot-fslc: Set build dir only for u-boot recipe Not setting the build dir in u-boot-fslc-common is breaking the build of u-boot-fslc-mxsboot. Instead of unsetting ${B}, set correctly the output and source dir in make Signed-off-by: Nicola Lunghi <nick83ola@gmail.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2020.01.inc1
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb4
2 files changed, 3 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2020.01.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2020.01.inc
index 6e5e5986..aa5c5d73 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2020.01.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2020.01.inc
@@ -16,3 +16,4 @@ SRCBRANCH = "2020.01+fslc"
16PV = "v2020.01+git${SRCPV}" 16PV = "v2020.01+git${SRCPV}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb
index a809a3f6..82763eb9 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2020.01.bb
@@ -10,8 +10,8 @@ EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}"
10inherit uboot-config 10inherit uboot-config
11 11
12do_compile () { 12do_compile () {
13 oe_runmake ${UBOOT_MACHINE} 13 oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}
14 oe_runmake envtools 14 oe_runmake -C ${S} O=${B} envtools
15} 15}
16 16
17do_install () { 17do_install () {