summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-02-28 10:26:50 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-02-28 08:16:14 -0300
commit2d5adaea3165ed728f0cef52528c99708ac34c0a (patch)
tree82cf61a063136da5fdbb434a9d94db2f8916e63b
parent54115b38b777f09d60847f7ba0ac7796230b3d89 (diff)
downloadmeta-freescale-2d5adaea3165ed728f0cef52528c99708ac34c0a.tar.gz
devregs: update to latest version from upstream
Drop the patch stored in this layer, since the PR with the same patch has been merged upstream. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--recipes-devtools/devregs/devregs_git.bb6
-rw-r--r--recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch33
2 files changed, 2 insertions, 37 deletions
diff --git a/recipes-devtools/devregs/devregs_git.bb b/recipes-devtools/devregs/devregs_git.bb
index 61bb0059..7f158fd8 100644
--- a/recipes-devtools/devregs/devregs_git.bb
+++ b/recipes-devtools/devregs/devregs_git.bb
@@ -3,10 +3,8 @@ SECTION = "devel"
3LICENSE = "GPL-1" 3LICENSE = "GPL-1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924" 4LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924"
5 5
6SRCREV = "6d2ad752ce92ad37ab144d9c3322f3dcd43398e5" 6SRCREV = "d5f6223027f4d6ae71bd5d432f5611486e0e6074"
7SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=http \ 7SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=http"
8 file://0001-devregs-add-support-for-imx8mn-soc.patch \
9"
10 8
11PV = "1.0+${SRCPV}" 9PV = "1.0+${SRCPV}"
12 10
diff --git a/recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch b/recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch
deleted file mode 100644
index b838ad03..00000000
--- a/recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From cca909511ead5023f4a9f71412d79411a384326d Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Mon, 13 Jan 2020 17:32:19 +0000
4Subject: [PATCH] devregs: add support for imx8mn soc
5
6i.MX8M Nano SoC is very close to i.MX8M Mini, therefore we would allow
7them to use the same register description file.
8
9Upstream-Status: Submitted [https://github.com/boundarydevices/devregs/pull/5]
10
11Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
12---
13 src/devregs.cpp | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/src/devregs.cpp b/src/devregs.cpp
17index 67c52eb..d540894 100644
18--- a/src/devregs.cpp
19+++ b/src/devregs.cpp
20@@ -717,6 +717,10 @@ static int getcpu(unsigned &cpu, const char *path) {
21 cpu = 0x82;
22 break;
23 }
24+ if (strstr(inBuf, "i.MX8MN")) {
25+ cpu = 0x82;
26+ break;
27+ }
28 if (!get_rev(inBuf, "Revision", &cpu))
29 if (cpu != 0x10)
30 break;
31--
322.17.1
33