summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2020-04-23 08:44:03 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-24 14:00:40 -0300
commitef01e8bffe63621871c696bcc3c5b68b40680033 (patch)
treee2c9c74da849735b8929fe9dc93b2276620beb1c
parente6f581f2064ed12a0535042bbb96361b6f617184 (diff)
downloadmeta-freescale-ef01e8bffe63621871c696bcc3c5b68b40680033.tar.gz
waffle: Fix x11 build without GBM support
For i.MX 6 and 7, building x11_egl failed with the following: ``` In file included from ../waffle-1.6.0/src/waffle/surfaceless_egl/sl_window.c:35: ../waffle-1.6.0/src/waffle/surfaceless_egl/sl_platform.h:30:10: fatal error: gbm.h: No such file or directory 30 | #include <gbm.h> | ^~~~~~~ ``` The failure is not surprising since i.MX 6 and 7 don't support GBM. What is surprising is surfaceless_egl is built even if it is disabled. The meson dependency for surfaceless_egl was incorrectly tied to x11_egl, so fix that, plus add a dependency on GBM. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit 76467d61049bd89a25f5a26592bc6c8808e51ff9)
-rw-r--r--recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch46
-rw-r--r--recipes-graphics/waffle/waffle_%.bbappend1
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
new file mode 100644
index 00000000..3f9f3b1c
--- /dev/null
+++ b/recipes-graphics/waffle/waffle/0002-meson-Separate-surfaceless-option-from-x11.patch
@@ -0,0 +1,46 @@
1From 451381a61ad0c96e870da2325fc188eaa3d91fec Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Wed, 22 Apr 2020 14:08:36 -0500
4Subject: [PATCH 2/2] meson: Separate surfaceless option from x11
5
6Allow surfaceless build separate from the x11 option.
7Also require gbm for surfaceless build.
8
9Upstream-Status: Pending
10
11Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
12---
13 meson.build | 5 ++++-
14 1 file changed, 4 insertions(+), 1 deletion(-)
15
16diff --git a/meson.build b/meson.build
17index 4ebb022..0705f61 100644
18--- a/meson.build
19+++ b/meson.build
20@@ -72,6 +72,7 @@ dep_udev = _dep_null
21 dep_cocoa = _dep_null
22 dep_core_foundation = _dep_null
23 dep_gl_headers = _dep_null
24+dep_surfaceless = _dep_null
25
26 # Get dependencies
27 if build_wgl
28@@ -101,12 +102,14 @@ else
29 endif
30 dep_gbm = dependency('gbm', required : get_option('gbm'))
31 dep_udev = dependency('libudev', required : get_option('gbm'))
32+ dep_surfaceless_egl = dependency('egl', required : get_option('surfaceless_egl'))
33+ dep_surfaceless_gbm = dependency('gbm', required : get_option('surfaceless_egl'))
34
35 build_x11_egl = dep_egl.found()
36 build_wayland = dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_wayland_egl.found()
37 build_glx = dep_gl.found()
38 build_gbm = dep_gbm.found() and dep_udev.found()
39- build_surfaceless = dep_egl.found()
40+ build_surfaceless = dep_surfaceless_egl.found() and dep_surfaceless_gbm.found()
41 endif
42
43 dep_bash = dependency('bash-completion', required : false)
44--
452.17.1
46
diff --git a/recipes-graphics/waffle/waffle_%.bbappend b/recipes-graphics/waffle/waffle_%.bbappend
index 4bb2ed5f..9d090bcf 100644
--- a/recipes-graphics/waffle/waffle_%.bbappend
+++ b/recipes-graphics/waffle/waffle_%.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2 2
3SRC_URI += " \ 3SRC_URI += " \
4 file://0001-meson-Add-missing-wayland-dependency-on-EGL.patch \ 4 file://0001-meson-Add-missing-wayland-dependency-on-EGL.patch \
5 file://0002-meson-Separate-surfaceless-option-from-x11.patch \
5" 6"
6 7
7PACKAGECONFIG_IMXGPU_X11 = "" 8PACKAGECONFIG_IMXGPU_X11 = ""