summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2020-04-23 08:38:34 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-24 14:00:40 -0300
commite6f581f2064ed12a0535042bbb96361b6f617184 (patch)
treedae3750eff06387b88f64b7a00f48b9c3640355f
parentc0df3dd0717a7d799993f571daa9d226c432c0b9 (diff)
downloadmeta-freescale-e6f581f2064ed12a0535042bbb96361b6f617184.tar.gz
waffle: Add missing dependency on EGL
For Wayland builds without XWayland support, the following build break was happening: In file included from /home/bamboo/build/5.4-zeus-full/fsl-imx-internal-wayland/temp_build_dir/build_fsl-imx-internal-wayland/tmp/work/aarch64-mx8-poky-linux/waffle/1.6.0-r0/recipe-sysroot/usr/include/EGL/egl.h:39, from ../waffle-1.6.0/src/waffle/egl/wegl_context.h:31, from ../waffle-1.6.0/src/waffle/egl/wegl_util.c:28: /home/bamboo/build/5.4-zeus-full/fsl-imx-internal-wayland/temp_build_dir/build_fsl-imx-internal-wayland/tmp/work/aarch64-mx8-poky-linux/waffle/1.6.0-r0/recipe-sysroot/usr/include/EGL/eglplatform.h:144:10: fatal error: X11/Xlib.h: No such file or directory 144 | #include <X11/Xlib.h> | ^~~~~~~~~~~~ compilation terminated. This happens because the egl.pc configuration is missing. Fix the mising dependency. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> (cherry picked from commit eea3e3bbe0870b46363884402c97b4f1b187a6f9)
-rw-r--r--recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch49
-rw-r--r--recipes-graphics/waffle/waffle_%.bbappend6
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
new file mode 100644
index 00000000..f613386f
--- /dev/null
+++ b/recipes-graphics/waffle/waffle/0001-meson-Add-missing-wayland-dependency-on-EGL.patch
@@ -0,0 +1,49 @@
1From 932c21d2851fe79bf4fe55d3b613f71f65762adb Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Wed, 22 Apr 2020 13:40:04 -0500
4Subject: [PATCH] meson: Add missing wayland dependency on EGL
5
6The build was not finding egl.pc due to this
7missing dependency.
8
9Upstream-Status: Pending
10
11Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
12---
13 meson.build | 6 ++++--
14 1 file changed, 4 insertions(+), 2 deletions(-)
15
16diff --git a/meson.build b/meson.build
17index 957737c..4ebb022 100644
18--- a/meson.build
19+++ b/meson.build
20@@ -65,6 +65,7 @@ dep_gl = _dep_null
21 dep_egl = _dep_null
22 dep_wayland_client = _dep_null
23 dep_wayland_egl = _dep_null
24+dep_wayland_wayland_egl = _dep_null
25 dep_x11_xcb = _dep_null
26 dep_gbm = _dep_null
27 dep_udev = _dep_null
28@@ -90,7 +91,8 @@ else
29 dep_wayland_client = dependency(
30 'wayland-client', version : '>= 1.0', required : get_option('wayland'),
31 )
32- dep_wayland_egl = dependency(
33+ dep_wayland_egl = dependency('egl', required : get_option('wayland'))
34+ dep_wayland_wayland_egl = dependency(
35 'wayland-egl', version : '>= 9.1', required : get_option('wayland'),
36 )
37 dep_x11_xcb = dependency('x11-xcb', required : get_option('glx'))
38@@ -101,7 +103,7 @@ else
39 dep_udev = dependency('libudev', required : get_option('gbm'))
40
41 build_x11_egl = dep_egl.found()
42- build_wayland = dep_wayland_client.found() and dep_wayland_egl.found()
43+ build_wayland = dep_wayland_client.found() and dep_wayland_egl.found() and dep_wayland_wayland_egl.found()
44 build_glx = dep_gl.found()
45 build_gbm = dep_gbm.found() and dep_udev.found()
46 build_surfaceless = dep_egl.found()
47--
482.17.1
49
diff --git a/recipes-graphics/waffle/waffle_%.bbappend b/recipes-graphics/waffle/waffle_%.bbappend
index 60825b6f..4bb2ed5f 100644
--- a/recipes-graphics/waffle/waffle_%.bbappend
+++ b/recipes-graphics/waffle/waffle_%.bbappend
@@ -1,3 +1,9 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " \
4 file://0001-meson-Add-missing-wayland-dependency-on-EGL.patch \
5"
6
1PACKAGECONFIG_IMXGPU_X11 = "" 7PACKAGECONFIG_IMXGPU_X11 = ""
2PACKAGECONFIG_IMXGPU_X11_imxgpu3d = "x11-egl glx" 8PACKAGECONFIG_IMXGPU_X11_imxgpu3d = "x11-egl glx"
3PACKAGECONFIG_IMXGPU_GBM = "gbm" 9PACKAGECONFIG_IMXGPU_GBM = "gbm"