summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantznin <agodard@witekio.com>2020-04-29 14:37:38 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-05 08:51:53 -0300
commita44d0e61e09ecefeee56403236e81a2f2eb0ab1d (patch)
treef99bdd516f53e9dc24707b4dec14fe614bfe39d7
parent6b9b83814d35d9055f0c2578f76a564096b8115f (diff)
downloadmeta-freescale-a44d0e61e09ecefeee56403236e81a2f2eb0ab1d.tar.gz
optee-os: Replace /lib by ${nonarch_base_libdir} in do_install
This fixes a do_package error when using `usrmerge` in `DISTRO_FEATURES`. In that case the bin files should have been installed in /usr/lib. Using ${nonarch_base_libdir} makes the location specific to distro settings. Signed-off-by: antznin <agodard@witekio.com>
-rw-r--r--recipes-security/optee-imx/optee-os_3.2.0.imx.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
index 43b0ef14..f4fc26e7 100644
--- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
@@ -71,8 +71,8 @@ do_deploy () {
71} 71}
72 72
73do_install () { 73do_install () {
74 install -d ${D}/lib/firmware/ 74 install -d ${D}${nonarch_base_libdir}/firmware/
75 install -m 644 ${B}/core/*.bin ${D}/lib/firmware/ 75 install -m 644 ${B}/core/*.bin ${D}${nonarch_base_libdir}/firmware/
76 76
77 # Install the TA devkit 77 # Install the TA devkit
78 install -d ${D}/usr/include/optee/export-user_ta_${OPTEE_ARCH}/ 78 install -d ${D}/usr/include/optee/export-user_ta_${OPTEE_ARCH}/