summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2019-11-17 09:25:11 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2019-11-18 10:16:54 -0300
commit8791f78b8c990e53704b013117f6c53570119ce5 (patch)
treef43d411f77166fbae75dc14103ff3d27ae231dce
parentc1ebb48c52762fbc75ef5efb6e2541c1869586bc (diff)
downloadmeta-freescale-8791f78b8c990e53704b013117f6c53570119ce5.tar.gz
weston: Move xwayland config to weston.ini
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend19
-rw-r--r--recipes-graphics/wayland/weston-init/imxdrm/weston.config2
-rwxr-xr-xrecipes-graphics/wayland/weston-init/mx6sl/weston.config2
-rw-r--r--recipes-graphics/wayland/weston-init/mx8mm/weston.config2
-rw-r--r--recipes-graphics/wayland/weston-init/weston.config2
5 files changed, 9 insertions, 18 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index ce6c4c7c..e5b90a57 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -6,14 +6,15 @@ IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu2d = "opengl"
6IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu3d = "" 6IMX_REQUIRED_DISTRO_FEATURES_REMOVE_imxgpu3d = ""
7REQUIRED_DISTRO_FEATURES_remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}" 7REQUIRED_DISTRO_FEATURES_remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}"
8 8
9SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd wayland x11', 'file://weston.config', '', d)}" 9SRC_URI_append_mx6sl = "file://weston.config"
10
11HAS_SYSTEMD = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}"
12HAS_XWAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', 'true', 'false', d)}"
13 10
14# To customize weston.ini, start by setting the desired assignment in weston.ini, 11# To customize weston.ini, start by setting the desired assignment in weston.ini,
15# commented out. Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS. 12# commented out. For example:
16INI_UNCOMMENT_ASSIGNMENTS = "" 13# #xwayland=true
14# Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS.
15INI_UNCOMMENT_ASSIGNMENTS = " \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland=true', '', d)} \
17"
17INI_UNCOMMENT_ASSIGNMENTS_append_mx7ulp = " \ 18INI_UNCOMMENT_ASSIGNMENTS_append_mx7ulp = " \
18 use-g2d=1 \ 19 use-g2d=1 \
19" 20"
@@ -34,10 +35,8 @@ uncomment() {
34} 35}
35 36
36do_install_append() { 37do_install_append() {
37 if ${HAS_SYSTEMD}; then 38 if [ -f "${WORKDIR}/weston.config" ]; then
38 if ${HAS_XWAYLAND}; then 39 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston
39 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston
40 fi
41 fi 40 fi
42 for assignment in ${INI_UNCOMMENT_ASSIGNMENTS}; do 41 for assignment in ${INI_UNCOMMENT_ASSIGNMENTS}; do
43 uncomment "$assignment" ${D}${sysconfdir}/xdg/weston/weston.ini 42 uncomment "$assignment" ${D}${sysconfdir}/xdg/weston/weston.ini
diff --git a/recipes-graphics/wayland/weston-init/imxdrm/weston.config b/recipes-graphics/wayland/weston-init/imxdrm/weston.config
deleted file mode 100644
index 7c92cf11..00000000
--- a/recipes-graphics/wayland/weston-init/imxdrm/weston.config
+++ /dev/null
@@ -1,2 +0,0 @@
1#!/bin/sh
2OPTARGS="--xwayland"
diff --git a/recipes-graphics/wayland/weston-init/mx6sl/weston.config b/recipes-graphics/wayland/weston-init/mx6sl/weston.config
index 89269d79..6456cd24 100755
--- a/recipes-graphics/wayland/weston-init/mx6sl/weston.config
+++ b/recipes-graphics/wayland/weston-init/mx6sl/weston.config
@@ -1,3 +1 @@
1#!/bin/sh
2OPTARGS="--xwayland"
3FB_MULTI_BUFFER=1 FB_MULTI_BUFFER=1
diff --git a/recipes-graphics/wayland/weston-init/mx8mm/weston.config b/recipes-graphics/wayland/weston-init/mx8mm/weston.config
deleted file mode 100644
index 7c92cf11..00000000
--- a/recipes-graphics/wayland/weston-init/mx8mm/weston.config
+++ /dev/null
@@ -1,2 +0,0 @@
1#!/bin/sh
2OPTARGS="--xwayland"
diff --git a/recipes-graphics/wayland/weston-init/weston.config b/recipes-graphics/wayland/weston-init/weston.config
deleted file mode 100644
index 7c92cf11..00000000
--- a/recipes-graphics/wayland/weston-init/weston.config
+++ /dev/null
@@ -1,2 +0,0 @@
1#!/bin/sh
2OPTARGS="--xwayland"