summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrieder Schrempf <frieder.schrempf@kontron.de>2020-02-13 12:37:46 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-02-17 11:38:09 -0300
commit3a3b13bef12c3a46da976fbf3b666310f8b694a7 (patch)
treee10b75bbb4f61aa0e3a5e506fedcd35c1952828b
parent19011b119dc1289e98f490c48bd5b93109c5d5f8 (diff)
downloadmeta-freescale-3a3b13bef12c3a46da976fbf3b666310f8b694a7.tar.gz
mesa: Allow to use Etnaviv with i.MX8
Currently the settings for i.MX8 are fixed to only allow to use OSMesa for offscreen rendering. Actually etnaviv is usable on i.MX8MM an it should therefore be possible to let Gallium be enabled instead of unconditionally disabling it. Therefore we introduce the USE_OSMESA_ONLY variable, that can be set to "no" for i.MX8 if etnaviv should be used just like for i.MX6. Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de> (cherry picked from commit deb2f61f227dcb31ed41629c98e5e5e1edf3afec)
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 0d0098dd..d61112e5 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -18,19 +18,19 @@ python () {
18PACKAGECONFIG_append_use-mainline-bsp = " gallium" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium"
19PACKAGECONFIG_append_use-mainline-bsp_armv7a = " etnaviv freedreno kmsro vc4" 19PACKAGECONFIG_append_use-mainline-bsp_armv7a = " etnaviv freedreno kmsro vc4"
20PACKAGECONFIG_append_use-mainline-bsp_armv7ve = " etnaviv freedreno kmsro vc4" 20PACKAGECONFIG_append_use-mainline-bsp_armv7ve = " etnaviv freedreno kmsro vc4"
21PACKAGECONFIG_append_use-mainline-bsp_mx8 = " etnaviv kmsro vc4"
21 22
22# Define the osmesa block in PACKAGECONFIG for target, this block is 23USE_OSMESA_ONLY ?= "no"
23# not defined in the master recipe, effectively causing the osmesa
24# feature to be disabled and -Dosmesa=none set.
25PACKAGECONFIG_append_mx8 = " osmesa"
26 24
27# Solve 'Problem encountered: OSMesa classic requires dri (classic) swrast.' 25# Etnaviv support state for i.MX8 is unknown, therefore only enable OSMesa and
28# by defining the dri swrast for mx8mm machine 26# disable Gallium for now. If you still want to enable Etnaviv, just set
29DRIDRIVERS_append_mx8 = "swrast" 27# USE_OSMESA_ONLY_mx8 = "no" in your bbappend.
28USE_OSMESA_ONLY_mx8 ?= "yes"
30 29
31# Solve 'ERROR: Problem encountered: Only one swrast provider can be built' 30# Enable OSMesa which also requires dri (classic) swrast
32# by excluding gallium support, dri is used together with 'classic' mesa backend. 31PACKAGECONFIG_append = " ${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', ' osmesa', '', d)}"
33PACKAGECONFIG_remove_mx8 = "gallium" 32PACKAGECONFIG_remove = " ${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', 'gallium', '', d)}"
33DRIDRIVERS_append = "${@oe.utils.conditional('USE_OSMESA_ONLY', 'yes', 'swrast', '', d)}"
34 34
35BACKEND = \ 35BACKEND = \
36 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \ 36 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', \