summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-01-06 16:54:36 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-08 08:43:39 -0300
commit375e31d47372a51adf1f228547bf7829ba1ca60a (patch)
tree9728577e025c3bcecfca570e0d9dd7eae8d77ed2
parent70150376c8ab00b8b77de576e5a3e2894256e843 (diff)
downloadmeta-freescale-375e31d47372a51adf1f228547bf7829ba1ca60a.tar.gz
optee-os: update to 4.19.35_1.1.0 and introduce imx8mn config
In order to support new i.MX8M Nano SoC, optee-os should be upgraded to use the imx_4.19.35_1.1.0 branch, which contains the support for new machine. In addition, introduce additional PLATFORM_FLAVOR for new imx8mnevk machine. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> (cherry picked from commit 866e460572ee6fb0398036fb8c1b33966669e086)
-rw-r--r--recipes-security/optee-imx/optee-os_3.2.0.imx.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
index 43b0ef14..c5328c9c 100644
--- a/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
+++ b/recipes-security/optee-imx/optee-os_3.2.0.imx.bb
@@ -9,10 +9,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
9inherit deploy pythonnative autotools 9inherit deploy pythonnative autotools
10DEPENDS = "python-pycrypto-native u-boot-mkimage-native" 10DEPENDS = "python-pycrypto-native u-boot-mkimage-native"
11 11
12SRCBRANCH = "imx_4.14.78_1.0.0_ga" 12SRCBRANCH = "imx_4.19.35_1.1.0"
13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https" 13OPTEE_OS_SRC ?= "git://source.codeaurora.org/external/imx/imx-optee-os.git;protocol=https"
14SRC_URI = "${OPTEE_OS_SRC};branch=${SRCBRANCH}" 14SRC_URI = "${OPTEE_OS_SRC};branch=${SRCBRANCH}"
15SRCREV = "6a52487eb0ff664e4ebbd48497f0d3322844d51d" 15SRCREV = "6a22e6e8a2840b245808527679f3397b7e620b3c"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18B = "${WORKDIR}/build.${PLATFORM_FLAVOR}" 18B = "${WORKDIR}/build.${PLATFORM_FLAVOR}"
@@ -25,6 +25,7 @@ PLATFORM_FLAVOR_imx6ull14x14evk = "mx6ullevk"
25PLATFORM_FLAVOR_imx6ull9x9evk = "mx6ullevk" 25PLATFORM_FLAVOR_imx6ull9x9evk = "mx6ullevk"
26PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk" 26PLATFORM_FLAVOR_imx6ulz14x14evk = "mx6ulzevk"
27PLATFORM_FLAVOR_mx8mm = "mx8mmevk" 27PLATFORM_FLAVOR_mx8mm = "mx8mmevk"
28PLATFORM_FLAVOR_mx8mn = "mx8mnevk"
28 29
29OPTEE_ARCH ?= "arm32" 30OPTEE_ARCH ?= "arm32"
30OPTEE_ARCH_armv7a = "arm32" 31OPTEE_ARCH_armv7a = "arm32"