summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrieder Schrempf <frieder.schrempf@kontron.de>2020-02-13 12:29:29 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2020-02-17 11:38:09 -0300
commit19011b119dc1289e98f490c48bd5b93109c5d5f8 (patch)
treefdb95adec991f9b09a075c65c98a475c022f3ad5
parente9d075e2e1084538a8f7e233f7982507213540e7 (diff)
downloadmeta-freescale-19011b119dc1289e98f490c48bd5b93109c5d5f8.tar.gz
mesa: Use PACKAGECONFIG to enable Gallium drivers
We don't need to manipulate the GALLIUMDRIVERS variable. Setting the correct PACKAGECONFIG options is enough as the main recipe handles the rest. Signed-off-by: Frieder Schrempf <frieder.schrempf@kontron.de> (cherry picked from commit 494ed8c9b7b211397ce621a36345539a23433ecc)
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index c522315a..0d0098dd 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -16,8 +16,8 @@ python () {
16 16
17# Enable Etnaviv and Freedreno support 17# Enable Etnaviv and Freedreno support
18PACKAGECONFIG_append_use-mainline-bsp = " gallium" 18PACKAGECONFIG_append_use-mainline-bsp = " gallium"
19GALLIUMDRIVERS_append_use-mainline-bsp_armv7a = ",etnaviv,freedreno,kmsro,vc4" 19PACKAGECONFIG_append_use-mainline-bsp_armv7a = " etnaviv freedreno kmsro vc4"
20GALLIUMDRIVERS_append_use-mainline-bsp_armv7ve = ",etnaviv,freedreno,kmsro,vc4" 20PACKAGECONFIG_append_use-mainline-bsp_armv7ve = " etnaviv freedreno kmsro vc4"
21 21
22# Define the osmesa block in PACKAGECONFIG for target, this block is 22# Define the osmesa block in PACKAGECONFIG for target, this block is
23# not defined in the master recipe, effectively causing the osmesa 23# not defined in the master recipe, effectively causing the osmesa