summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-05-02 17:25:12 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-05-17 07:56:07 -0300
commit0a0049285c3e97b045f2dd3c91ceb069a429ee2c (patch)
tree3f297176e16193d3ba00b5aed3122c5f55378856
parent0d81eff9424295dfdbb63901252ee9f8741f4736 (diff)
downloadmeta-freescale-0a0049285c3e97b045f2dd3c91ceb069a429ee2c.tar.gz
qtwayland: drop xcomposite-egl, xcomposite-glx packageconfig for mx8
NXP dropped native X11 support for i.MX 8(X). with xcomposite-glx: qtwayland fails in configure with: | ERROR: Feature 'xcomposite-glx' was enabled, but the pre-condition 'features.wayland-client && features.opengl && !features.opengles2 && features.xlib && libs.xcomposite && libs.glx' failed. | ERROR: Feature 'xcomposite-glx' was enabled, but the pre-condition 'features.wayland-server && features.opengl && !features.opengles2 && libs.xcomposite && libs.glx' failed. with xcomposte-egl: qtwayland fails during compile starting with: | .../qwaylandxcompositeeglclientbufferintegration.cpp:140:59: error: cannot convert 'Display*' {aka '_XDisplay*'} to 'EGLNativeDisplayType' {aka 'wl_display*'} | integration->mEglDisplay = eglGetDisplay(integration->mDisplay); | ~~~~~~~~~~~~~^~~~~~~~ Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
index 7f61dc50..afc728c1 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtwayland_%.bbappend
@@ -1,2 +1,5 @@
1# etnaviv mesa does not have glx 1# etnaviv mesa does not have glx
2PACKAGECONFIG_remove_use-mainline-bsp = "xcomposite-glx" 2PACKAGECONFIG_remove_use-mainline-bsp = "xcomposite-glx"
3
4# i.MX8 does never provide native x11, so required dependencies are not met
5PACKAGECONFIG_remove_mx8 = "xcomposite-egl xcomposite-glx"