summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2023-07-26 17:19:25 -0300
committerDaiane Angolini <daiane.angolini@foundries.io>2023-07-26 19:37:48 -0300
commitcfeb85ce48fcd54b5e8ff4ce72d56f79d10c929f (patch)
tree2438c56a3348a43e151056553a1bb39f280f0df0
parent70676ce1e890f6061313c15fcfe7e6f75395f0dd (diff)
downloadmeta-freescale-cfeb85ce48fcd54b5e8ff4ce72d56f79d10c929f.tar.gz
mcore-demos: imx-m4-demos: Add package based on 6.1.22-2.0.0
Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb28
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_2.13.0.bb19
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb19
3 files changed, 66 insertions, 0 deletions
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
new file mode 100644
index 00000000..fd99c637
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "i.MX M4 core Demo images"
2SECTION = "app"
3LICENSE = "Proprietary"
4LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"
5
6inherit deploy fsl-eula-unpack
7
8M4_SOC ?= "INVALID"
9M4_SOC:mx7d-nxp-bsp = "imx7d-sabresd"
10
11SRC_URI = "${FSL_MIRROR}/${M4_SOC}-m4-freertos-${PV}.bin;fsl-eula=true"
12S = "${WORKDIR}/${M4_SOC}-m4-freertos-${PV}"
13
14SRC_URI[md5sum] = "b05b780ff3916f4953ab58ac95233c38"
15SRC_URI[sha256sum] = "cc00d3b936d49b2794a2a99e10129437e70caba3fd26b8379b8c50dd22f73254"
16
17do_deploy () {
18 # Install the demo binaries
19 install -d ${DEPLOYDIR}
20 cp ${S}/*.bin ${DEPLOYDIR}/
21 ls ${DEPLOYDIR}/
22}
23
24addtask deploy before do_build after do_compile
25
26PACKAGE_ARCH = "${MACHINE_SOCARCH}"
27COMPATIBLE_MACHINE = "(mx7d-nxp-bsp)"
28
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_2.13.0.bb b/recipes-fsl/mcore-demos/imx-m4-demos_2.13.0.bb
new file mode 100644
index 00000000..b3c6dbdc
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_2.13.0.bb
@@ -0,0 +1,19 @@
1# Copyright 2017-2023 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require imx-mcore-demos.inc
5
6LIC_FILES_CHKSUM:mx8mm-nxp-bsp = "file://COPYING;md5=add2d392714d3096ed7e0f7e2190724b"
7LIC_FILES_CHKSUM:mx8mq-nxp-bsp = "file://COPYING;md5=add2d392714d3096ed7e0f7e2190724b"
8LIC_FILES_CHKSUM:mx7ulp-nxp-bsp = "file://COPYING;md5=add2d392714d3096ed7e0f7e2190724b"
9
10SRC_URI[imx8mm.md5sum] = "0ae9ae9047b37e9750fea900cb9f3944"
11SRC_URI[imx8mm.sha256sum] = "fe024edb89bac0ab0a5b74ad2b0a231cba92b9b2c0cdab496e45c3b2b131fa8e"
12
13SRC_URI[imx8mq.md5sum] = "2860266c99a4535c2bd14adb7ceaf6ba"
14SRC_URI[imx8mq.sha256sum] = "cc13003b637d6912780dc70f37c78b60403a080c6edbb0bf3c7f9bf5a2f98971"
15
16SRC_URI[imx7ulp.md5sum] = "5ca17160cfbac5ce84d9f0fa04cf9ecf"
17SRC_URI[imx7ulp.sha256sum] = "eba89bcd1c162a5d81707abdba5bea2ef862acd8c5558bce2f3435e27c00ada9"
18
19COMPATIBLE_MACHINE = "(mx7ulp-nxp-bsp|mx8mm-nxp-bsp|mx8mq-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb b/recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb
new file mode 100644
index 00000000..63c402dd
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb
@@ -0,0 +1,19 @@
1# Copyright 2017-2021 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require imx-mcore-demos.inc
5
6LIC_FILES_CHKSUM:mx8dxl-nxp-bsp = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
7LIC_FILES_CHKSUM:mx8qm-nxp-bsp = "file://COPYING;md5=a632fefd1c359980434f9389833cab3a"
8LIC_FILES_CHKSUM:mx8qxp-nxp-bsp = "file://COPYING;md5=a632fefd1c359980434f9389833cab3a"
9
10SRC_URI[imx8dxl.md5sum] = "8850c04a8af91e2bd822cecd5ec56e12"
11SRC_URI[imx8dxl.sha256sum] = "66ddba970712ed394de4034b362334a12caa5865a6afc1dfb5a897bb55b4fcf1"
12
13SRC_URI[imx8qm.md5sum] = "5912ca94847ee56a7e8b866b211b67d9"
14SRC_URI[imx8qm.sha256sum] = "c695e72b0c7f609132f5990469cf950c03e137de887bd7e24d059c51a7b499be"
15
16SRC_URI[imx8qx.md5sum] = "5bc15014f59b2b11c71299fac608be5d"
17SRC_URI[imx8qx.sha256sum] = "bbb268a30a58a86e38966122191c8aa69f427c6c1d56b0ce81e518f4d652782a"
18
19COMPATIBLE_MACHINE = "(mx8dxl-nxp-bsp|mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp)"