summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2023-07-26 17:14:39 -0300
committerDaiane Angolini <daiane.angolini@foundries.io>2023-07-26 19:37:48 -0300
commit70676ce1e890f6061313c15fcfe7e6f75395f0dd (patch)
tree385957c53d56f30ab2a2036bc98d433b6f33b5c7
parentaf6bb957e52834e2615b0350ea24af88648f5141 (diff)
downloadmeta-freescale-70676ce1e890f6061313c15fcfe7e6f75395f0dd.tar.gz
mcore-demos: imx-m33-demos: Add package based on 6.1.22-2.0.0
Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
-rw-r--r--recipes-fsl/mcore-demos/README11
-rw-r--r--recipes-fsl/mcore-demos/imx-m33-demos_2.14.0.bb15
-rw-r--r--recipes-fsl/mcore-demos/imx-mcore-demos.inc62
3 files changed, 88 insertions, 0 deletions
diff --git a/recipes-fsl/mcore-demos/README b/recipes-fsl/mcore-demos/README
new file mode 100644
index 00000000..d3770e8b
--- /dev/null
+++ b/recipes-fsl/mcore-demos/README
@@ -0,0 +1,11 @@
1The M4 demo app version of each SoCs are followed:
2* 2.13.0 -- i.MX 7ULP, 8MQ, 8MM
3* 2.9.0 -- i.MX 8DXL, 8QM, 8QXP
4* 1.0.1 -- i.MX 7D
5
6The M7 demo app version of each SoCs are followed:
7* 2.13.0 -- i.MX 8MNULite, 8MN
8* 2.13.1 -- i.MX 8MP
9
10The M33 demo app version of each SoCs are followed:
11* 2.14.0 -- i.MX 8ULP,i.MX 93
diff --git a/recipes-fsl/mcore-demos/imx-m33-demos_2.14.0.bb b/recipes-fsl/mcore-demos/imx-m33-demos_2.14.0.bb
new file mode 100644
index 00000000..4b937a27
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m33-demos_2.14.0.bb
@@ -0,0 +1,15 @@
1# Copyright 2023 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require imx-mcore-demos.inc
5
6LIC_FILES_CHKSUM:mx8ulp-nxp-bsp = "file://COPYING;md5=63a38e9f392d8813d6f1f4d0d6fbe657"
7LIC_FILES_CHKSUM:mx93-nxp-bsp = "file://COPYING;md5=63a38e9f392d8813d6f1f4d0d6fbe657"
8
9SRC_URI[imx8ulp.md5sum] = "8c084435f30319948e037be3b5c4d807"
10SRC_URI[imx8ulp.sha256sum] = "c2f086257251b222ec60307e51874974ec1f4166736a747546055fdac991647b"
11
12SRC_URI[imx93.md5sum] = "5eb97a5afed0aafda98ea5bdc665811c"
13SRC_URI[imx93.sha256sum] = "54ca75f62baf0f197f77837822fe8fb0e4fa2e2450c81dca60d24ca5f59d48bd"
14
15COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp|mx93-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-mcore-demos.inc b/recipes-fsl/mcore-demos/imx-mcore-demos.inc
new file mode 100644
index 00000000..844ed882
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-mcore-demos.inc
@@ -0,0 +1,62 @@
1# Copyright 2017-2021 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "i.MX M4/M7/M33 core Demo images"
5SECTION = "app"
6LICENSE = "Proprietary"
7
8inherit deploy fsl-eula-unpack
9
10SOC ?= "INVALID"
11SOC:mx7ulp-nxp-bsp = "imx7ulp"
12SOC:mx8dxl-nxp-bsp = "imx8dxl"
13SOC:mx8mm-nxp-bsp = "imx8mm"
14SOC:mx8mn-nxp-bsp = "imx8mn"
15SOC:mx8mnul-nxp-bsp = "imx8mnddr3l"
16SOC:mx8mp-nxp-bsp = "imx8mp"
17SOC:mx8mpul-nxp-bsp = "imx8mp"
18SOC:mx8mq-nxp-bsp = "imx8mq"
19SOC:mx8qm-nxp-bsp = "imx8qm"
20SOC:mx8qxp-nxp-bsp = "imx8qx"
21SOC:mx8dx-nxp-bsp = "imx8qx"
22SOC:mx8ulp-nxp-bsp = "imx8ulp"
23SOC:mx93-nxp-bsp = "imx93"
24
25MCORE_TYPE ?= "m4"
26MCORE_TYPE:mx8mn-nxp-bsp = "m7"
27MCORE_TYPE:mx8mnul-nxp-bsp = "m7"
28MCORE_TYPE:mx8mp-nxp-bsp = "m7"
29MCORE_TYPE:mx8mpul-nxp-bsp = "m7"
30MCORE_TYPE:mx8ulp-nxp-bsp = "m33"
31MCORE_TYPE:mx93-nxp-bsp = "m33"
32
33SRC_URI = "${FSL_MIRROR}/${SOC}-${MCORE_TYPE}-demo-${PV}.bin;name=${SOC};fsl-eula=true"
34
35S = "${WORKDIR}/${SOC}-${MCORE_TYPE}-demo-${PV}"
36
37#SRC_URI="https://www.nxp.com/lgfiles/NMG/MAD/YOCTO//imx93-m33-demo-2.14.0.bin;fsl-eula=true;name=imx93"
38
39
40SCR = "SCR-${SOC}-${MCORE_TYPE}-demo.txt"
41
42do_install () {
43 # install elf format binary to /lib/firmware
44 install -d ${D}${base_libdir}/firmware
45 install -m 0644 ${S}/*.elf ${D}${base_libdir}/firmware
46}
47
48DEPLOY_FILE_EXT ?= "bin"
49DEPLOY_FILE_EXT:mx7ulp-nxp-bsp = "img"
50
51do_deploy () {
52 # Install the demo binaries
53 install -m 0644 ${S}/*.${DEPLOY_FILE_EXT} ${DEPLOYDIR}/
54}
55
56addtask deploy after do_install
57
58PACKAGE_ARCH = "${MACHINE_SOCARCH}"
59
60FILES:${PN} = "${nonarch_base_libdir}/firmware"
61
62INSANE_SKIP:${PN} = "arch"