summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-07-25 07:58:23 -0300
committerGitHub <noreply@github.com>2023-07-25 07:58:23 -0300
commit4b8c4612f4dda57489d8f465387e05c87decfc05 (patch)
treec10756c5de95ba0d25a2578bfb67eb5c22c864ae
parent1fec47836b5d077acb0417d561a09fecc64ac62f (diff)
parent6e097f563928b3ac9e2b472433eabbc08a094e93 (diff)
downloadmeta-freescale-4b8c4612f4dda57489d8f465387e05c87decfc05.tar.gz
Merge pull request #1620 from junzhuimx/master
Update rcw/uefi/mc-utils/dp-firmware-cadence to L6.1.22-2.0.0 release
-rw-r--r--recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_20.04.bb30
-rw-r--r--recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_22.04.bb29
-rw-r--r--recipes-bsp/mc-utils/mc-utils_git.bb2
-rw-r--r--recipes-bsp/rcw/rcw_git.bb2
-rw-r--r--recipes-bsp/uefi/uefi_git.bb2
5 files changed, 32 insertions, 33 deletions
diff --git a/recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_20.04.bb b/recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_20.04.bb
deleted file mode 100644
index 7b77e6f8..00000000
--- a/recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_20.04.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1SUMMARY = "DP firmware"
2LICENSE = "Proprietary"
3LIC_FILES_CHKSUM = "file://COPYING;md5=228c72f2a91452b8a03c4cab30f30ef9"
4
5inherit deploy fsl-eula-unpack
6
7SRC_URI = "https://www.nxp.com/lgfiles/sdk/lsdk2004/firmware-cadence-lsdk2004.bin;fsl-eula=true"
8
9SRC_URI[md5sum] = "d7eb8ef87cae8e4a205c266b3ac6f330"
10SRC_URI[sha256sum] = "bef89a3eceed95e90748a2301d6f6ffbdf1a72237c0045093cb9485b05eb8fbd"
11
12S = "${WORKDIR}/firmware-cadence-lsdk2004"
13
14do_install () {
15 install -d ${D}/boot
16 cp -fr ${S}/dp/*.bin ${D}/boot
17}
18
19do_deploy () {
20 install -d ${DEPLOYDIR}/dp
21 cp -fr ${S}/dp/*.bin ${DEPLOYDIR}/dp
22}
23addtask deploy before do_build after do_install
24
25PACKAGES += "${PN}-image"
26FILES:${PN}-image += "/boot"
27
28COMPATIBLE_MACHINE = "(qoriq-arm64)"
29PACKAGE_ARCH = "${MACHINE_ARCH}"
30
diff --git a/recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_22.04.bb b/recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_22.04.bb
new file mode 100644
index 00000000..5cf543ab
--- /dev/null
+++ b/recipes-bsp/dp-firmware-cadence/dp-firmware-cadence_22.04.bb
@@ -0,0 +1,29 @@
1SUMMARY = "DP firmware"
2LICENSE = "Proprietary"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d3c315c6eaa43e07d8c130dc3a04a011"
4
5inherit deploy fsl-eula-unpack
6
7SRC_URI = "${FSL_MIRROR}/firmware-imx-8.16.bin;fsl-eula=true"
8
9SRC_URI[md5sum] = "9ed2923c0eb511c7fcf37dd607944124"
10SRC_URI[sha256sum] = "65f829a9e2597bffc58a680aaefa638122144a083633d1ae09b3aec1d9f8ab84"
11
12S = "${WORKDIR}/firmware-imx-8.16"
13
14do_install () {
15 install -d ${D}/boot
16 install -m 0644 ${S}/firmware/hdmi/cadence/dp_ls1028a.bin ${D}/boot/ls1028a-dp-fw.bin
17}
18
19do_deploy () {
20 install -d ${DEPLOYDIR}/dp
21 install -m 0644 ${S}/firmware/hdmi/cadence/dp_ls1028a.bin ${DEPLOYDIR}/dp/ls1028a-dp-fw.bin
22}
23addtask deploy before do_build after do_install
24
25PACKAGES += "${PN}-image"
26FILES:${PN}-image += "/boot"
27
28COMPATIBLE_MACHINE = "(qoriq-arm64)"
29PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/mc-utils/mc-utils_git.bb b/recipes-bsp/mc-utils/mc-utils_git.bb
index fc0486e0..568096c4 100644
--- a/recipes-bsp/mc-utils/mc-utils_git.bb
+++ b/recipes-bsp/mc-utils/mc-utils_git.bb
@@ -8,7 +8,7 @@ DEPENDS += "dtc-native"
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://github.com/nxp-qoriq/mc-utils;protocol=https;nobranch=1" 10SRC_URI = "git://github.com/nxp-qoriq/mc-utils;protocol=https;nobranch=1"
11SRCREV = "bc141334051a2e1e3ea2f4eedee8e1165d52e4a5" 11SRCREV = "8efeeac253ff780cbf1382ff40e09436d65e220d"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index 901fed5d..5721313b 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -8,7 +8,7 @@ DEPENDS += "tcl-native"
8inherit deploy siteinfo 8inherit deploy siteinfo
9 9
10SRC_URI = "git://github.com/nxp-qoriq/rcw;protocol=https;nobranch=1" 10SRC_URI = "git://github.com/nxp-qoriq/rcw;protocol=https;nobranch=1"
11SRCREV = "a4db86818de35d0168a48d3f17878ec68fb1cf6d" 11SRCREV = "020dcf0645959afec6705f518e8350476891ef4f"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
14 14
diff --git a/recipes-bsp/uefi/uefi_git.bb b/recipes-bsp/uefi/uefi_git.bb
index 51a8be63..b001a325 100644
--- a/recipes-bsp/uefi/uefi_git.bb
+++ b/recipes-bsp/uefi/uefi_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=343ec8f06efc37467a6de53686fa6315"
6inherit deploy 6inherit deploy
7 7
8SRC_URI = "git://github.com/NXP/qoriq-uefi-binary.git;nobranch=1;protocol=https" 8SRC_URI = "git://github.com/NXP/qoriq-uefi-binary.git;nobranch=1;protocol=https"
9SRCREV = "d887e52b7a50c7d20fd8200cd741ac61309e0af2" 9SRCREV = "15deb924ff063007592ee647602dd454353f5aee"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12