summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-08-01 08:24:30 -0300
committerGitHub <noreply@github.com>2023-08-01 08:24:30 -0300
commit29758cce6b676ecee9b654954bd4aa94f4b94d9e (patch)
tree9518d5f995dfbf6bc64b2b9e6958cb44db78b01b
parent992973ab4bdbabd21a2c1f2cea86d85e60a79c5e (diff)
parent92c5a2650353f18580df13e4a344a4142ab300ea (diff)
downloadmeta-freescale-29758cce6b676ecee9b654954bd4aa94f4b94d9e.tar.gz
Merge pull request #1630 from dv1/imxdmabuffer-imxvpuapi-gstimx-upgrades
Upgrades for libimxdmabuffer, libimxvpuapi2, gstreamer-imx
-rw-r--r--recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch28
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb (renamed from recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb)3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb)16
-rw-r--r--recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb (renamed from recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb)7
4 files changed, 17 insertions, 37 deletions
diff --git a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch b/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
deleted file mode 100644
index 490d3a2f..00000000
--- a/recipes-bsp/libimxdmabuffer/files/0001-g2d-Fix-typo.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 41825b11289be251fed64470893d18b89b0dd38b Mon Sep 17 00:00:00 2001
2From: Carlos Rafael Giani <crg7475@mailbox.org>
3Date: Sun, 8 May 2022 16:25:44 +0200
4Subject: [PATCH] g2d: Fix typo
5
6Signed-off-by: Carlos Rafael Giani <crg7475@mailbox.org>
7
8Upstream-Status: Backport [41825b11289be251fed64470893d18b89b0dd38b]
9---
10 imxdmabuffer/imxdmabuffer_g2d_allocator.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/imxdmabuffer/imxdmabuffer_g2d_allocator.c b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
14index f10a909..497dcea 100644
15--- a/imxdmabuffer/imxdmabuffer_g2d_allocator.c
16+++ b/imxdmabuffer/imxdmabuffer_g2d_allocator.c
17@@ -139,7 +139,7 @@ static uint8_t* imx_dma_buffer_g2d_allocator_map(ImxDmaBufferAllocator *allocato
18 * (Other allocators perform more steps than this.) */
19 if (imx_g2d_buffer->mapping_refcount > 0)
20 {
21- assert((imx_dwl_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
22+ assert((imx_g2d_buffer->map_flags & flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK) == (flags & IMX_DMA_BUFFER_MAPPING_READWRITE_FLAG_MASK));
23 imx_g2d_buffer->mapping_refcount++;
24 }
25 else
26--
272.32.0
28
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
index 090593be..b160c31d 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.2.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.1.3.bb
@@ -8,9 +8,8 @@ SECTION = "base"
8PV .= "+git${SRCPV}" 8PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "5410b44fb0c5bbd9fb1f3ba0681e65068d8cde57" 11SRCREV = "faf547cc2345bfbf95507ab7e86530f85289bb5b"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://0001-g2d-Fix-typo.patch \
14 file://run-ptest \ 13 file://run-ptest \
15 " 14 "
16 15
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
index fb18f1bb..70ae8937 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.1.0.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_2.2.0.bb
@@ -15,7 +15,7 @@ RDEPENDS:gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparser
15PV .= "+git${SRCPV}" 15PV .= "+git${SRCPV}"
16 16
17SRCBRANCH ?= "master" 17SRCBRANCH ?= "master"
18SRCREV = "b1e5cca1a6df9d2c0dc505ae222775798108d340" 18SRCREV = "cb3cd45676e808b222ac573e8a118f44fd70c288"
19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https" 19SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH};protocol=https"
20 20
21S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
@@ -31,18 +31,24 @@ LIBG2D_DEPENDENCIES = "virtual/libg2d"
31LIBG2D_DPU_OPTION:imxdpu = "-Dg2d-based-on-dpu=true" 31LIBG2D_DPU_OPTION:imxdpu = "-Dg2d-based-on-dpu=true"
32LIBG2D_DEPENDENCIES:imxdpu = "virtual/libg2d libdrm" 32LIBG2D_DEPENDENCIES:imxdpu = "virtual/libg2d libdrm"
33 33
34EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX}" 34# v4l2-amphion and v4l2-isi are meant for the Amphion Malone
35# VPU decoder and the ISI drivers in older kernels, which had
36# lots of bugs that required nontrivial workarounds. In the
37# kernels in this release, newer drivers are present, which
38# obviate the need for these special elements.
39EXTRA_OEMESON += "-Dimx-headers-path=${STAGING_INCDIR_IMX} -Dv4l2-amphion=disabled -Dv4l2-isi=false"
35 40
36PACKAGECONFIG ?= "uniaudiodec" 41PACKAGECONFIG ?= "uniaudiodec"
37PACKAGECONFIG:append:imxgpu2d = " g2d" 42PACKAGECONFIG:append:imxgpu2d = " g2d"
38PACKAGECONFIG:append:imxvpu = " vpu" 43PACKAGECONFIG:append:imxvpu = " vpu"
39PACKAGECONFIG:append:imxipu = " ipu" 44PACKAGECONFIG:append:imxipu = " ipu"
40PACKAGECONFIG:append:imxpxp = " pxp" 45PACKAGECONFIG:append:imxpxp = " pxp"
41# The custom imxv4l2 elements are only available on the i.MX6. 46# The custom imxv4l2 source and sink elements are only
47# available on the i.MX6.
42# The 2D blitter sinks require an MXC framebuffer, which 48# The 2D blitter sinks require an MXC framebuffer, which
43# is not available anymore on the i.MX8 (since these SoCs 49# is not available anymore on the i.MX8 (since these SoCs
44# now use KMS instead of the old Linux framebuffer). 50# now use KMS instead of the old Linux framebuffer).
45PACKAGECONFIG:append:mx6-nxp-bsp = " imx2dvideosink v4l2" 51PACKAGECONFIG:append:mx6-nxp-bsp = " imx2dvideosink v4l2-mxc-source-sink"
46PACKAGECONFIG:append:mx7-nxp-bsp = " imx2dvideosink" 52PACKAGECONFIG:append:mx7-nxp-bsp = " imx2dvideosink"
47 53
48PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}" 54PACKAGECONFIG[g2d] = "-Dg2d=enabled ${LIBG2D_DPU_OPTION},-Dg2d=disabled,${LIBG2D_DEPENDENCIES}"
@@ -50,7 +56,7 @@ PACKAGECONFIG[pxp] = "-Dpxp=enabled,-Dpxp=disabled,"
50PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled," 56PACKAGECONFIG[ipu] = "-Dipu=enabled,-Dipu=disabled,"
51PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2" 57PACKAGECONFIG[vpu] = "-Dvpu=enabled,-Dvpu=disabled,libimxvpuapi2"
52PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false," 58PACKAGECONFIG[imx2dvideosink] = "-Dimx2d-videosink=true,-Dimx2d-videosink=false,"
53PACKAGECONFIG[v4l2] = "-Dv4l2=true,-Dv4l2=false," 59PACKAGECONFIG[v4l2-mxc-source-sink] = "-Dv4l2-mxc-source-sink=true,-Dv4l2-mxc-source-sink=false,"
54PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec" 60PACKAGECONFIG[uniaudiodec] = "-Duniaudiodec=enabled,-Duniaudiodec=disabled,imx-codec"
55PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec" 61PACKAGECONFIG[mp3encoder] = "-Dmp3encoder=enabled,-Dmp3encoder=disabled,imx-codec"
56 62
diff --git a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb
index b7f43a61..1e7d8252 100644
--- a/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.2.2.bb
+++ b/recipes-multimedia/libimxvpuapi/libimxvpuapi2_2.3.0.bb
@@ -4,11 +4,14 @@ LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=38fa42a5a6425b26d2919b17b1527324"
5SECTION = "multimedia" 5SECTION = "multimedia"
6DEPENDS = "virtual/imxvpu libimxdmabuffer" 6DEPENDS = "virtual/imxvpu libimxdmabuffer"
7# Add imx-vpu-hantro-vc as dependency for being
8# able to encode video using the VC8000E encoder
9DEPENDS:append:mx8mp-nxp-bsp = " imx-vpu-hantro-vc"
7 10
8PV .= "+git${SRCPV}" 11PV .= "+git${SRCPV}"
9 12
10SRCBRANCH ?= "master" 13SRCBRANCH ?= "master"
11SRCREV = "b6486118d47937cd717c4881158dda6e72cf2855" 14SRCREV = "6f803f46d6b53a08cf02fc3d440072e01e2f3a09"
12SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https" 15SRC_URI = "git://github.com/Freescale/libimxvpuapi.git;branch=${SRCBRANCH};protocol=https"
13 16
14S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
@@ -18,7 +21,7 @@ inherit waf pkgconfig use-imx-headers
18IMX_PLATFORM:mx6-nxp-bsp = "imx6" 21IMX_PLATFORM:mx6-nxp-bsp = "imx6"
19IMX_PLATFORM:mx8mq-nxp-bsp = "imx8m" 22IMX_PLATFORM:mx8mq-nxp-bsp = "imx8m"
20IMX_PLATFORM:mx8mm-nxp-bsp = "imx8mm" 23IMX_PLATFORM:mx8mm-nxp-bsp = "imx8mm"
21IMX_PLATFORM:mx8mp-nxp-bsp = "imx8m" 24IMX_PLATFORM:mx8mp-nxp-bsp = "imx8mp"
22 25
23EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}" 26EXTRA_OECONF = "--imx-platform=${IMX_PLATFORM} --libdir=${libdir} --imx-headers=${STAGING_INCDIR_IMX} --sysroot-path=${RECIPE_SYSROOT}"
24 27