summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-06-06 11:27:22 +0200
committerMax Krummenacher <max.krummenacher@toradex.com>2022-06-06 12:59:03 +0200
commit2a6149309783401d271e13d6e6cf76135df2fed1 (patch)
tree89290ae9cc54c729b43bd65d0a2ba85fc9b2009e
parent8770de5876704956b34f63e5bbde8a77912a4480 (diff)
downloadmeta-freescale-2a6149309783401d271e13d6e6cf76135df2fed1.tar.gz
alsa-lib: drop not applying patch
With the update from v1.2.6.1 to v1.2.7 the patch no longer applies. The patched code sections have been refactored to be provided from a common helper functions [1] and the code has been reworked to better cope with suspend e.g. [2]. As it is unclear how to reproduce what the patch tries to fix just drop the patch for now to keep the recipe building. At least aplay and arecord still work, if aplay is interrupted with a suspend/resume cycle playing restarts on resume. (This on a Apalis iMX6, SGTL5000 codec). [1] https://github.com/alsa-project/alsa-lib/commit/3577a7a26beb74285af776fbd499b519723a955a [2] https://github.com/alsa-project/alsa-lib/commit/b3ce9cb8391654b6924868b0393cc33ef653268b Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
-rw-r--r--recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch67
-rw-r--r--recipes-multimedia/alsa/alsa-lib_%.bbappend1
2 files changed, 0 insertions, 68 deletions
diff --git a/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch b/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch
deleted file mode 100644
index 896d9426..00000000
--- a/recipes-multimedia/alsa/alsa-lib/0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1From 09c1a959e7d007e00741606f69444c1f865a4beb Mon Sep 17 00:00:00 2001
2From: Shengjiu Wang <shengjiu.wang@freescale.com>
3Date: Tue, 10 May 2016 15:09:26 +0800
4Subject: [PATCH] pcm: Don't store the state for SND_PCM_STATE_SUSPENDED
5
6The resume function don't update the dmix->state, if store SUSPENDED
7state in snd_pcm_dmix_state, the write function after resume will
8return error -ESTRPIPE, because the snd_pcm_write_areas() will check
9the state of the pcm device.
10This patch remove the store SND_PCM_STATE_SUSPENDED state operation
11for dmix,dshare,dsnoop.
12
13Upstream-Status: Pending
14
15Signed-off-by: Shengjiu Wang <shengjiu.wang@freescale.com>
16
17---
18 src/pcm/pcm_dmix.c | 2 +-
19 src/pcm/pcm_dshare.c | 2 +-
20 src/pcm/pcm_dsnoop.c | 2 +-
21 3 files changed, 3 insertions(+), 3 deletions(-)
22
23diff --git a/src/pcm/pcm_dmix.c b/src/pcm/pcm_dmix.c
24index 608593f..3d068c7 100644
25--- a/src/pcm/pcm_dmix.c
26+++ b/src/pcm/pcm_dmix.c
27@@ -460,9 +460,9 @@ static snd_pcm_state_t snd_pcm_dmix_state(snd_pcm_t *pcm)
28 snd_pcm_state_t state;
29 state = snd_pcm_state(dmix->spcm);
30 switch (state) {
31- case SND_PCM_STATE_SUSPENDED:
32 case SND_PCM_STATE_DISCONNECTED:
33 dmix->state = state;
34+ case SND_PCM_STATE_SUSPENDED:
35 return state;
36 case SND_PCM_STATE_XRUN:
37 if ((err = snd_pcm_direct_slave_recover(dmix)) < 0)
38diff --git a/src/pcm/pcm_dshare.c b/src/pcm/pcm_dshare.c
39index a918512..18071fb 100644
40--- a/src/pcm/pcm_dshare.c
41+++ b/src/pcm/pcm_dshare.c
42@@ -258,9 +258,9 @@ static snd_pcm_state_t snd_pcm_dshare_state(snd_pcm_t *pcm)
43 snd_pcm_state_t state;
44 state = snd_pcm_state(dshare->spcm);
45 switch (state) {
46- case SND_PCM_STATE_SUSPENDED:
47 case SND_PCM_STATE_DISCONNECTED:
48 dshare->state = state;
49+ case SND_PCM_STATE_SUSPENDED:
50 return state;
51 case SND_PCM_STATE_XRUN:
52 if ((err = snd_pcm_direct_slave_recover(dshare)) < 0)
53diff --git a/src/pcm/pcm_dsnoop.c b/src/pcm/pcm_dsnoop.c
54index 2c3b9f4..3b711ab 100644
55--- a/src/pcm/pcm_dsnoop.c
56+++ b/src/pcm/pcm_dsnoop.c
57@@ -209,9 +209,9 @@ static snd_pcm_state_t snd_pcm_dsnoop_state(snd_pcm_t *pcm)
58 snd_pcm_state_t state;
59 state = snd_pcm_state(dsnoop->spcm);
60 switch (state) {
61- case SND_PCM_STATE_SUSPENDED:
62 case SND_PCM_STATE_DISCONNECTED:
63 dsnoop->state = state;
64+ case SND_PCM_STATE_SUSPENDED:
65 return state;
66 case SND_PCM_STATE_XRUN:
67 if ((err = snd_pcm_direct_slave_recover(dsnoop)) < 0)
diff --git a/recipes-multimedia/alsa/alsa-lib_%.bbappend b/recipes-multimedia/alsa/alsa-lib_%.bbappend
index 8a13d4c1..0b4ddc9b 100644
--- a/recipes-multimedia/alsa/alsa-lib_%.bbappend
+++ b/recipes-multimedia/alsa/alsa-lib_%.bbappend
@@ -2,7 +2,6 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2 2
3IMX_PATCH = " \ 3IMX_PATCH = " \
4 file://0001-add-conf-for-multichannel-support-in-imx.patch \ 4 file://0001-add-conf-for-multichannel-support-in-imx.patch \
5 file://0004-pcm-Don-t-store-the-state-for-SND_PCM_STATE_SUSPENDE.patch \
6 file://0005-add-ak4458-conf-for-multichannel-support.patch \ 5 file://0005-add-ak4458-conf-for-multichannel-support.patch \
7 file://0006-add-conf-for-iMX-XCVR-sound-card.patch \ 6 file://0006-add-conf-for-iMX-XCVR-sound-card.patch \
8" 7"