summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-07-25 19:40:12 -0300
committerGitHub <noreply@github.com>2022-07-25 19:40:12 -0300
commit15098843f469944ad5c374f4babc7c50163ab1dc (patch)
treeea14f91e1f03ae5c34ef767baf83bb64bf94d990
parent912908ce41427c6510b2b6464c83e12f6f11a0e4 (diff)
parent237f04e8b1967ef5615fa888657f8766bd52c287 (diff)
downloadmeta-freescale-15098843f469944ad5c374f4babc7c50163ab1dc.tar.gz
Merge pull request #1144 from Freescale/topic/qoirq-rework
[qoriq] Rework cst and optee recipes
-rw-r--r--conf/machine/include/qoriq-base.inc2
-rw-r--r--recipes-bsp/atf/qoriq-atf_2.4.bb2
-rw-r--r--recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch (renamed from recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch)0
-rw-r--r--recipes-devtools/qoriq-cst/qoriq-cst_git.bb (renamed from recipes-devtools/cst/cst_git.bb)2
-rw-r--r--recipes-security/optee-qoriq/optee-client-qoriq_3.13.0.bb (renamed from recipes-security/optee/optee-client-qoriq_3.13.0.bb)0
-rw-r--r--recipes-security/optee-qoriq/optee-client.nxp.inc (renamed from recipes-security/optee/optee-client.nxp.inc)0
-rw-r--r--recipes-security/optee-qoriq/optee-client/tee-supplicant.service (renamed from recipes-security/optee/optee-client/tee-supplicant.service)0
-rw-r--r--recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb (renamed from recipes-security/optee/optee-os-qoriq_3.13.0.bb)0
-rw-r--r--recipes-security/optee-qoriq/optee-os.nxp.inc (renamed from recipes-security/optee/optee-os.nxp.inc)0
-rw-r--r--recipes-security/optee-qoriq/optee-test-qoriq_3.13.0.bb (renamed from recipes-security/optee/optee-test-qoriq_3.13.0.bb)0
-rw-r--r--recipes-security/optee-qoriq/optee-test.nxp.inc (renamed from recipes-security/optee/optee-test.nxp.inc)0
11 files changed, 3 insertions, 3 deletions
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc
index 35b7d82e..4340c942 100644
--- a/conf/machine/include/qoriq-base.inc
+++ b/conf/machine/include/qoriq-base.inc
@@ -39,7 +39,7 @@ WKS_FILE ?= "${SOC_DEFAULT_WKS_FILE}"
39MACHINE_FEATURES ?= "pci ext2 ext3 serial" 39MACHINE_FEATURES ?= "pci ext2 ext3 serial"
40MACHINE_EXTRA_RRECOMMENDS += "udev-extraconf udev-rules-qoriq kernel-modules" 40MACHINE_EXTRA_RRECOMMENDS += "udev-extraconf udev-rules-qoriq kernel-modules"
41 41
42EXTRA_IMAGEDEPENDS += "u-boot cst-native" 42EXTRA_IMAGEDEPENDS += "u-boot qoriq-cst-native"
43 43
44MACHINEOVERRIDES =. "qoriq:" 44MACHINEOVERRIDES =. "qoriq:"
45 45
diff --git a/recipes-bsp/atf/qoriq-atf_2.4.bb b/recipes-bsp/atf/qoriq-atf_2.4.bb
index b6716272..ec953297 100644
--- a/recipes-bsp/atf/qoriq-atf_2.4.bb
+++ b/recipes-bsp/atf/qoriq-atf_2.4.bb
@@ -2,7 +2,7 @@ require recipes-bsp/atf/qoriq-atf-2.4.inc
2 2
3inherit deploy 3inherit deploy
4 4
5DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native rcw cst-native bc-native" 5DEPENDS += "u-boot-mkimage-native u-boot openssl openssl-native rcw qoriq-cst-native bc-native"
6DEPENDS:append:lx2160a = " ddr-phy" 6DEPENDS:append:lx2160a = " ddr-phy"
7DEPENDS:append:lx2162a = " ddr-phy" 7DEPENDS:append:lx2162a = " ddr-phy"
8do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" 8do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy"
diff --git a/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
index d25675aa..d25675aa 100644
--- a/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
+++ b/recipes-devtools/qoriq-cst/qoriq-cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
index b9ac3e9e..ca0f35fb 100644
--- a/recipes-devtools/cst/cst_git.bb
+++ b/recipes-devtools/qoriq-cst/qoriq-cst_git.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD-3-Clause"
4 4
5LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff" 5LIC_FILES_CHKSUM = "file://COPYING;md5=e959d5d617e33779d0e90ce1d9043eff"
6 6
7DEPENDS += "openssl cst-native" 7DEPENDS += "openssl qoriq-cst-native"
8RDEPENDS:${PN} = "bash" 8RDEPENDS:${PN} = "bash"
9 9
10GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys" 10GENKEYS ?= "${STAGING_BINDIR_NATIVE}/cst/gen_keys"
diff --git a/recipes-security/optee/optee-client-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-client-qoriq_3.13.0.bb
index 94123e43..94123e43 100644
--- a/recipes-security/optee/optee-client-qoriq_3.13.0.bb
+++ b/recipes-security/optee-qoriq/optee-client-qoriq_3.13.0.bb
diff --git a/recipes-security/optee/optee-client.nxp.inc b/recipes-security/optee-qoriq/optee-client.nxp.inc
index fa187e84..fa187e84 100644
--- a/recipes-security/optee/optee-client.nxp.inc
+++ b/recipes-security/optee-qoriq/optee-client.nxp.inc
diff --git a/recipes-security/optee/optee-client/tee-supplicant.service b/recipes-security/optee-qoriq/optee-client/tee-supplicant.service
index 0e2b4f6b..0e2b4f6b 100644
--- a/recipes-security/optee/optee-client/tee-supplicant.service
+++ b/recipes-security/optee-qoriq/optee-client/tee-supplicant.service
diff --git a/recipes-security/optee/optee-os-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb
index 3c3652d3..3c3652d3 100644
--- a/recipes-security/optee/optee-os-qoriq_3.13.0.bb
+++ b/recipes-security/optee-qoriq/optee-os-qoriq_3.13.0.bb
diff --git a/recipes-security/optee/optee-os.nxp.inc b/recipes-security/optee-qoriq/optee-os.nxp.inc
index 72af6ca4..72af6ca4 100644
--- a/recipes-security/optee/optee-os.nxp.inc
+++ b/recipes-security/optee-qoriq/optee-os.nxp.inc
diff --git a/recipes-security/optee/optee-test-qoriq_3.13.0.bb b/recipes-security/optee-qoriq/optee-test-qoriq_3.13.0.bb
index 69ef73d3..69ef73d3 100644
--- a/recipes-security/optee/optee-test-qoriq_3.13.0.bb
+++ b/recipes-security/optee-qoriq/optee-test-qoriq_3.13.0.bb
diff --git a/recipes-security/optee/optee-test.nxp.inc b/recipes-security/optee-qoriq/optee-test.nxp.inc
index e3ba0c8e..e3ba0c8e 100644
--- a/recipes-security/optee/optee-test.nxp.inc
+++ b/recipes-security/optee-qoriq/optee-test.nxp.inc