summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-03-10 08:26:59 -0300
committerGitHub <noreply@github.com>2023-03-10 08:26:59 -0300
commit006150473048c94d32a9bd255f09525a286c2b7c (patch)
tree9155ca31104ab67f811952097a34e3156bebfd07
parentba70f6a7139b16984e4e6e29f24dfe86582d09b4 (diff)
parentdb5b46f714bb14a7daa77e20c0121c3e2ba68580 (diff)
downloadmeta-freescale-006150473048c94d32a9bd255f09525a286c2b7c.tar.gz
Merge pull request #1448 from quaresmajose/gst
gstreamer: rename the version to be imx specific
-rw-r--r--conf/machine/include/imx-base.inc6
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-libav_1.20.3.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-libav_1.20.3.bb)5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb)5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.20.3.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.20.3.bb)5
4 files changed, 18 insertions, 3 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 741d23ac..a454c913 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -476,9 +476,9 @@ PREFERRED_VERSION_gstreamer1.0:mx8-nxp-bsp ??= "1.20.3.imx"
476PREFERRED_VERSION_gstreamer1.0-plugins-base:mx8-nxp-bsp ??= "1.20.3.imx" 476PREFERRED_VERSION_gstreamer1.0-plugins-base:mx8-nxp-bsp ??= "1.20.3.imx"
477PREFERRED_VERSION_gstreamer1.0-plugins-good:mx8-nxp-bsp ??= "1.20.3.imx" 477PREFERRED_VERSION_gstreamer1.0-plugins-good:mx8-nxp-bsp ??= "1.20.3.imx"
478PREFERRED_VERSION_gstreamer1.0-plugins-bad:mx8-nxp-bsp ??= "1.20.3.imx" 478PREFERRED_VERSION_gstreamer1.0-plugins-bad:mx8-nxp-bsp ??= "1.20.3.imx"
479PREFERRED_VERSION_gstreamer1.0-plugins-ugly:mx8-nxp-bsp ??= "1.20.3" 479PREFERRED_VERSION_gstreamer1.0-plugins-ugly:mx8-nxp-bsp ??= "1.20.3.imx"
480PREFERRED_VERSION_gstreamer1.0-libav:mx8-nxp-bsp ??= "1.20.3" 480PREFERRED_VERSION_gstreamer1.0-libav:mx8-nxp-bsp ??= "1.20.3.imx"
481PREFERRED_VERSION_gstreamer1.0-rtsp-server:mx8-nxp-bsp ??= "1.20.3" 481PREFERRED_VERSION_gstreamer1.0-rtsp-server:mx8-nxp-bsp ??= "1.20.3.imx"
482PREFERRED_VERSION_ffmpeg:mx8-nxp-bsp ??= "4.4.1" 482PREFERRED_VERSION_ffmpeg:mx8-nxp-bsp ??= "4.4.1"
483 483
484# Determines if the SoC has support for Vivante kernel driver 484# Determines if the SoC has support for Vivante kernel driver
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.20.3.bb b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.20.3.imx.bb
index e0ee5778..a3f22a0d 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.20.3.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.20.3.imx.bb
@@ -29,4 +29,9 @@ EXTRA_OEMESON += " \
29FILES:${PN} += "${libdir}/gstreamer-1.0/*.so" 29FILES:${PN} += "${libdir}/gstreamer-1.0/*.so"
30FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a" 30FILES:${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
31 31
32# These recipes are copies of oe-core 1.20.3 that are not available
33# anymore upstream on the master branch.
34# The requirement to have them is because they are dependencies of
35# the other ones imx specific gstreamer forks on the layer.
36# So make their names maching the exisng ones will make it more safe.
32COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 37COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb
index 9511984e..d961c5af 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.20.3.imx.bb
@@ -45,4 +45,9 @@ EXTRA_OEMESON += " \
45FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs" 45FILES:${PN}-amrnb += "${datadir}/gstreamer-1.0/presets/GstAmrnbEnc.prs"
46FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs" 46FILES:${PN}-x264 += "${datadir}/gstreamer-1.0/presets/GstX264Enc.prs"
47 47
48# These recipes are copies of oe-core 1.20.3 that are not available
49# anymore upstream on the master branch.
50# The requirement to have them is because they are dependencies of
51# the other ones imx specific gstreamer forks on the layer.
52# So make their names maching the exisng ones will make it more safe.
48COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 53COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.20.3.bb b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.20.3.imx.bb
index 992dbda8..172cb083 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.20.3.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.20.3.imx.bb
@@ -30,4 +30,9 @@ require recipes-multimedia/gstreamer/gstreamer1.0-plugins-packaging.inc
30 30
31CVE_PRODUCT += "gst-rtsp-server" 31CVE_PRODUCT += "gst-rtsp-server"
32 32
33# These recipes are copies of oe-core 1.20.3 that are not available
34# anymore upstream on the master branch.
35# The requirement to have them is because they are dependencies of
36# the other ones imx specific gstreamer forks on the layer.
37# So make their names maching the exisng ones will make it more safe.
33COMPATIBLE_MACHINE = "(imx-nxp-bsp)" 38COMPATIBLE_MACHINE = "(imx-nxp-bsp)"