summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-08-03 08:31:43 -0700
committerKhem Raj <raj.khem@gmail.com>2023-08-07 09:01:39 -0700
commita92a9d0fd5ff1134e2e42c2a9e53cf38e51cede2 (patch)
tree2ebcc335518ede7a157ac39986ce0247f6d1c298
parent9b00d40b787c2b7105ce209f5635cc1a0cab81ca (diff)
downloadmeta-freescale-a92a9d0fd5ff1134e2e42c2a9e53cf38e51cede2.tar.gz
Revert "imx-atf: Explicitly demand BFD linker"
This reverts commit 535a46d8fd17ef4fe5588e90c6fd741ef8537a28.
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.8.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.8.bb b/recipes-bsp/imx-atf/imx-atf_2.8.bb
index b6acd13d..c1fd562c 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.8.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.8.bb
@@ -48,7 +48,7 @@ def remove_options_tail (in_string):
48 from itertools import takewhile 48 from itertools import takewhile
49 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 49 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
50 50
51EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}.bfd"' 51EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
52 52
53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
54 54