summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-08-08 08:14:59 -0300
committerGitHub <noreply@github.com>2023-08-08 08:14:59 -0300
commit863c8117920280d922d48efbce3ffdc4318d5526 (patch)
tree5867d5e9894a18da6d0d42e832c7968ba4f1f22c
parent9b00d40b787c2b7105ce209f5635cc1a0cab81ca (diff)
parentf46655cad34c3f3dbfbb8a2bfceded0877a70409 (diff)
downloadmeta-freescale-863c8117920280d922d48efbce3ffdc4318d5526.tar.gz
Merge pull request #1638 from YoeDistro/yoe/mut
musl fixes
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.8.bb2
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc5
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocator-Fix-typcasts.patch47
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb1
4 files changed, 54 insertions, 1 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.8.bb b/recipes-bsp/imx-atf/imx-atf_2.8.bb
index b6acd13d..c1fd562c 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.8.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.8.bb
@@ -48,7 +48,7 @@ def remove_options_tail (in_string):
48 from itertools import takewhile 48 from itertools import takewhile
49 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 49 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
50 50
51EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}.bfd"' 51EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
52 52
53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
54 54
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index 59d1716f..64f367a4 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -424,3 +424,8 @@ FILES:imx-gpu-viv-demos = "/opt"
424INSANE_SKIP:imx-gpu-viv-demos += "rpaths dev-deps" 424INSANE_SKIP:imx-gpu-viv-demos += "rpaths dev-deps"
425 425
426FILES:libnn-imx = "${libdir}/libNN*${SOLIBS}" 426FILES:libnn-imx = "${libdir}/libNN*${SOLIBS}"
427
428# It will use gcompat at runtime therefore checking for these at compile time wont be useful as
429# they dont match musl/gcompat but it should run fine
430INSANE_SKIP:append:libc-musl = " file-rdeps"
431
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocator-Fix-typcasts.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocator-Fix-typcasts.patch
new file mode 100644
index 00000000..3ab4bab4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocator-Fix-typcasts.patch
@@ -0,0 +1,47 @@
1From 90b94ff95c72487054fd283fb7cb5ebd13822b3f Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 7 Aug 2023 18:56:05 -0700
4Subject: [PATCH] gstallocator: Fix typcasts
5
6These are found when building with clang+musl
7| ../git/gst-libs/gst/allocators/gstallocatorphymem.c:228:10: error: incompatible pointer to integer conversion returning 'gpointer' (aka 'void *') from a function with result type 'guintptr
8' (aka 'unsigned long') [-Wint-conversion]
9| 228 | return gst_phymem_get_phy (mem);
10| | ^~~~~~~~~~~~~~~~~~~~~~~~
11
12Upstream-Status: Submitted [https://github.com/nxp-imx/gst-plugins-base/pull/4]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 gst-libs/gst/allocators/gstallocatorphymem.c | 2 +-
16 gst-libs/gst/gl/gstglphymemory.c | 2 +-
17 2 files changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/gst-libs/gst/allocators/gstallocatorphymem.c b/gst-libs/gst/allocators/gstallocatorphymem.c
20index f3c3306c7..f8a4511ab 100755
21--- a/gst-libs/gst/allocators/gstallocatorphymem.c
22+++ b/gst-libs/gst/allocators/gstallocatorphymem.c
23@@ -225,7 +225,7 @@ static guintptr
24 gst_allocator_phymem_get_phys_addr (GstPhysMemoryAllocator * allocator,
25 GstMemory * mem)
26 {
27- return gst_phymem_get_phy (mem);
28+ return (guintptr)gst_phymem_get_phy (mem);
29 }
30
31 static void
32diff --git a/gst-libs/gst/gl/gstglphymemory.c b/gst-libs/gst/gl/gstglphymemory.c
33index d82c9a66a..1d8be0a5d 100644
34--- a/gst-libs/gst/gl/gstglphymemory.c
35+++ b/gst-libs/gst/gl/gstglphymemory.c
36@@ -337,7 +337,7 @@ gst_gl_physical_memory_setup_buffer (GstAllocator * allocator,
37 GST_VIDEO_INFO_HEIGHT (info),
38 viv_fmt,
39 memblk->vaddr,
40- memblk->paddr,
41+ (guint)memblk->paddr,
42 FALSE
43 };
44
45--
462.41.0
47
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb
index 04cb5a5b..df0b9912 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.0.imx.bb
@@ -114,6 +114,7 @@ SRC_URI:remove = " \
114 file://0003-viv-fb-Make-sure-config.h-is-included.patch \ 114 file://0003-viv-fb-Make-sure-config.h-is-included.patch \
115 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch" 115 file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch"
116SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} " 116SRC_URI:prepend = "${GST1.0-PLUGINS-BASE_SRC};branch=${SRCBRANCH} "
117SRC_URI:append = " file://0001-gstallocator-Fix-typcasts.patch"
117GST1.0-PLUGINS-BASE_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-base.git;protocol=https" 118GST1.0-PLUGINS-BASE_SRC ?= "gitsm://github.com/nxp-imx/gst-plugins-base.git;protocol=https"
118SRCBRANCH = "MM_04.08.00_2305_L6.1.y" 119SRCBRANCH = "MM_04.08.00_2305_L6.1.y"
119SRCREV = "aaaf7df211523b1835659ae85c510e5615d451d7" 120SRCREV = "aaaf7df211523b1835659ae85c510e5615d451d7"