summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-08-21 11:48:06 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-08-21 12:37:17 -0700
commit049b242ddaf38aa74fc4b99fceb03f38562f03a9 (patch)
treedfaed3077edb249cc71f1b782ea43b334e818ec9
parent74a5b2faa65dbedabbae6055104f7cc61f54df72 (diff)
downloadmeta-freescale-049b242ddaf38aa74fc4b99fceb03f38562f03a9.tar.gz
firmware-sentinel: Upgrade 0.8 -> 0.10
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/firmware-sentinel/firmware-sentinel_0.10.bb27
-rw-r--r--recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb23
2 files changed, 27 insertions, 23 deletions
diff --git a/recipes-bsp/firmware-sentinel/firmware-sentinel_0.10.bb b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.10.bb
new file mode 100644
index 00000000..1b2b2021
--- /dev/null
+++ b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.10.bb
@@ -0,0 +1,27 @@
1# Copyright 2021-2023 NXP
2SUMMARY = "NXP i.MX Sentinel firmware"
3DESCRIPTION = "Firmware for i.MX Sentinel Security Controller"
4SECTION = "base"
5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=63a38e9f392d8813d6f1f4d0d6fbe657"
7
8inherit fsl-eula-unpack use-imx-security-controller-firmware deploy
9
10SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "a92e272d665a3b3bb9281253d5eca69f"
12SRC_URI[sha256sum] = "be862b62c849510cce08ec24c1ddf53d826458e326e5a7f09c4b35092d6f9950"
13
14do_compile[noexec] = "1"
15
16do_install() {
17 install -Dm 0644 ${S}/${SECO_FIRMWARE_NAME} ${D}${nonarch_base_libdir}/firmware/imx/ele/${SECO_FIRMWARE_NAME}
18}
19
20do_deploy() {
21 install -m 0644 ${S}/${SECO_FIRMWARE_NAME} ${DEPLOYDIR}
22}
23addtask deploy after do_compile before do_build
24
25FILES:${PN} += "${nonarch_base_libdir}/firmware/imx/ele/${SECO_FIRMWARE_NAME}"
26
27COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp|mx9-nxp-bsp)"
diff --git a/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb b/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb
deleted file mode 100644
index 50787fd6..00000000
--- a/recipes-bsp/firmware-sentinel/firmware-sentinel_0.8.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1# Copyright 2021-2022 NXP
2SUMMARY = "NXP i.MX Sentinel firmware"
3DESCRIPTION = "Firmware for i.MX Sentinel Security Controller"
4SECTION = "base"
5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
7
8inherit fsl-eula-unpack use-imx-security-controller-firmware deploy nopackages
9
10SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
11SRC_URI[md5sum] = "be47a5e59c1192ee36246af97d5d1532"
12SRC_URI[sha256sum] = "1003d4c6773c153ea341911a74e25c249423644f70f3d8f8d085599e00770b3f"
13
14do_compile[noexec] = "1"
15do_install[noexec] = "1"
16
17do_deploy () {
18 # Deploy the related firmware to be package by imx-boot
19 install -m 0644 ${S}/${SECO_FIRMWARE_NAME} ${DEPLOYDIR}
20}
21addtask deploy after do_install before do_build
22
23COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp|mx9-nxp-bsp)"