summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-05-18 09:54:42 -0300
committerGitHub <noreply@github.com>2023-05-18 09:54:42 -0300
commitcb365fdc9b2740508bac95e13a0f91d70fbbea45 (patch)
treeda3778a9c72ac8d7920ec7153d56dbb4acdd3340
parent46a3c02d353d71e45a8dd758f721c03fe86eb34c (diff)
parentbac5b1e0bbad7ce1ea8ba7d77b2a9eee3fcb618d (diff)
downloadmeta-freescale-cb365fdc9b2740508bac95e13a0f91d70fbbea45.tar.gz
Merge pull request #1538 from thochstein/weston-init
weston-init
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend102
-rw-r--r--recipes-graphics/wayland/weston-init/imx-nxp-bsp/weston.ini11
2 files changed, 58 insertions, 55 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index a742bb86..69a807a3 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -8,64 +8,72 @@ REQUIRED_DISTRO_FEATURES:remove = "${IMX_REQUIRED_DISTRO_FEATURES_REMOVE}"
8 8
9SRC_URI:append:mx6sl-nxp-bsp = " file://weston.config" 9SRC_URI:append:mx6sl-nxp-bsp = " file://weston.config"
10 10
11# To customize weston.ini, start by setting the desired assignment in weston.ini, 11PACKAGECONFIG ??= " \
12# commented in. For example: 12 no-idle-timeout \
13# xwayland=true 13 ${PACKAGECONFIG_GBM_FORMAT} \
14# Then add the assignment to INI_COMMENT_ASSIGNMENTS. 14 ${PACKAGECONFIG_REPAINT_WINDOW} \
15# 15 ${PACKAGECONFIG_SIZE} \
16# commented out. For example: 16 ${PACKAGECONFIG_USE_G2D} \
17# #xwayland=true
18# Then add the assignment to INI_UNCOMMENT_ASSIGNMENTS.
19INI_COMMENT_ASSIGNMENTS:append:imx-mainline-bsp = " \
20 xwayland=true \
21" 17"
22 18
23INI_UNCOMMENT_ASSIGNMENTS:append:mx8-nxp-bsp = " \ 19PACKAGECONFIG_GBM_FORMAT ?= ""
24 repaint-window=16 \ 20PACKAGECONFIG_GBM_FORMAT:mx8mq-nxp-bsp ?= "gbm-format"
25"
26INI_UNCOMMENT_ASSIGNMENTS:append:mx8mq-nxp-bsp = " \
27 gbm-format=argb8888 \
28 \\[shell\\] \
29 size=1920x1080 \
30"
31 21
32# FIXME: The 8QM and 8QXP SoCs have better performance without G2D so don't enable it 22GBM_FORMAT_VALUE:mx8mq-nxp-bsp = "argb8888"
33# Ideally, this should be seamless and Vivante ought to handle it internally and take the fastest
34# rendering code.
35INI_UNCOMMENT_USE_G2D ?= ""
36INI_UNCOMMENT_USE_G2D:imxgpu2d ?= "use-g2d=1"
37INI_UNCOMMENT_USE_G2D:mx8qm-nxp-bsp ?= ""
38INI_UNCOMMENT_USE_G2D:mx8qxp-nxp-bsp ?= ""
39INI_UNCOMMENT_USE_G2D:mx8dx-nxp-bsp ?= ""
40INI_UNCOMMENT_ASSIGNMENTS:append = " \
41 ${INI_UNCOMMENT_USE_G2D} \
42"
43 23
44comment() { 24PACKAGECONFIG_REPAINT_WINDOW ?= ""
45 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then 25PACKAGECONFIG_REPAINT_WINDOW:mx8-nxp-bsp ?= "repaint-window"
46 bbwarn "Commented setting '#$1' not found in file $2" 26PACKAGECONFIG_REPAINT_WINDOW:mx9-nxp-bsp ?= "repaint-window"
47 fi
48 sed -i -e 's,^'"$1"',#'"$1"',g' $2
49}
50 27
51uncomment() { 28PACKAGECONFIG_SIZE ?= ""
52 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then 29PACKAGECONFIG_SIZE:mx8mq-nxp-bsp ?= "size"
53 bbwarn "Commented setting '#$1' not found in file $2" 30
54 fi 31SIZE_VALUE:mx8mq-nxp-bsp = "1920x1080"
55 sed -i -e 's,^#'"$1"','"$1"',g' $2 32
56} 33PACKAGECONFIG_USE_G2D ?= ""
34PACKAGECONFIG_USE_G2D:imxgpu2d ?= "use-g2d"
35PACKAGECONFIG_USE_G2D:mx8qm-nxp-bsp ?= ""
36PACKAGECONFIG_USE_G2D:mx8qxp-nxp-bsp ?= ""
37PACKAGECONFIG_USE_G2D:mx8dx-nxp-bsp ?= ""
38PACKAGECONFIG_USE_G2D:mx93-nxp-bsp ?= "use-g2d"
39
40USE_G2D_VALUE = "true"
41USE_G2D_VALUE:mx6-nxp-bsp = "1"
42USE_G2D_VALUE:mx7-nxp-bsp = "1"
43
44PACKAGECONFIG[gbm-format] = ",,"
45PACKAGECONFIG[rdp] = ",,"
46PACKAGECONFIG[repaint-window] = ",,"
47PACKAGECONFIG[size] = ",,"
48PACKAGECONFIG[use-g2d] = ",,"
57 49
58do_install:append() { 50do_install:append() {
59 if [ -f "${WORKDIR}/weston.config" ]; then 51 if [ -f "${WORKDIR}/weston.config" ]; then
60 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston 52 install -Dm0755 ${WORKDIR}/weston.config ${D}${sysconfdir}/default/weston
61 fi 53 fi
62 54
63 for assignment in ${INI_COMMENT_ASSIGNMENTS}; do 55 if [ "${@bb.utils.contains('PACKAGECONFIG', 'gbm-format', 'yes', 'no', d)}" = "yes" ]; then
64 comment "$assignment" ${D}${sysconfdir}/xdg/weston/weston.ini 56 sed -i -e "/^\[core\]/a gbm-format=${GBM_FORMAT_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
65 done 57 fi
58
59 if [ "${@bb.utils.contains('PACKAGECONFIG', 'rdp', 'yes', 'no', d)}" = "yes" ]; then
60 sed -i -e "s|^command=${bindir}/weston .*|& --rdp-tls-cert=${sysconfdir}/freerdp/keys/server.crt --rdp-tls-key=${sysconfdir}/freerdp/keys/server.key|" ${D}${sysconfdir}/xdg/weston/weston.ini
61 sed -i -e "/^\[core\]/a modules=screen-share.so" ${D}${sysconfdir}/xdg/weston/weston.ini
62 fi
63
64 if [ "${@bb.utils.contains('PACKAGECONFIG', 'repaint-window', 'yes', 'no', d)}" = "yes" ]; then
65 sed -i -e "/^\[core\]/a repaint-window=16" ${D}${sysconfdir}/xdg/weston/weston.ini
66 fi
67
68 if [ "${@bb.utils.contains('PACKAGECONFIG', 'size', 'yes', 'no', d)}" = "yes" ]; then
69 sed -i -e "/^\[shell\]/a size=${SIZE_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
70 fi
71
72 if [ "${@bb.utils.contains('PACKAGECONFIG', 'use-g2d', 'yes', 'no', d)}" = "yes" ]; then
73 sed -i -e "/^\[core\]/a use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
74 else
75 sed -i -e "/^\[core\]/a #use-g2d=${USE_G2D_VALUE}" ${D}${sysconfdir}/xdg/weston/weston.ini
76 fi
66 77
67 for assignment in ${INI_UNCOMMENT_ASSIGNMENTS}; do
68 uncomment "$assignment" ${D}${sysconfdir}/xdg/weston/weston.ini
69 done
70 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini 78 sed -i -e 's,@bindir@,${bindir},g' ${D}${sysconfdir}/xdg/weston/weston.ini
71} 79}
diff --git a/recipes-graphics/wayland/weston-init/imx-nxp-bsp/weston.ini b/recipes-graphics/wayland/weston-init/imx-nxp-bsp/weston.ini
index 3e298973..19e6ad24 100644
--- a/recipes-graphics/wayland/weston-init/imx-nxp-bsp/weston.ini
+++ b/recipes-graphics/wayland/weston-init/imx-nxp-bsp/weston.ini
@@ -1,13 +1,7 @@
1[core] 1[core]
2#gbm-format=argb8888
3idle-time=0
4#use-g2d=1
5#repaint-window=16
6#enable-overlay-view=1 2#enable-overlay-view=1
7modules=screen-share.so
8 3
9#[shell] 4[shell]
10#size=1920x1080
11 5
12[libinput] 6[libinput]
13touchscreen_calibrator=true 7touchscreen_calibrator=true
@@ -27,4 +21,5 @@ touchscreen_calibrator=true
27#transform=rotate-90 21#transform=rotate-90
28 22
29[screen-share] 23[screen-share]
30command=@bindir@/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize --rdp-tls-cert=/etc/freerdp/keys/server.crt --rdp-tls-key=/etc/freerdp/keys/server.key 24command=@bindir@/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
25#start-on-startup=true