summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-05-23 15:52:58 -0300
committerGitHub <noreply@github.com>2023-05-23 15:52:58 -0300
commit17a762639f1d3f355291a3de4767983deaf4493d (patch)
treed423282a664c4909206f4fc7db598481cf6e5ad7
parent194a3566304484f06fb9967e6295a645fcbd8572 (diff)
parentababadce2a55b0993633de70d35ae7e48f37d681 (diff)
downloadmeta-freescale-17a762639f1d3f355291a3de4767983deaf4493d.tar.gz
Merge pull request #1544 from Freescale/topic/drop-lzop-requirement
Remove the need of lzop-native from layer
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_6.1.bb5
-rw-r--r--recipes-kernel/linux/linux-fslc_6.1.bb6
-rw-r--r--recipes-kernel/linux/linux-imx/ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch27
-rw-r--r--recipes-kernel/linux/linux-imx_6.1.bb2
4 files changed, 32 insertions, 8 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx_6.1.bb b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
index c52b947a..8c26da77 100644
--- a/recipes-kernel/linux/linux-fslc-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_6.1.bb
@@ -38,6 +38,7 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
38# ------------------------------------------------------------------------------ 38# ------------------------------------------------------------------------------
39# 3. Critical patches (SHA(s)) 39# 3. Critical patches (SHA(s))
40# ------------------------------------------------------------------------------ 40# ------------------------------------------------------------------------------
41# - ad9ab3b3c553c ARM: imx_v7_defconfig: Remove KERNEL_LZO config
41# 42#
42# NOTE to upgraders: 43# NOTE to upgraders:
43# This recipe should NOT collect individual patches, they should be applied to 44# This recipe should NOT collect individual patches, they should be applied to
@@ -47,11 +48,9 @@ Latest stable Kernel patchlevel is applied and maintained by Community."
47 48
48require linux-imx.inc 49require linux-imx.inc
49 50
50DEPENDS += "lzop-native bc-native"
51
52KBRANCH = "6.1-1.0.x-imx" 51KBRANCH = "6.1-1.0.x-imx"
53SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 52SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
54SRCREV = "897d73a656fe33d0c4549c5de1d07797f99d6871" 53SRCREV = "ad9ab3b3c553cbc3c61f233b6e2cd5abdd2a624b"
55 54
56# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 55# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
57# required by kernel-yocto.bbclass. 56# required by kernel-yocto.bbclass.
diff --git a/recipes-kernel/linux/linux-fslc_6.1.bb b/recipes-kernel/linux/linux-fslc_6.1.bb
index 56729428..7f59d689 100644
--- a/recipes-kernel/linux/linux-fslc_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc_6.1.bb
@@ -10,8 +10,6 @@ provide support for some backported features and fixes, or because it was applie
10and takes some time to become part of a stable version, or because it is not applicable for \ 10and takes some time to become part of a stable version, or because it is not applicable for \
11upstreaming." 11upstreaming."
12 12
13DEPENDS += "lzop-native bc-native"
14
15require linux-imx.inc 13require linux-imx.inc
16 14
17SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https" 15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
@@ -21,10 +19,10 @@ SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=
21# 19#
22# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
23# should be updated once patchlevel is merged. 21# should be updated once patchlevel is merged.
24LINUX_VERSION = "6.1.27" 22LINUX_VERSION = "6.1.29"
25 23
26KBRANCH = "6.1.x+fslc" 24KBRANCH = "6.1.x+fslc"
27SRCREV = "ddc32335b72f78943045b242eb6e0b069ef4cdae" 25SRCREV = "9dd7c6bd8a02e7c5b745b18cfec8bce73feb6de7"
28 26
29KBUILD_DEFCONFIG:mx27-generic-bsp = "imx_v4_v5_defconfig" 27KBUILD_DEFCONFIG:mx27-generic-bsp = "imx_v4_v5_defconfig"
30KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
diff --git a/recipes-kernel/linux/linux-imx/ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch b/recipes-kernel/linux/linux-imx/ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch
new file mode 100644
index 00000000..59490768
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx/ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch
@@ -0,0 +1,27 @@
1From ad9ab3b3c553cbc3c61f233b6e2cd5abdd2a624b Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 23 May 2023 13:16:05 -0300
4Subject: [PATCH] ARM: imx_v7_defconfig: Remove KERNEL_LZO config
5
6The KERNEL_GZIP is used in most config and is the default, there is no
7clear reason to diverge so let default be used.
8
9Upstream-Status: Pending
10
11Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
12---
13 arch/arm/configs/imx_v7_defconfig | 1 -
14 1 file changed, 1 deletion(-)
15
16diff --git a/arch/arm/configs/imx_v7_defconfig b/arch/arm/configs/imx_v7_defconfig
17index 6de3049689191..94e9457e2bab1 100644
18--- a/arch/arm/configs/imx_v7_defconfig
19+++ b/arch/arm/configs/imx_v7_defconfig
20@@ -1,4 +1,3 @@
21-CONFIG_KERNEL_LZO=y
22 CONFIG_SYSVIPC=y
23 CONFIG_POSIX_MQUEUE=y
24 CONFIG_NO_HZ=y
25--
262.40.1
27
diff --git a/recipes-kernel/linux/linux-imx_6.1.bb b/recipes-kernel/linux/linux-imx_6.1.bb
index 490e2171..59a7e5cc 100644
--- a/recipes-kernel/linux/linux-imx_6.1.bb
+++ b/recipes-kernel/linux/linux-imx_6.1.bb
@@ -12,7 +12,7 @@ i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU
12 12
13require recipes-kernel/linux/linux-imx.inc 13require recipes-kernel/linux/linux-imx.inc
14 14
15DEPENDS += "lzop-native bc-native" 15SRC_URI += "file://ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch"
16 16
17SRCBRANCH = "lf-6.1.y" 17SRCBRANCH = "lf-6.1.y"
18LOCALVERSION = "-6.1.1-1.0.0" 18LOCALVERSION = "-6.1.1-1.0.0"