summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Perrot <thomas.perrot@bootlin.com>2022-02-03 09:54:43 +0100
committerThomas Perrot <thomas.perrot@bootlin.com>2022-02-04 06:43:30 +0100
commitcc0a7fd6696991ba20f0d9ea5bb11221f47e9f73 (patch)
tree261d9d28daadd43d9578625d5d6ad9609522b80e
parent57955f43f5840c83bec9da1344a0fb54ad965e4a (diff)
downloadmeta-freescale-cc0a7fd6696991ba20f0d9ea5bb11221f47e9f73.tar.gz
imx-atf: add mark quotation to prevent build issue with ccache
Otherwise, when ccache is enable the following issue occurs: Log data follows: | DEBUG: Executing shell function do_compile | NOTE: make -j 8 CROSS_COMPILE=aarch64-oe-linux- PLAT=imx8qx LD=aarch64-oe-linux-ld CC=ccache aarch64-oe-linux-gcc bl31 | make: *** No rule to make target 'aarch64-oe-linux-gcc'. Stop. | ERROR: oe_runmake failed | WARNING: exit code 1 from a shell command. Signed-off-by: Thomas Perrot <thomas.perrot@bootlin.com>
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index afb31698..eedcdc54 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -43,9 +43,9 @@ def remove_options_tail (in_string):
43 from itertools import takewhile 43 from itertools import takewhile
44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
45 45
46EXTRA_OEMAKE += "LD=${@remove_options_tail(d.getVar('LD'))}" 46EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
47 47
48EXTRA_OEMAKE += "CC=${@remove_options_tail(d.getVar('CC'))}" 48EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
49 49
50do_compile() { 50do_compile() {
51 # Clear LDFLAGS to avoid the option -Wl recognize issue 51 # Clear LDFLAGS to avoid the option -Wl recognize issue