summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-18 22:47:37 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2022-02-21 20:06:28 -0300
commit7357b1100b184b8da51d6da7ac030055dd8c4b1c (patch)
treedf208a17354ce62a4f71730040f7bdd3c1585791
parent7fc91523b3e43ff458d24788380d0d7df8c41598 (diff)
downloadmeta-freescale-7357b1100b184b8da51d6da7ac030055dd8c4b1c.tar.gz
Rework recipes to use imx-nxp-bsp more extensively
This rework the recipes making use of new imx-nxp-bsp override; it has been applied to: - gstreamer1.0 - gstreamer1.0-plugins-bad - gstreamer1.0-plugins-base - gstreamer1.0-plugins-good - imx-alsa-plugins - imx-codec - imx-gst1.0-plugin - imx-parser - libdrm - libimxdmabuffer - linux-fslc-imx - linux-imx - optee-client - optee-test Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb2
-rw-r--r--recipes-graphics/drm/libdrm_2.4.107.imx.bb2
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_5.10.bb2
-rw-r--r--recipes-kernel/linux/linux-imx_5.10.bb2
-rw-r--r--recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb2
-rw-r--r--recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb2
-rw-r--r--recipes-multimedia/imx-codec/imx-codec_4.6.2.bb2
-rw-r--r--recipes-multimedia/imx-parser/imx-parser_4.6.2.bb2
-rw-r--r--recipes-security/optee-imx/optee-client_3.10.0.imx.bb2
-rw-r--r--recipes-security/optee-imx/optee-test_3.10.0.imx.bb2
14 files changed, 14 insertions, 14 deletions
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
index dbf54440..3866ab5b 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
@@ -51,4 +51,4 @@ do_install_ptest_base() {
51 install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH} 51 install -m 0755 ${B}/test-alloc ${D}${PTEST_PATH}
52} 52}
53 53
54COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 54COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-graphics/drm/libdrm_2.4.107.imx.bb b/recipes-graphics/drm/libdrm_2.4.107.imx.bb
index 8e1a6a0f..b732e82a 100644
--- a/recipes-graphics/drm/libdrm_2.4.107.imx.bb
+++ b/recipes-graphics/drm/libdrm_2.4.107.imx.bb
@@ -18,7 +18,7 @@ SRCREV = "a7316e7d67b7708f40ffe469858dae07f14fe21a"
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20DEFAULT_PREFERENCE = "-1" 20DEFAULT_PREFERENCE = "-1"
21COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 21COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
22 22
23inherit meson pkgconfig manpages 23inherit meson pkgconfig manpages
24 24
diff --git a/recipes-kernel/linux/linux-fslc-imx_5.10.bb b/recipes-kernel/linux/linux-fslc-imx_5.10.bb
index 3025840d..1819dfde 100644
--- a/recipes-kernel/linux/linux-fslc-imx_5.10.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_5.10.bb
@@ -87,4 +87,4 @@ LOCALVERSION = "-5.10.52-2.1.0"
87 87
88DEFAULT_PREFERENCE = "1" 88DEFAULT_PREFERENCE = "1"
89 89
90COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 90COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-kernel/linux/linux-imx_5.10.bb b/recipes-kernel/linux/linux-imx_5.10.bb
index 79506b38..1a454b82 100644
--- a/recipes-kernel/linux/linux-imx_5.10.bb
+++ b/recipes-kernel/linux/linux-imx_5.10.bb
@@ -30,4 +30,4 @@ LINUX_VERSION = "5.10.72"
30 30
31DEFAULT_PREFERENCE = "1" 31DEFAULT_PREFERENCE = "1"
32 32
33COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 33COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
index 634508f9..6a665729 100644
--- a/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
+++ b/recipes-multimedia/alsa/imx-alsa-plugins_1.0.26.bb
@@ -33,4 +33,4 @@ FILES:${PN} += "${libdir}/alsa-lib/libasound_*.so"
33FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug" 33FILES:${PN}-dbg += "${libdir}/alsa-lib/.debug"
34FILES:${PN}-dev += "${libdir}/alsa-lib/*.la" 34FILES:${PN}-dev += "${libdir}/alsa-lib/*.la"
35 35
36COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 36COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
index c3f4cf25..530db622 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.0.imx.bb
@@ -160,4 +160,4 @@ FILES:${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
160# include fragment shaders 160# include fragment shaders
161FILES:${PN}-opengl += "/usr/share/*.fs" 161FILES:${PN}-opengl += "/usr/share/*.fs"
162 162
163COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 163COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
index d254db0c..835264ec 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.18.0.imx.bb
@@ -99,4 +99,4 @@ def get_opengl_cmdline_list(switch_name, options, d):
99 99
100CVE_PRODUCT += "gst-plugins-base" 100CVE_PRODUCT += "gst-plugins-base"
101 101
102COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 102COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
index 19248583..dd2996b0 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.18.0.imx.bb
@@ -74,4 +74,4 @@ EXTRA_OEMESON += " \
74 74
75FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" 75FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"
76 76
77COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 77COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
index eabf0f44..8de623fc 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0_1.18.0.imx.bb
@@ -79,4 +79,4 @@ CVE_PRODUCT = "gstreamer"
79 79
80PTEST_BUILD_HOST_FILES = "" 80PTEST_BUILD_HOST_FILES = ""
81 81
82COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 82COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
index db3badac..2de5df53 100644
--- a/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
+++ b/recipes-multimedia/gstreamer/imx-gst1.0-plugin_4.6.1.bb
@@ -82,4 +82,4 @@ FILES:${PN}-grecorder = "${bindir}/grecorder-1.0"
82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}" 82FILES:${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}" 83FILES:${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
84 84
85COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 85COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb b/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb
index cdb5a8ac..3e142694 100644
--- a/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb
+++ b/recipes-multimedia/imx-codec/imx-codec_4.6.2.bb
@@ -116,4 +116,4 @@ FILES:${PN}-nb += "${libdir}/imx-mm/audio-codec/wrap/lib_nbamrd_wrap_arm*_elinux
116FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*" 116FILES:${PN}-wb += "${libdir}/imx-mm/audio-codec/wrap/lib_wbamrd_wrap_arm*_elinux.so.*"
117 117
118PACKAGE_ARCH = "${MACHINE_ARCH}" 118PACKAGE_ARCH = "${MACHINE_ARCH}"
119COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 119COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb b/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb
index f8ee180e..847734a4 100644
--- a/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb
+++ b/recipes-multimedia/imx-parser/imx-parser_4.6.2.bb
@@ -41,4 +41,4 @@ FILES:${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
41 41
42INHIBIT_SYSROOT_STRIP = "1" 42INHIBIT_SYSROOT_STRIP = "1"
43 43
44COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 44COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb b/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
index 2f5166d1..2ad55a64 100644
--- a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-client_3.10.0.imx.bb
@@ -49,4 +49,4 @@ INSANE_SKIP:${PN} = "ldflags dev-elf"
49INSANE_SKIP:${PN}-dev = "ldflags dev-elf" 49INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
50INSANE_SKIP:tee-supplicant = "ldflags" 50INSANE_SKIP:tee-supplicant = "ldflags"
51 51
52COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 52COMPATIBLE_MACHINE = "(imx-nxp-bsp)"
diff --git a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
index ef540bbc..7039d0c4 100644
--- a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
@@ -60,4 +60,4 @@ do_install () {
60 60
61FILES:${PN} = "/usr/bin/ /lib*/optee_armtz/" 61FILES:${PN} = "/usr/bin/ /lib*/optee_armtz/"
62 62
63COMPATIBLE_MACHINE = "(mx6-nxp-bsp|mx7-nxp-bsp|mx8-nxp-bsp)" 63COMPATIBLE_MACHINE = "(imx-nxp-bsp)"