summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-05 17:49:23 -0300
committerGitHub <noreply@github.com>2022-02-05 17:49:23 -0300
commit682f1826e53632fbdc12edc9f1cb47762987e382 (patch)
tree687deb3c59c1ab9923cb5d5c4478d96a78e66e02
parent9c5b793b88f1b7de3acc857d5a3c2e86165e32e3 (diff)
parentcc0a7fd6696991ba20f0d9ea5bb11221f47e9f73 (diff)
downloadmeta-freescale-682f1826e53632fbdc12edc9f1cb47762987e382.tar.gz
Merge pull request #973 from tprrt/tprrt/fix-imx-atf-ccache
imx-atf: add mark quotation to prevent build issue with ccache
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index afb31698..eedcdc54 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -43,9 +43,9 @@ def remove_options_tail (in_string):
43 from itertools import takewhile 43 from itertools import takewhile
44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' '))) 44 return ' '.join(takewhile(lambda x: not x.startswith('-'), in_string.split(' ')))
45 45
46EXTRA_OEMAKE += "LD=${@remove_options_tail(d.getVar('LD'))}" 46EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
47 47
48EXTRA_OEMAKE += "CC=${@remove_options_tail(d.getVar('CC'))}" 48EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
49 49
50do_compile() { 50do_compile() {
51 # Clear LDFLAGS to avoid the option -Wl recognize issue 51 # Clear LDFLAGS to avoid the option -Wl recognize issue