summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-02-02 10:52:37 -0300
committerGitHub <noreply@github.com>2022-02-02 10:52:37 -0300
commit57955f43f5840c83bec9da1344a0fb54ad965e4a (patch)
treec19b2f7e4aabcc0a5ebd6de68ce09096027debe9
parent0f619f42b4ba3cb02dd9da322785678ac8e2ed56 (diff)
parent39868190cda524c0cf781bbacb8e894e2e0078a6 (diff)
downloadmeta-freescale-57955f43f5840c83bec9da1344a0fb54ad965e4a.tar.gz
Merge pull request #970 from tprrt/tprrt/fix-optee-overrides
optee: fix override syntax
-rw-r--r--recipes-security/optee-imx/optee-test_3.10.0.imx.bb4
-rw-r--r--recipes-security/optee/optee-client.nxp.inc2
-rw-r--r--recipes-security/optee/optee-os.nxp.inc3
3 files changed, 4 insertions, 5 deletions
diff --git a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
index 4ccce2cd..0019e8c8 100644
--- a/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
+++ b/recipes-security/optee-imx/optee-test_3.10.0.imx.bb
@@ -23,8 +23,8 @@ OPTEE_ARCH ?= "arm32"
23OPTEE_ARCH:armv7a = "arm32" 23OPTEE_ARCH:armv7a = "arm32"
24OPTEE_ARCH:aarch64 = "arm64" 24OPTEE_ARCH:aarch64 = "arm64"
25 25
26TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta:arm32/" 26TA_DEV_KIT_DIR:arm = "${STAGING_INCDIR}/optee/export-user_ta_arm32/"
27TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta:arm64/" 27TA_DEV_KIT_DIR:aarch64 = "${STAGING_INCDIR}/optee/export-user_ta_arm64/"
28 28
29CFLAGS += "--sysroot=${STAGING_DIR_HOST}" 29CFLAGS += "--sysroot=${STAGING_DIR_HOST}"
30CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}" 30CXXFLAGS += "--sysroot=${STAGING_DIR_HOST}"
diff --git a/recipes-security/optee/optee-client.nxp.inc b/recipes-security/optee/optee-client.nxp.inc
index de2ba8ae..fa187e84 100644
--- a/recipes-security/optee/optee-client.nxp.inc
+++ b/recipes-security/optee/optee-client.nxp.inc
@@ -17,7 +17,7 @@ S = "${WORKDIR}/git"
17B = "${WORKDIR}/build" 17B = "${WORKDIR}/build"
18 18
19OPTEE_ARCH ?= "arm32" 19OPTEE_ARCH ?= "arm32"
20OPTEE_ARCH_armv7a = "arm32" 20OPTEE_ARCH:armv7a = "arm32"
21OPTEE_ARCH:aarch64 = "arm64" 21OPTEE_ARCH:aarch64 = "arm64"
22 22
23EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}" 23EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}"
diff --git a/recipes-security/optee/optee-os.nxp.inc b/recipes-security/optee/optee-os.nxp.inc
index f376b3ce..72af6ca4 100644
--- a/recipes-security/optee/optee-os.nxp.inc
+++ b/recipes-security/optee/optee-os.nxp.inc
@@ -18,7 +18,7 @@ B = "${WORKDIR}/build.${PLATFORM_FLAVOR}"
18PLATFORM_FLAVOR ?= "${MACHINE}" 18PLATFORM_FLAVOR ?= "${MACHINE}"
19 19
20OPTEE_ARCH ?= "arm64" 20OPTEE_ARCH ?= "arm64"
21OPTEE_ARCH_armv7a = "arm32" 21OPTEE_ARCH:armv7a = "arm32"
22OPTEE_ARCH:aarch64 = "arm64" 22OPTEE_ARCH:aarch64 = "arm64"
23 23
24OPTEE_CORE_LOG_LEVEL ?= "1" 24OPTEE_CORE_LOG_LEVEL ?= "1"
@@ -73,4 +73,3 @@ FILES:${PN}-staticdev = "/usr/include/optee/"
73RDEPENDS:${PN}-dev += "${PN}-staticdev" 73RDEPENDS:${PN}-dev += "${PN}-staticdev"
74 74
75PACKAGE_ARCH = "${MACHINE_ARCH}" 75PACKAGE_ARCH = "${MACHINE_ARCH}"
76