summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-07-25 16:29:13 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-07-28 13:49:29 -0500
commita9c993ea72351ecaf8f894db7f869835d325b8bf (patch)
tree922fe03305b229249739f19a7b8aeccfc6bfdec4
parenta4f0b0c2514098fdf5b1f969f9553aa91334a969 (diff)
downloadmeta-freescale-a9c993ea72351ecaf8f894db7f869835d325b8bf.tar.gz
linux-imx: Upgrade to 5.15.32
For i.MX 6 & 7, replace imx-nxp-bsp/defconfig from kernel source arch/arm/configs/imx_v7_defconfig: ``` dd64df27cab6 LF-5825 ARM: config: add tun device support ``` For i.MX 8, replace mx8-nxp-bsp/defconfig from kernel source arch/arm64/configs/imx_v8_defconfig: ``` 3ff6d5992aba LF-5547 .config: imx_v8_defconfig updated c15b5abd7494 LF-5834-2 arm64: configs: imx_v8_defconfig: build module for rpmsg iio pedometer 335562271c7d MLK-25832-4: arch: arm64: configs: Add HDMI RX to imx_v8_defconfig 313dda7d889d LF-5346-2 arm64: imx_v8_defconfig: build FXLS8962AF as module ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig1
-rw-r--r--recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig10
-rw-r--r--recipes-kernel/linux/linux-imx_5.15.bb12
3 files changed, 17 insertions, 6 deletions
diff --git a/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig b/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig
index f4697de8..582625f2 100644
--- a/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig
+++ b/recipes-kernel/linux/linux-imx/imx-nxp-bsp/defconfig
@@ -147,6 +147,7 @@ CONFIG_BLK_DEV_MD=m
147CONFIG_BLK_DEV_DM=m 147CONFIG_BLK_DEV_DM=m
148CONFIG_DM_CRYPT=m 148CONFIG_DM_CRYPT=m
149CONFIG_NETDEVICES=y 149CONFIG_NETDEVICES=y
150CONFIG_TUN=y
150# CONFIG_NET_VENDOR_BROADCOM is not set 151# CONFIG_NET_VENDOR_BROADCOM is not set
151CONFIG_CS89x0_PLATFORM=y 152CONFIG_CS89x0_PLATFORM=y
152# CONFIG_NET_VENDOR_FARADAY is not set 153# CONFIG_NET_VENDOR_FARADAY is not set
diff --git a/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig b/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig
index c00288d1..74dc82cb 100644
--- a/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig
+++ b/recipes-kernel/linux/linux-imx/mx8-nxp-bsp/defconfig
@@ -843,6 +843,8 @@ CONFIG_STAGING_MEDIA=y
843CONFIG_VIDEO_HANTRO=m 843CONFIG_VIDEO_HANTRO=m
844CONFIG_VIDEO_IMX_CAPTURE=y 844CONFIG_VIDEO_IMX_CAPTURE=y
845CONFIG_IMX8_MEDIA_DEVICE=m 845CONFIG_IMX8_MEDIA_DEVICE=m
846CONFIG_MHDP_HDMIRX=y
847CONFIG_MHDP_HDMIRX_CEC=y
846CONFIG_FSL_DPAA2=y 848CONFIG_FSL_DPAA2=y
847CONFIG_FSL_PPFE=y 849CONFIG_FSL_PPFE=y
848CONFIG_FSL_PPFE_UTIL_DISABLED=y 850CONFIG_FSL_PPFE_UTIL_DISABLED=y
@@ -893,6 +895,7 @@ CONFIG_EXTCON_PTN5150=m
893CONFIG_EXTCON_USB_GPIO=y 895CONFIG_EXTCON_USB_GPIO=y
894CONFIG_EXTCON_USBC_CROS_EC=y 896CONFIG_EXTCON_USBC_CROS_EC=y
895CONFIG_IIO=y 897CONFIG_IIO=y
898CONFIG_FXLS8962AF_I2C=m
896CONFIG_IMX8QXP_ADC=y 899CONFIG_IMX8QXP_ADC=y
897CONFIG_MAX9611=m 900CONFIG_MAX9611=m
898CONFIG_QCOM_SPMI_VADC=m 901CONFIG_QCOM_SPMI_VADC=m
@@ -901,6 +904,7 @@ CONFIG_IIO_CROS_EC_SENSORS_CORE=m
901CONFIG_IIO_CROS_EC_SENSORS=m 904CONFIG_IIO_CROS_EC_SENSORS=m
902CONFIG_FXAS21002C=y 905CONFIG_FXAS21002C=y
903CONFIG_FXOS8700_I2C=y 906CONFIG_FXOS8700_I2C=y
907CONFIG_RPMSG_IIO_PEDOMETER=m
904CONFIG_IIO_ST_LSM6DSX=y 908CONFIG_IIO_ST_LSM6DSX=y
905CONFIG_IIO_CROS_EC_LIGHT_PROX=m 909CONFIG_IIO_CROS_EC_LIGHT_PROX=m
906CONFIG_SENSORS_ISL29018=y 910CONFIG_SENSORS_ISL29018=y
@@ -1038,3 +1042,9 @@ CONFIG_CORESIGHT_SOURCE_ETM4X=y
1038CONFIG_MEMTEST=y 1042CONFIG_MEMTEST=y
1039CONFIG_TLS=y 1043CONFIG_TLS=y
1040CONFIG_TLS_DEVICE=y 1044CONFIG_TLS_DEVICE=y
1045
1046# enable Trusted Keys based on CAAM
1047CONFIG_TRUSTED_KEYS=m
1048CONFIG_TRUSTED_KEYS_TPM=n
1049CONFIG_TRUSTED_KEYS_TEE=n
1050CONFIG_TRUSTED_KEYS_CAAM=y
diff --git a/recipes-kernel/linux/linux-imx_5.15.bb b/recipes-kernel/linux/linux-imx_5.15.bb
index 751e4c9f..8bd3065c 100644
--- a/recipes-kernel/linux/linux-imx_5.15.bb
+++ b/recipes-kernel/linux/linux-imx_5.15.bb
@@ -20,19 +20,19 @@ DEPENDS += "lzop-native bc-native"
20# UPGRADE NOTE: 20# UPGRADE NOTE:
21# The linux-imx kernel build uses a defconfig maintained in the layer. That 21# The linux-imx kernel build uses a defconfig maintained in the layer. That
22# defconfig is a copy of a defconfig maintained by NXP in the source. 22# defconfig is a copy of a defconfig maintained by NXP in the source.
23# | defconfig in layer | copied from NXP kernel source | 23# | SOURCE | LAYER |
24# | linux-imx/imx-nxp-bsp/defconfig | arch/arm/configs/imx_v7_defconfig | 24# | arch/arm/configs/imx_v7_defconfig | linux-imx/imx-nxp-bsp/defconfig |
25# | linux-imx/mx8-nxp-bsp/defconfig | arch/arm64/configs/imx_v8_defconfig | 25# | arch/arm64/configs/imx_v8_defconfig | linux-imx/mx8-nxp-bsp/defconfig |
26SRCBRANCH = "lf-5.15.y" 26SRCBRANCH = "lf-5.15.y"
27LOCALVERSION = "-5.15.5_1.0.0" 27LOCALVERSION = "-5.15.32_2.0.0"
28SRCREV = "c1084c2773fc1005ed140db625399d5334d94a28" 28SRCREV = "fa6c3168595c02bd9d5366fcc28c9e7304947a3d"
29 29
30# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition 30# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
31# required by kernel-yocto.bbclass. 31# required by kernel-yocto.bbclass.
32# 32#
33# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 33# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
34# should be updated once patchlevel is merged. 34# should be updated once patchlevel is merged.
35LINUX_VERSION = "5.15.5" 35LINUX_VERSION = "5.15.32"
36 36
37DEFAULT_PREFERENCE = "1" 37DEFAULT_PREFERENCE = "1"
38 38