summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVinicius Aquino <voa.aquino@gmail.com>2021-04-12 17:25:38 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2021-04-13 10:16:48 -0300
commitcb3020653421d46fb5308b59da1d9a1e83d99c1a (patch)
treeafe7fb4dbf7f2d96ed96732791310b38799da388
parent6e848584a5a1a5a6be6ee9bc675edf8eafbb2391 (diff)
downloadmeta-freescale-cb3020653421d46fb5308b59da1d9a1e83d99c1a.tar.gz
weston-init: Rework uncomment function logic
Fix error "Commented setting '#use-g2d=1' not found" when building for some imx machines. Signed-off-by: Vinicius Aquino <voa.aquino@gmail.com>
-rw-r--r--recipes-graphics/wayland/weston-init.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-graphics/wayland/weston-init.bbappend b/recipes-graphics/wayland/weston-init.bbappend
index 8e590965..22ffb7ff 100644
--- a/recipes-graphics/wayland/weston-init.bbappend
+++ b/recipes-graphics/wayland/weston-init.bbappend
@@ -40,7 +40,7 @@ INI_UNCOMMENT_ASSIGNMENTS_append_mx8mq = " \
40" 40"
41 41
42uncomment() { 42uncomment() {
43 if ! (grep "^#$1" $2); then 43 if ! grep -q "^#$1" $2 && ! grep -q "^$1" $2; then
44 bbfatal "Commented setting '#$1' not found in file $2" 44 bbfatal "Commented setting '#$1' not found in file $2"
45 fi 45 fi
46 sed -i -e 's,^#'"$1"','"$1"',g' $2 46 sed -i -e 's,^#'"$1"','"$1"',g' $2