summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-08-18 09:59:11 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-23 23:40:51 -0300
commit5b58232d3e7b5e66d5bdcfd11a6265b098b2f898 (patch)
treec88d74543f2fe3170508c26fb5951c2d395336ba
parentff402ae4bfb6b80b2312a6fcd6c0638673e2c053 (diff)
downloadmeta-freescale-5b58232d3e7b5e66d5bdcfd11a6265b098b2f898.tar.gz
u-boot-imx: upgrade to imx_v2020.04_5.4.24_2.1.0
Drop patch appplied upstream, remove additional install step which is handled by imx-boot recipe. Update u-boot dtb names in machine description files, upstream U-Boot from NXP has DTB files renamed. Upgrade u-boot-imx-tools and u-boot-imx-mfgtool to 2020.04 as well to match u-boot-imx recipe. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--conf/machine/imx8mmevk.conf2
-rw-r--r--conf/machine/imx8mnevk.conf2
-rw-r--r--conf/machine/imx8mqevk.conf2
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-common.inc4
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2020.04.bb (renamed from recipes-bsp/u-boot/u-boot-imx-mfgtool_2019.04.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb (renamed from recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/0001-Add-target-to-generate-initial-environment.patch49
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2020.04.bb (renamed from recipes-bsp/u-boot/u-boot-imx_2019.04.bb)5
8 files changed, 6 insertions, 58 deletions
diff --git a/conf/machine/imx8mmevk.conf b/conf/machine/imx8mmevk.conf
index 57d74d9c..db722c72 100644
--- a/conf/machine/imx8mmevk.conf
+++ b/conf/machine/imx8mmevk.conf
@@ -39,7 +39,7 @@ SPL_BINARY = "spl/u-boot-spl.bin"
39DDR_FIRMWARE_NAME = "lpddr4_pmu_train_1d_imem.bin lpddr4_pmu_train_1d_dmem.bin lpddr4_pmu_train_2d_imem.bin lpddr4_pmu_train_2d_dmem.bin" 39DDR_FIRMWARE_NAME = "lpddr4_pmu_train_1d_imem.bin lpddr4_pmu_train_1d_dmem.bin lpddr4_pmu_train_2d_imem.bin lpddr4_pmu_train_2d_dmem.bin"
40 40
41# Set u-boot DTB 41# Set u-boot DTB
42UBOOT_DTB_NAME = "fsl-imx8mm-evk.dtb" 42UBOOT_DTB_NAME = "imx8mm-evk.dtb"
43 43
44# Set imx-mkimage boot target 44# Set imx-mkimage boot target
45IMXBOOT_TARGETS = "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_evk_flexspi', 'flash_evk', d)}" 45IMXBOOT_TARGETS = "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_evk_flexspi', 'flash_evk', d)}"
diff --git a/conf/machine/imx8mnevk.conf b/conf/machine/imx8mnevk.conf
index cc92ac7c..80d77ac8 100644
--- a/conf/machine/imx8mnevk.conf
+++ b/conf/machine/imx8mnevk.conf
@@ -36,7 +36,7 @@ DDR_FIRMWARE_NAME = "ddr4_imem_1d_201810.bin \
36 ddr4_dmem_2d_201810.bin" 36 ddr4_dmem_2d_201810.bin"
37 37
38# Set u-boot DTB 38# Set u-boot DTB
39UBOOT_DTB_NAME = "fsl-imx8mn-ddr4-evk.dtb" 39UBOOT_DTB_NAME = "imx8mn-ddr4-evk.dtb"
40 40
41# Set imx-mkimage boot target 41# Set imx-mkimage boot target
42IMXBOOT_TARGETS = "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_ddr4_evk_flexspi', 'flash_ddr4_evk', d)}" 42IMXBOOT_TARGETS = "${@bb.utils.contains('UBOOT_CONFIG', 'fspi', 'flash_ddr4_evk_flexspi', 'flash_ddr4_evk', d)}"
diff --git a/conf/machine/imx8mqevk.conf b/conf/machine/imx8mqevk.conf
index 25e03093..2c9c8c29 100644
--- a/conf/machine/imx8mqevk.conf
+++ b/conf/machine/imx8mqevk.conf
@@ -41,7 +41,7 @@ SPL_BINARY = "spl/u-boot-spl.bin"
41DDR_FIRMWARE_NAME = "lpddr4_pmu_train_1d_imem.bin lpddr4_pmu_train_1d_dmem.bin lpddr4_pmu_train_2d_imem.bin lpddr4_pmu_train_2d_dmem.bin" 41DDR_FIRMWARE_NAME = "lpddr4_pmu_train_1d_imem.bin lpddr4_pmu_train_1d_dmem.bin lpddr4_pmu_train_2d_imem.bin lpddr4_pmu_train_2d_dmem.bin"
42 42
43# Set u-boot DTB 43# Set u-boot DTB
44UBOOT_DTB_NAME = "fsl-imx8mq-evk.dtb" 44UBOOT_DTB_NAME = "imx8mq-evk.dtb"
45 45
46# Set imx-mkimage boot target 46# Set imx-mkimage boot target
47IMXBOOT_TARGETS = "flash_evk flash_evk_no_hdmi flash_dp_evk" 47IMXBOOT_TARGETS = "flash_evk flash_evk_no_hdmi flash_dp_evk"
diff --git a/recipes-bsp/u-boot/u-boot-imx-common.inc b/recipes-bsp/u-boot/u-boot-imx-common.inc
index a2d2ed01..e5f15b12 100644
--- a/recipes-bsp/u-boot/u-boot-imx-common.inc
+++ b/recipes-bsp/u-boot/u-boot-imx-common.inc
@@ -3,9 +3,9 @@ DESCRIPTION = "i.MX U-Boot suppporting i.MX reference boards."
3LICENSE = "GPLv2+" 3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263" 4LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5 5
6SRCBRANCH = "lf-5.4.y_v2019.04" 6SRCBRANCH = "imx_v2020.04_5.4.24_2.1.0"
7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" 7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
8SRCREV = "228843cdf5435d4bd69f42a6015f78761ff4cc0d" 8SRCREV = "4979a99482f7e04a3c1f4fb55e3182395ee8f710"
9 9
10DEPENDS += "flex-native bison-native bc-native dtc-native" 10DEPENDS += "flex-native bison-native bc-native dtc-native"
11 11
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2020.04.bb
index 2b296c19..2b296c19 100644
--- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2020.04.bb
diff --git a/recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb
index 12ac72e2..12ac72e2 100644
--- a/recipes-bsp/u-boot/u-boot-imx-tools_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb
diff --git a/recipes-bsp/u-boot/u-boot-imx/0001-Add-target-to-generate-initial-environment.patch b/recipes-bsp/u-boot/u-boot-imx/0001-Add-target-to-generate-initial-environment.patch
deleted file mode 100644
index c717e029..00000000
--- a/recipes-bsp/u-boot/u-boot-imx/0001-Add-target-to-generate-initial-environment.patch
+++ /dev/null
@@ -1,49 +0,0 @@
1From bdaa73a5b3923257add182b4ab8058dbfa33421b Mon Sep 17 00:00:00 2001
2From: Stefano Babic <sbabic@denx.de>
3Date: Wed, 13 Mar 2019 09:46:45 +0100
4Subject: [PATCH] Add target to generate initial environment
5
6The initial environment is linked to the u-boot binary. Modifying the
7environment from User Space with the env tools requires that the tools
8are always built together with the bootloader to be sure that they
9contain the initial environment in case no environment is stored into
10persistent storage or when a board boots with just the default
11environment. This makes difficult for distros to provide a general
12package to access the environment. A simpler way is if the tools are
13generic for all boards and a configuration file is given to provide the
14initial environment.
15
16The patch just generates the initial environment by extracting it from
17the compiled object. This file can then be used for tools in user space
18to initialize the environment.
19
20Signed-off-by: Stefano Babic <sbabic@denx.de>
21
22Upstream-Status: Backport [https://github.com/u-boot/u-boot/commit/bdaa73a5b3923257add182b4ab8058dbfa33421b]
23
24Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
25---
26 Makefile | 7 +++++++
27 1 file changed, 7 insertions(+)
28
29diff --git a/Makefile b/Makefile
30index 66a09ac900..f2c7bb6041 100644
31--- a/Makefile
32+++ b/Makefile
33@@ -1977,6 +1977,13 @@ endif
34 $(build)=$(build-dir) $(@:.ko=.o)
35 $(Q)$(MAKE) -f $(srctree)/scripts/Makefile.modpost
36
37+quiet_cmd_genenv = GENENV $@
38+cmd_genenv = $(OBJCOPY) --dump-section .rodata.default_environment=$@ env/common.o; \
39+ sed --in-place -e 's/\x00/\x0A/g' $@
40+
41+u-boot-initial-env: u-boot.bin
42+ $(call if_changed,genenv)
43+
44 # Consistency checks
45 # ---------------------------------------------------------------------------
46
47--
482.17.1
49
diff --git a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb b/recipes-bsp/u-boot/u-boot-imx_2020.04.bb
index d37ede83..b36730e0 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2019.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2020.04.bb
@@ -1,12 +1,10 @@
1# Copyright (C) 2013-2016 Freescale Semiconductor 1# Copyright (C) 2013-2016 Freescale Semiconductor
2# Copyright 2018 (C) O.S. Systems Software LTDA. 2# Copyright 2018 (C) O.S. Systems Software LTDA.
3# Copyright 2017-2019 NXP 3# Copyright (C) 2017-2020 NXP
4 4
5require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common.inc 6require u-boot-imx-common.inc
7 7
8SRC_URI += "file://0001-Add-target-to-generate-initial-environment.patch"
9
10PROVIDES += "u-boot" 8PROVIDES += "u-boot"
11 9
12do_deploy_append_mx8m() { 10do_deploy_append_mx8m() {
@@ -21,7 +19,6 @@ do_deploy_append_mx8m() {
21 then 19 then
22 install -d ${DEPLOYDIR}/${BOOT_TOOLS} 20 install -d ${DEPLOYDIR}/${BOOT_TOOLS}
23 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS} 21 install -m 0777 ${B}/${config}/arch/arm/dts/${UBOOT_DTB_NAME} ${DEPLOYDIR}/${BOOT_TOOLS}
24 install -m 0777 ${B}/${config}/tools/mkimage ${DEPLOYDIR}/${BOOT_TOOLS}/mkimage_uboot
25 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG} 22 install -m 0777 ${B}/${config}/u-boot-nodtb.bin ${DEPLOYDIR}/${BOOT_TOOLS}/u-boot-nodtb.bin-${MACHINE}-${UBOOT_CONFIG}
26 fi 23 fi
27 done 24 done