summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-01-19 19:29:24 -0300
committerGitHub <noreply@github.com>2022-01-19 19:29:24 -0300
commit63073229b904c0c662cb75116a8c4dfaf03da1f4 (patch)
tree0977606ae3a29bfc6844c0d285a1b23ddc446abb
parent1041425ee15140674d3fd721c6c85c5f59f5728b (diff)
parent9fa3004dab003fd616fea89c5a0baf6c48ce5a72 (diff)
downloadmeta-freescale-63073229b904c0c662cb75116a8c4dfaf03da1f4.tar.gz
Merge pull request #954 from thochstein/recipes-bsp
u-boot-imx and recipes-bsp for 5.10.72-2.2.0
-rw-r--r--classes/uuu_bootloader_tag.bbclass11
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8.14.inc (renamed from recipes-bsp/firmware-imx/firmware-imx-8.13.inc)6
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8_8.14.bb (renamed from recipes-bsp/firmware-imx/firmware-imx-8_8.13.bb)0
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx-8m_8.14.bb (renamed from recipes-bsp/firmware-imx/firmware-imx-8m_8.13.bb)0
-rw-r--r--recipes-bsp/firmware-imx/firmware-imx_8.14.bb (renamed from recipes-bsp/firmware-imx/firmware-imx_8.13.bb)15
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb2
-rw-r--r--recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch135
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb10
-rw-r--r--recipes-bsp/imx-mkimage/imx-mkimage_git.inc4
-rw-r--r--recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.11.0.bb (renamed from recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.10.0.bb)6
-rw-r--r--recipes-bsp/imx-seco/imx-seco-libs_git.bb6
-rw-r--r--recipes-bsp/imx-seco/imx-seco_3.8.4.bb (renamed from recipes-bsp/imx-seco/imx-seco_3.8.2.bb)6
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb4
-rw-r--r--recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.6.0.bb (renamed from recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb)6
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.1.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb)4
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.24.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb)6
-rw-r--r--recipes-bsp/isp-imx/basler-camera_4.2.2.16.0.bb (renamed from recipes-bsp/isp-imx/basler-camera_4.2.2.15.0.bb)6
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.16.0.bb (renamed from recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb)7
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc6
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb4
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2021.04.bb9
21 files changed, 84 insertions, 169 deletions
diff --git a/classes/uuu_bootloader_tag.bbclass b/classes/uuu_bootloader_tag.bbclass
new file mode 100644
index 00000000..fb6acd72
--- /dev/null
+++ b/classes/uuu_bootloader_tag.bbclass
@@ -0,0 +1,11 @@
1# Append a tag to the bootloader image used in the SD card image. The tag
2# contains the size of the bootloader image so UUU can easily find the end of
3# the bootloader in the SD card image.
4do_deploy:append() {
5 if [ "${UUU_BOOTLOADER}" != "" ]; then
6 cp ${DEPLOYDIR}/${UUU_BOOTLOADER} ${DEPLOYDIR}/${UUU_BOOTLOADER_TAGGED}
7 ln -sf ${UUU_BOOTLOADER_TAGGED} ${DEPLOYDIR}/${UUU_BOOTLOADER}
8 stat -L -cUUUBURNXXOEUZX7+A-XY5601QQWWZ%sEND ${DEPLOYDIR}/${UUU_BOOTLOADER} \
9 >> ${DEPLOYDIR}/${UUU_BOOTLOADER}
10 fi
11}
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8.13.inc b/recipes-bsp/firmware-imx/firmware-imx-8.14.inc
index ff739c4c..5af24283 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8.13.inc
+++ b/recipes-bsp/firmware-imx/firmware-imx-8.14.inc
@@ -3,14 +3,14 @@
3# Copyright (C) 2018 O.S. Systems Software LTDA. 3# Copyright (C) 2018 O.S. Systems Software LTDA.
4SECTION = "base" 4SECTION = "base"
5LICENSE = "Proprietary" 5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 6LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 ${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true \ 9 ${FSL_MIRROR}/firmware-imx-${PV}.bin;fsl-eula=true \
10" 10"
11 11
12SRC_URI[md5sum] = "97eb12ba899bc29a5375993889708bfb" 12SRC_URI[md5sum] = "3357c84e48fdc220984a9642d1e808f6"
13SRC_URI[sha256sum] = "8b7aa9b41a0389e5f40bdf91cb1224f79ea4c2e7fc36292f27ad4bef7044d7f0" 13SRC_URI[sha256sum] = "bfe9c57857e8442e7eb26ba3e1020733b09a7c9b83952ad4822980546c58a7f4"
14 14
15S = "${WORKDIR}/firmware-imx-${PV}" 15S = "${WORKDIR}/firmware-imx-${PV}"
16 16
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8_8.13.bb b/recipes-bsp/firmware-imx/firmware-imx-8_8.14.bb
index 6ea16d5b..6ea16d5b 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8_8.13.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx-8_8.14.bb
diff --git a/recipes-bsp/firmware-imx/firmware-imx-8m_8.13.bb b/recipes-bsp/firmware-imx/firmware-imx-8m_8.14.bb
index a48356ed..a48356ed 100644
--- a/recipes-bsp/firmware-imx/firmware-imx-8m_8.13.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx-8m_8.14.bb
diff --git a/recipes-bsp/firmware-imx/firmware-imx_8.13.bb b/recipes-bsp/firmware-imx/firmware-imx_8.14.bb
index 68539a61..5628e40b 100644
--- a/recipes-bsp/firmware-imx/firmware-imx_8.13.bb
+++ b/recipes-bsp/firmware-imx/firmware-imx_8.14.bb
@@ -1,5 +1,5 @@
1# Copyright (C) 2012-2016 Freescale Semiconductor 1# Copyright (C) 2012-2016 Freescale Semiconductor
2# Copyright (C) 2017-2020 NXP 2# Copyright (C) 2017-2021 NXP
3# Copyright (C) 2018 O.S. Systems Software LTDA. 3# Copyright (C) 2018 O.S. Systems Software LTDA.
4SUMMARY = "Freescale i.MX firmware" 4SUMMARY = "Freescale i.MX firmware"
5DESCRIPTION = "Freescale i.MX firmware such as for the VPU" 5DESCRIPTION = "Freescale i.MX firmware such as for the VPU"
@@ -43,10 +43,9 @@ do_install() {
43 # NOTE: 43 # NOTE:
44 # Only install pre-defined list of firmware files, since the source archive contains 44 # Only install pre-defined list of firmware files, since the source archive contains
45 # also HDMI binary files for imx8m derivatives, which are taken care of by another recipe 45 # also HDMI binary files for imx8m derivatives, which are taken care of by another recipe
46 install -d ${D}${nonarch_base_libdir}/firmware/imx/hdmi 46 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${D}${nonarch_base_libdir}/firmware
47 install -m 0644 ${S}/firmware/hdmi/cadence/hdmitxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi 47 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${D}${nonarch_base_libdir}/firmware
48 install -m 0644 ${S}/firmware/hdmi/cadence/hdmirxfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi 48 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${D}${nonarch_base_libdir}/firmware
49 install -m 0644 ${S}/firmware/hdmi/cadence/dpfw.bin ${D}${nonarch_base_libdir}/firmware/imx/hdmi
50 49
51 # VPU Firmware section 50 # VPU Firmware section
52 # NOTE: 51 # NOTE:
@@ -124,6 +123,10 @@ PACKAGES_DYNAMIC = "${PN}-vpu-* ${PN}-sdma-* ${PN}-easrc-* ${PN}-xcvr-* ${PN}-xu
124PACKAGES = "${PN} ${PN}-epdc ${PN}-hdmi" 123PACKAGES = "${PN} ${PN}-epdc ${PN}-hdmi"
125 124
126FILES:${PN}-epdc = "${nonarch_base_libdir}/firmware/imx/epdc/" 125FILES:${PN}-epdc = "${nonarch_base_libdir}/firmware/imx/epdc/"
127FILES:${PN}-hdmi = "${nonarch_base_libdir}/firmware/imx/hdmi/" 126FILES:${PN}-hdmi = " \
127 ${nonarch_base_libdir}/firmware/hdmitxfw.bin \
128 ${nonarch_base_libdir}/firmware/hdmirxfw.bin \
129 ${nonarch_base_libdir}/firmware/dpfw.bin \
130"
128 131
129COMPATIBLE_MACHINE = "(imx|use-mainline-bsp)" 132COMPATIBLE_MACHINE = "(imx|use-mainline-bsp)"
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index ce30822e..afb31698 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -10,7 +10,7 @@ PV .= "+git${SRCPV}"
10SRCBRANCH = "lf_v2.4" 10SRCBRANCH = "lf_v2.4"
11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \ 11SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
12" 12"
13SRCREV = "bb4957067d4b96a6ee197a333425948e409e990d" 13SRCREV = "5782363f92a2fdf926784449270433cf3ddf44bd"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch b/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
index 3c2842af..5a4a895b 100644
--- a/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
+++ b/recipes-bsp/imx-mkimage/files/0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch
@@ -1,19 +1,10 @@
1From 9cf936493388897379f33b511ec869c6fa5409ce Mon Sep 17 00:00:00 2001 1From f281b935985f1b592534ee2837ce0d0b28c7dc43 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com> 2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Thu, 22 Apr 2021 12:20:28 +0000 3Date: Tue, 11 Jan 2022 15:32:05 -0600
4Subject: [PATCH] mkimage_fit_atf: fix fit generator node naming 4Subject: [PATCH] mkimage_fit_atf: fix fit generator node naming
5 5
6Since upstream commit 79af75f777 ("fit: Don't allow verification of images 6Extend sections which contains "firmware" in their types with "os"
7with @ nodes") [1], unit addresses on the nodes are prohibited and nodes 7parameter to conform to the latest FIT specification.
8that do contain those addresses are ignored during the ITS parsing. This
9is done in an effort to cover the CVE-2021-27138, where nodes with unit
10addresses can be mis-interpreted by libfdt.
11
12Correct FIT generator script and replace nodes with unit addresses to
13plain node names with "-" instead of "@" to create a unique naming.
14
15In addition, extend sections which contains "firmware" in their types
16with "os" parameter to conform to the latest FIT specification.
17 8
18Indicate that load and entry addresses are covered by one 32-bit value 9Indicate that load and entry addresses are covered by one 32-bit value
19by adding "address-cells" in the root node of the generated ITS. 10by adding "address-cells" in the root node of the generated ITS.
@@ -23,40 +14,13 @@ Link: [1] https://github.com/u-boot/u-boot/commit/79af75f7776fc20b0d7eb6afe1e27c
23Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> 14Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
24Cc: Tom Hochstein <tom.hochstein@nxp.com> 15Cc: Tom Hochstein <tom.hochstein@nxp.com>
25--- 16---
26 iMX8M/mkimage_fit_atf.sh | 40 ++++++++++++++++++++++------------------ 17 iMX8M/mkimage_fit_atf.sh | 4 ++++
27 1 file changed, 22 insertions(+), 18 deletions(-) 18 1 file changed, 4 insertions(+)
28 19
29diff --git a/iMX8M/mkimage_fit_atf.sh b/iMX8M/mkimage_fit_atf.sh 20diff --git a/iMX8M/mkimage_fit_atf.sh b/iMX8M/mkimage_fit_atf.sh
30index 95749b1..10903ea 100755 21index 4f2b3f3..10903ea 100755
31--- a/iMX8M/mkimage_fit_atf.sh 22--- a/iMX8M/mkimage_fit_atf.sh
32+++ b/iMX8M/mkimage_fit_atf.sh 23+++ b/iMX8M/mkimage_fit_atf.sh
33@@ -23,7 +23,7 @@ else
34 fi
35
36 BL32="tee.bin"
37-LOADABLES="\"atf@1\""
38+LOADABLES="\"atf-1\""
39
40 if [ ! -f $BL32 ]; then
41 BL32=/dev/null
42@@ -31,7 +31,7 @@ else
43 echo "Building with TEE support, make sure your bl31 is compiled with spd. If you do not want tee, please delete tee.bin" >&2
44 echo "tee.bin size: " >&2
45 ls -lct tee.bin | awk '{print $5}' >&2
46- LOADABLES="$LOADABLES, \"tee@1\""
47+ LOADABLES="$LOADABLES, \"tee-1\""
48 fi
49
50 BL33="u-boot-nodtb.bin"
51@@ -41,7 +41,7 @@ if [ ! -f $DEK_BLOB ]; then
52 DEK_BLOB=/dev/null
53 else
54 echo "Building with encrypted boot support, make sure to replace DEK Blob in final image." >&2
55- LOADABLES="\"dek_blob@1\", $LOADABLES"
56+ LOADABLES="\"dek_blob-1\", $LOADABLES"
57 fi
58
59 if [ ! -f $BL33 ]; then
60@@ -64,10 +64,12 @@ cat << __HEADER_EOF 24@@ -64,10 +64,12 @@ cat << __HEADER_EOF
61 25
62 / { 26 / {
@@ -64,103 +28,28 @@ index 95749b1..10903ea 100755
64+ #address-cells = <1>; 28+ #address-cells = <1>;
65 29
66 images { 30 images {
67- uboot@1 { 31 uboot-1 {
68+ uboot-1 {
69 description = "U-Boot (64-bit)"; 32 description = "U-Boot (64-bit)";
70+ os = "u-boot"; 33+ os = "u-boot";
71 data = /incbin/("$BL33"); 34 data = /incbin/("$BL33");
72 type = "standalone"; 35 type = "standalone";
73 arch = "arm64"; 36 arch = "arm64";
74@@ -80,7 +82,7 @@ cnt=1 37@@ -93,6 +95,7 @@ done
75 for dtname in $*
76 do
77 cat << __FDT_IMAGE_EOF
78- fdt@$cnt {
79+ fdt-$cnt {
80 description = "$(basename $dtname .dtb)";
81 data = /incbin/("$dtname");
82 type = "flat_dt";
83@@ -91,8 +93,9 @@ cnt=$((cnt+1))
84 done
85
86 cat << __HEADER_EOF 38 cat << __HEADER_EOF
87- atf@1 { 39 atf-1 {
88+ atf-1 {
89 description = "ARM Trusted Firmware"; 40 description = "ARM Trusted Firmware";
90+ os = "arm-trusted-firmware"; 41+ os = "arm-trusted-firmware";
91 data = /incbin/("$BL31"); 42 data = /incbin/("$BL31");
92 type = "firmware"; 43 type = "firmware";
93 arch = "arm64"; 44 arch = "arm64";
94@@ -104,8 +107,9 @@ __HEADER_EOF 45@@ -106,6 +109,7 @@ if [ -f $BL32 ]; then
95
96 if [ -f $BL32 ]; then
97 cat << __HEADER_EOF 46 cat << __HEADER_EOF
98- tee@1 { 47 tee-1 {
99+ tee-1 {
100 description = "TEE firmware"; 48 description = "TEE firmware";
101+ os = "op-tee-firmware"; 49+ os = "op-tee-firmware";
102 data = /incbin/("$BL32"); 50 data = /incbin/("$BL32");
103 type = "firmware"; 51 type = "firmware";
104 arch = "arm64"; 52 arch = "arm64";
105@@ -118,7 +122,7 @@ fi
106
107 if [ -f $DEK_BLOB ]; then
108 cat << __HEADER_EOF
109- dek_blob@1 {
110+ dek_blob-1 {
111 description = "dek_blob";
112 data = /incbin/("$DEK_BLOB");
113 type = "script";
114@@ -131,7 +135,7 @@ fi
115 cat << __CONF_HEADER_EOF
116 };
117 configurations {
118- default = "config@1";
119+ default = "config-1";
120
121 __CONF_HEADER_EOF
122
123@@ -141,31 +145,31 @@ do
124 if [ -f $BL32 ]; then
125 if [ $ROLLBACK_INDEX_IN_FIT ]; then
126 cat << __CONF_SECTION_EOF
127- config@$cnt {
128+ config-$cnt {
129 description = "$(basename $dtname .dtb)";
130- firmware = "uboot@1";
131+ firmware = "uboot-1";
132 loadables = $LOADABLES;
133- fdt = "fdt@$cnt";
134+ fdt = "fdt-$cnt";
135 rbindex = "$ROLLBACK_INDEX_IN_FIT";
136 };
137 __CONF_SECTION_EOF
138 else
139 cat << __CONF_SECTION_EOF
140- config@$cnt {
141+ config-$cnt {
142 description = "$(basename $dtname .dtb)";
143- firmware = "uboot@1";
144+ firmware = "uboot-1";
145 loadables = $LOADABLES;
146- fdt = "fdt@$cnt";
147+ fdt = "fdt-$cnt";
148 };
149 __CONF_SECTION_EOF
150 fi
151 else
152 cat << __CONF_SECTION1_EOF
153- config@$cnt {
154+ config-$cnt {
155 description = "$(basename $dtname .dtb)";
156- firmware = "uboot@1";
157+ firmware = "uboot-1";
158 loadables = $LOADABLES;
159- fdt = "fdt@$cnt";
160+ fdt = "fdt-$cnt";
161 };
162 __CONF_SECTION1_EOF
163 fi
164-- 53--
1652.17.1 542.17.1
166 55
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index f8ebb730..b332e079 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -24,7 +24,10 @@ DEPENDS:append:mx8m = " u-boot-mkimage-native dtc-native"
24BOOT_NAME = "imx-boot" 24BOOT_NAME = "imx-boot"
25PROVIDES = "${BOOT_NAME}" 25PROVIDES = "${BOOT_NAME}"
26 26
27inherit deploy 27inherit deploy uuu_bootloader_tag
28
29UUU_BOOTLOADER = "${BOOT_NAME}"
30UUU_BOOTLOADER_TAGGED = "${BOOT_NAME}-tagged"
28 31
29# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build 32# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build
30CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" 33CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}"
@@ -190,9 +193,8 @@ do_deploy() {
190 fi 193 fi
191 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE}-${target} ${DEPLOYDIR} 194 install -m 0644 ${S}/${BOOT_CONFIG_MACHINE}-${target} ${DEPLOYDIR}
192 done 195 done
193 cd ${DEPLOYDIR} 196
194 ln -sf ${BOOT_CONFIG_MACHINE}-${IMAGE_IMXBOOT_TARGET} ${BOOT_NAME} 197 ln -sf ${BOOT_CONFIG_MACHINE}-${IMAGE_IMXBOOT_TARGET} ${DEPLOYDIR}/${BOOT_NAME}
195 cd -
196} 198}
197addtask deploy before do_build after do_compile 199addtask deploy before do_build after do_compile
198 200
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc
index c51c1e08..b4d32a54 100644
--- a/recipes-bsp/imx-mkimage/imx-mkimage_git.inc
+++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.inc
@@ -2,12 +2,12 @@
2 2
3DEPENDS = "zlib-native openssl-native" 3DEPENDS = "zlib-native openssl-native"
4 4
5SRCBRANCH = "lf-5.10.52_2.1.0" 5SRCBRANCH = "lf-5.10.72_2.2.0"
6SRC_URI = "git://source.codeaurora.org/external/imx/imx-mkimage.git;protocol=https;branch=${SRCBRANCH} \ 6SRC_URI = "git://source.codeaurora.org/external/imx/imx-mkimage.git;protocol=https;branch=${SRCBRANCH} \
7 file://0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch \ 7 file://0001-mkimage_fit_atf-fix-fit-generator-node-naming.patch \
8 file://0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch \ 8 file://0001-iMX8M-soc.mak-use-native-mkimage-from-sysroot.patch \
9" 9"
10SRCREV = "1112c88470f339dc631e2a7117087f416af6d6b5" 10SRCREV = "7a277c8a1a21ff921d217889dde6a9f84e6d2168"
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13BOOT_TOOLS = "imx-boot-tools" 13BOOT_TOOLS = "imx-boot-tools"
diff --git a/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.10.0.bb b/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.11.0.bb
index e3dad7da..27f7a2a7 100644
--- a/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.10.0.bb
+++ b/recipes-bsp/imx-sc-firmware/imx-sc-firmware_1.11.0.bb
@@ -3,15 +3,15 @@
3 3
4DESCRIPTION = "i.MX System Controller Firmware" 4DESCRIPTION = "i.MX System Controller Firmware"
5LICENSE = "Proprietary" 5LICENSE = "Proprietary"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 6LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
7SECTION = "BSP" 7SECTION = "BSP"
8 8
9inherit fsl-eula-unpack pkgconfig deploy 9inherit fsl-eula-unpack pkgconfig deploy
10 10
11SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true" 11SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
12 12
13SRC_URI[md5sum] = "5c2b9d35e526136042a84e8d8f6c116e" 13SRC_URI[md5sum] = "95f1b0a148c323968c0741e807995948"
14SRC_URI[sha256sum] = "0adc3d2c2df250a873232f1b62b14674694b50a4e01dd6ceae479e4ff2b2276b" 14SRC_URI[sha256sum] = "4ad2999088098c7d95837b7dc88adceda319c2102c8bdf55bf6e9453653fba00"
15 15
16BOARD_TYPE ?= "mek" 16BOARD_TYPE ?= "mek"
17SC_FIRMWARE_NAME ?= "INVALID" 17SC_FIRMWARE_NAME ?= "INVALID"
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
index 41128e28..f8c3c239 100644
--- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb
+++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
@@ -4,14 +4,14 @@ SUMMARY = "NXP i.MX SECO library"
4DESCRIPTION = "NXP i.MX Security Controller library" 4DESCRIPTION = "NXP i.MX Security Controller library"
5SECTION = "base" 5SECTION = "base"
6LICENSE = "Proprietary" 6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://EULA.txt;md5=85d06b38f17b935ca11784d67075b846" 7LIC_FILES_CHKSUM = "file://EULA.txt;md5=76871788f27c28af824e2ec1ca187832"
8 8
9DEPENDS = "zlib" 9DEPENDS = "zlib"
10 10
11SRCBRANCH = "lf-5.10.y_2.0.0" 11SRCBRANCH = "lf-5.10.72_2.2.0"
12SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \ 12SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \
13 file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch" 13 file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch"
14SRCREV = "44caf511023012e9eda93f8bf64c90eaff1bade6" 14SRCREV = "3e8ad6b168f23a8c6ecd75edabc18d2673403e24"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
diff --git a/recipes-bsp/imx-seco/imx-seco_3.8.2.bb b/recipes-bsp/imx-seco/imx-seco_3.8.4.bb
index bd749e4f..bd5739cd 100644
--- a/recipes-bsp/imx-seco/imx-seco_3.8.2.bb
+++ b/recipes-bsp/imx-seco/imx-seco_3.8.4.bb
@@ -4,14 +4,14 @@ SUMMARY = "NXP i.MX SECO firmware"
4DESCRIPTION = "NXP i.MX Security Controller firmware" 4DESCRIPTION = "NXP i.MX Security Controller firmware"
5SECTION = "base" 5SECTION = "base"
6LICENSE = "Proprietary" 6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 7LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
8 8
9inherit fsl-eula-unpack use-imx-security-controller-firmware deploy 9inherit fsl-eula-unpack use-imx-security-controller-firmware deploy
10 10
11SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" 11SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
12 12
13SRC_URI[md5sum] = "92a15f2ffe162374806e2dfe9b0aa2e9" 13SRC_URI[md5sum] = "38d298cda9ea91db945b266bd6774e07"
14SRC_URI[sha256sum] = "c543cd3ec4d30c0cf5ee2a2f4dc7efe209363e45087e0b7c380b727b7bcf2c8a" 14SRC_URI[sha256sum] = "ed65381fac7a17a7594099191952821ed3f3f54c944937926dc19f82ecd8fef5"
15 15
16do_compile[noexec] = "1" 16do_compile[noexec] = "1"
17 17
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index f7ef0348..d33ad18c 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -16,12 +16,12 @@ DEPENDS:append:imxvpu = " virtual/imxvpu"
16PE = "1" 16PE = "1"
17PV = "7.0+${SRCPV}" 17PV = "7.0+${SRCPV}"
18 18
19SRCBRANCH = "lf-5.10.52_2.1.0" 19SRCBRANCH = "lf-5.10.72_2.2.0"
20SRC_URI = " \ 20SRC_URI = " \
21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \ 21 git://source.codeaurora.org/external/imx/imx-test.git;protocol=https;branch=${SRCBRANCH} \
22 file://memtool_profile \ 22 file://memtool_profile \
23" 23"
24SRCREV = "2dcb987a91183770f328258b424d9ad2fdfdc17a" 24SRCREV = "a26b1ee51177e317aa05251d4c8f10c4c68064f6"
25S = "${WORKDIR}/git" 25S = "${WORKDIR}/git"
26 26
27inherit module-base use-imx-headers 27inherit module-base use-imx-headers
diff --git a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.6.0.bb
index e6cffaca..2a17d76f 100644
--- a/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.5.0.bb
+++ b/recipes-bsp/imx-vpu-hantro-vc/imx-vpu-hantro-vc_1.6.0.bb
@@ -2,7 +2,7 @@
2 2
3DESCRIPTION = "i.MX VC8000E Encoder library" 3DESCRIPTION = "i.MX VC8000E Encoder library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 5LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
6 6
7inherit fsl-eula-unpack 7inherit fsl-eula-unpack
8 8
@@ -10,8 +10,8 @@ SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10 10
11S = "${WORKDIR}/${BPN}-${PV}" 11S = "${WORKDIR}/${BPN}-${PV}"
12 12
13SRC_URI[md5sum] = "fbd43a100c27abbae301428f1ae2bc64" 13SRC_URI[md5sum] = "c24e2622c522bb4bc2da710c27389ee4"
14SRC_URI[sha256sum] = "e59ac2ded726d722f61793b17fc394ce87b1c5710cb79f0b1d60b87fca5829e1" 14SRC_URI[sha256sum] = "338eaa313cfa6f93eee5930903386fca922f82fda3617ecb2597cc90ccf8f22d"
15 15
16# SCR is the location and name of the Software Content Register file 16# SCR is the location and name of the Software Content Register file
17# relative to ${D}${D_SUBDIR}. 17# relative to ${D}${D_SUBDIR}.
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.1.bb
index 25f54c7a..d4a48627 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-daemon_1.1.1.bb
@@ -9,8 +9,8 @@ DEPENDS:append:mx8mp = " imx-vpu-hantro-vc"
9SRC_URI = " \ 9SRC_URI = " \
10 ${FSL_MIRROR}/${BP}.tar.gz \ 10 ${FSL_MIRROR}/${BP}.tar.gz \
11" 11"
12SRC_URI[md5sum] = "980237589af195c2c4b852a7aad175ee" 12SRC_URI[md5sum] = "99e96b2e00516d56a78a95a80851076b"
13SRC_URI[sha256sum] = "a5d915fefd3637e68d693638edd1161c30e75011a6312251b914f04546fd0fc9" 13SRC_URI[sha256sum] = "e7b3d55f72e233179b1b28c03628139b463d1994d140fed3c3e0796c66e917c8"
14 14
15PLATFORM:mx8mm = "IMX8MM" 15PLATFORM:mx8mm = "IMX8MM"
16PLATFORM:mx8mq = "IMX8MQ" 16PLATFORM:mx8mq = "IMX8MQ"
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.24.0.bb
index 427dbf92..84c71610 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.23.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.24.0.bb
@@ -2,13 +2,13 @@
2 2
3DESCRIPTION = "i.MX Hantro VPU library" 3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 5LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
6 6
7PROVIDES = "virtual/imxvpu" 7PROVIDES = "virtual/imxvpu"
8 8
9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true" 9SRC_URI = "${FSL_MIRROR}/${BP}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "3f8d4bb593d851d0523d0146131946ae" 10SRC_URI[md5sum] = "1f99c6941b8a51035b52cc5bc72faa3d"
11SRC_URI[sha256sum] = "a312a0b6d32ed16527e5bfcff362b231069428362ad5710f816bca019f70c6a2" 11SRC_URI[sha256sum] = "aa9461a152e13a1caa852f29ae18fd33aebd90c8a2b49519003e632687fe89d6"
12 12
13inherit fsl-eula-unpack use-imx-headers 13inherit fsl-eula-unpack use-imx-headers
14 14
diff --git a/recipes-bsp/isp-imx/basler-camera_4.2.2.15.0.bb b/recipes-bsp/isp-imx/basler-camera_4.2.2.16.0.bb
index 0122d273..e7c8a326 100644
--- a/recipes-bsp/isp-imx/basler-camera_4.2.2.15.0.bb
+++ b/recipes-bsp/isp-imx/basler-camera_4.2.2.16.0.bb
@@ -2,14 +2,14 @@
2 2
3DESCRIPTION = "Basler camera binary drivers" 3DESCRIPTION = "Basler camera binary drivers"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 5LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
6 6
7inherit fsl-eula-unpack 7inherit fsl-eula-unpack
8 8
9SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true" 9SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
10 10
11SRC_URI[md5sum] = "963339f568e8b0ba5d67328238284d47" 11SRC_URI[md5sum] = "489763169857773bade28611e649172e"
12SRC_URI[sha256sum] = "f4d4aa08103937ddd86b9c0880d07c1e0db1ec7f51a420a8ccc76dcf2fb7dbe6" 12SRC_URI[sha256sum] = "3d4ae594659a697eef7479ca2480cc53f1d460f22bcc1c58104cff63bc6705fe"
13 13
14do_install() { 14do_install() {
15 dest_dir=${D}/opt/imx8-isp/bin 15 dest_dir=${D}/opt/imx8-isp/bin
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.16.0.bb
index 9ede07bd..4411c351 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.15.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.16.0.bb
@@ -2,17 +2,16 @@
2 2
3DESCRIPTION = "i.MX Verisilicon Software ISP" 3DESCRIPTION = "i.MX Verisilicon Software ISP"
4LICENSE = "Proprietary" 4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e565271ec9a80ce47abbddc4bffe56fa" 5LIC_FILES_CHKSUM = "file://COPYING;md5=03bcadc8dc0a788f66ca9e2b89f56c6f"
6DEPENDS = "python3 libdrm virtual/libg2d libtinyxml2-8" 6DEPENDS = "python3 libdrm virtual/libg2d libtinyxml2-8"
7 7
8SRC_URI = " \ 8SRC_URI = " \
9 ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \ 9 ${FSL_MIRROR}/${BP}.bin;fsl-eula=true \
10 file://0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch \ 10 file://0001-start_isp.sh-fix-NR_DEVICE_TREE_BASLER-variable.patch \
11 file://0001-isp-imx-drop-use-of-__TIME__-__DATE__.patch \
12" 11"
13 12
14SRC_URI[md5sum] = "e9e0943b9f4923c767d07901e550c41c" 13SRC_URI[md5sum] = "f490153dbec234a04416ad41834806b2"
15SRC_URI[sha256sum] = "13274c0fd442da4b3b9900a7568c59872ffa6408f5699d35eebc6760a8e51297" 14SRC_URI[sha256sum] = "83b24b9d1f7a40a506a45a1c5c2ef2ca2313fe9b23fde591e3b7dce77ea359ca"
16 15
17inherit fsl-eula-unpack cmake systemd use-imx-headers 16inherit fsl-eula-unpack cmake systemd use-imx-headers
18 17
diff --git a/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
index 2abcac9b..f82f7b67 100644
--- a/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
+++ b/recipes-bsp/u-boot/u-boot-imx-common_2021.04.inc
@@ -5,7 +5,8 @@ LIC_FILES_CHKSUM = "file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a
5 5
6SRCBRANCH = "lf_v2021.04" 6SRCBRANCH = "lf_v2021.04"
7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}" 7SRC_URI = "git://source.codeaurora.org/external/imx/uboot-imx.git;protocol=https;branch=${SRCBRANCH}"
8SRCREV = "3463140881c523e248d2fcb6bfc9ed25c0db93bd" 8SRCREV = "263b27e076a0f6e5dcc80227a235f0af73718342"
9LOCALVERSION ?= "-imx_v2021.04_5.10.72_2.2.0"
9 10
10DEPENDS += "flex-native bison-native bc-native dtc-native" 11DEPENDS += "flex-native bison-native bc-native dtc-native"
11 12
@@ -14,7 +15,4 @@ B = "${WORKDIR}/build"
14 15
15inherit fsl-u-boot-localversion 16inherit fsl-u-boot-localversion
16 17
17LOCALVERSION ?= "-imx_v2021.04_5.10.35_2.0.0"
18
19BOOT_TOOLS = "imx-boot-tools" 18BOOT_TOOLS = "imx-boot-tools"
20
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
index af502889..5443ceac 100644
--- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2021.04.bb
@@ -6,3 +6,7 @@ FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-imx:"
6 6
7require u-boot-imx_${PV}.bb 7require u-boot-imx_${PV}.bb
8require u-boot-mfgtool.inc 8require u-boot-mfgtool.inc
9
10UUU_BOOTLOADER_TAGGED = ""
11UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
12UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
index bb5809e2..96552eef 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2021.04.bb
@@ -7,6 +7,15 @@ require u-boot-imx-common_${PV}.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot"
9 9
10inherit uuu_bootloader_tag
11
12UUU_BOOTLOADER = ""
13UUU_BOOTLOADER:mx6 = "${UBOOT_BINARY}"
14UUU_BOOTLOADER:mx7 = "${UBOOT_BINARY}"
15UUU_BOOTLOADER_TAGGED = ""
16UUU_BOOTLOADER_TAGGED:mx6 = "u-boot-tagged.${UBOOT_SUFFIX}"
17UUU_BOOTLOADER_TAGGED:mx7 = "u-boot-tagged.${UBOOT_SUFFIX}"
18
10do_deploy:append:mx8m() { 19do_deploy:append:mx8m() {
11 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary 20 # Deploy u-boot-nodtb.bin and fsl-imx8m*-XX.dtb for mkimage to generate boot binary
12 if [ -n "${UBOOT_CONFIG}" ] 21 if [ -n "${UBOOT_CONFIG}" ]