summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-12-14 15:12:29 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2023-04-01 17:37:43 -0300
commitf93d50e3dd78983172b9458244d2b78327a5f571 (patch)
tree1909fc009d2c57ddc99faf2f754e7ee183453861
parentc5ebde814cbc67656d2d2c373095a0f1515e1e09 (diff)
downloadmeta-freescale-f93d50e3dd78983172b9458244d2b78327a5f571.tar.gz
uuu-bin-native: init at 1.4.243
This recipe uses the pre-built binaries provided by NXP itself so we can offer Linux, Windows and MacOS binaries. Those binaries are intended for use in the mfgtool-bundle and not for execution in the host. We install the binaries in '${libdir}/uuu'. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-devtools/uuu/uuu-bin-native_1.4.243.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-devtools/uuu/uuu-bin-native_1.4.243.bb b/recipes-devtools/uuu/uuu-bin-native_1.4.243.bb
new file mode 100644
index 00000000..db4245e0
--- /dev/null
+++ b/recipes-devtools/uuu/uuu-bin-native_1.4.243.bb
@@ -0,0 +1,37 @@
1# Copyright (C) 2022-2023 O.S. Systems Software LTDA.
2# Released under the MIT License (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Update Utility - Binaries"
5DESCRIPTION = "Image deploy tool for i.MX chips"
6HOMEPAGE = "https://github.com/NXPmicro/mfgtools"
7
8LICENSE = "BSD-3-Clause & LGPL-2.1-or-later"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \
10 file://${COMMON_LICENSE_DIR}/LGPL-2.1-or-later;md5=2a4f4fd2128ea2f65047ee63fbca9f68"
11
12SRC_URI = " \
13 https://github.com/NXPmicro/mfgtools/releases/download/uuu_${PV}/uuu;downloadfilename=uuu-${PV};name=Linux \
14 https://github.com/NXPmicro/mfgtools/releases/download/uuu_${PV}/uuu_mac;downloadfilename=uuu-${PV}_mac;name=Mac \
15 https://github.com/NXPmicro/mfgtools/releases/download/uuu_${PV}/uuu.exe;downloadfilename=uuu-${PV}.exe;name=Windows \
16"
17
18SRC_URI[Linux.sha256sum] = "dfb2a6dca337ebd59675ea5ce7f1bce6724e3b901bcb455126d4bf9bdfa2e585"
19SRC_URI[Mac.sha256sum] = "399efa4bc7e3eb452fefe89ef5e2e453b516ea716658a963a890c430ad81a471"
20SRC_URI[Windows.sha256sum] = "f3f178e7be161c7dc058dbcd35c8cfa1516981e7c4f915fe0256ae4cda7f101e"
21
22S = "${WORKDIR}"
23
24inherit native
25
26do_install() {
27 install -D -m 0755 ${WORKDIR}/uuu-${PV} ${D}${libdir}/uuu/uuu
28 install -D -m 0755 ${WORKDIR}/uuu-${PV}_mac ${D}${libdir}/uuu/uuu_mac
29 install -D -m 0644 ${WORKDIR}/uuu-${PV}.exe ${D}${libdir}/uuu/uuu.exe
30}
31
32SYSROOT_DIRS_NATIVE = "${libdir}/uuu"
33
34# HACK! We are not aiming to run those binaries during the build but copy then for MFGTOOL
35# bundle. If make the binaries relocatable they will rely on OpenEmbedded native sysroot paths but
36# we want them to run at user machine.
37SYSROOT_PREPROCESS_FUNCS:remove = "relocatable_binaries_preprocess relocatable_native_pcfiles"