summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-02-01 21:42:20 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-01 21:42:20 -0800
commit82492293279a30445af9c74fae598f63e39599d6 (patch)
treeea88e9e78e25a36585d317c191aebd304f9b2787
parent3d6766b7a9334dfc46b1bbb2a26309defef36b43 (diff)
downloadmeta-freescale-82492293279a30445af9c74fae598f63e39599d6.tar.gz
kernel-module-nxp89xx: Pin to imx machine kernel
It fails to build with linux-yocto 5.15 e.g. TOPDIR/build/tmp/work/qemumips-yoe-linux/kernel-module-nxp89xx/git-r0/git/mxm_wifiex/wlan_src/mlinux/moal_shim.c:1405:49: error: 'RX_PKT_FATE_DRV_DROP_NOBUFS' undeclared (first use in this function) 1405 | RX_PKT_FATE_DRV_DROP_NOBUFS, | ^~~~~~~~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-nxp89xx_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-nxp89xx_git.bb b/recipes-kernel/kernel-modules/kernel-module-nxp89xx_git.bb
index ab096e81..f99b7594 100644
--- a/recipes-kernel/kernel-modules/kernel-module-nxp89xx_git.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-nxp89xx_git.bb
@@ -12,3 +12,6 @@ S = "${WORKDIR}/git/mxm_wifiex/wlan_src"
12inherit module 12inherit module
13 13
14EXTRA_OEMAKE = "KERNELDIR=${STAGING_KERNEL_BUILDDIR} -C ${STAGING_KERNEL_BUILDDIR} M=${S}" 14EXTRA_OEMAKE = "KERNELDIR=${STAGING_KERNEL_BUILDDIR} -C ${STAGING_KERNEL_BUILDDIR} M=${S}"
15
16COMPATIBLE_MACHINE = "(imx)"
17