summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-02-12 20:26:51 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2021-02-13 09:56:03 -0300
commitd82d3823e83a161b488fe017d120255b1216bcc9 (patch)
tree332324775e87a3b0a7d57fd5aa4c9f32adc3491d
parentbc80ff0fa409e9c28c7b6ae1581b1aa20a0e7d9f (diff)
downloadmeta-freescale-d82d3823e83a161b488fe017d120255b1216bcc9.tar.gz
imx-seco-libs: Fix host-user-contaminated QA issue
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch34
-rw-r--r--recipes-bsp/imx-seco/imx-seco-libs_git.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch b/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch
new file mode 100644
index 00000000..757b9a6a
--- /dev/null
+++ b/recipes-bsp/imx-seco/imx-seco-libs/0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch
@@ -0,0 +1,34 @@
1From 59608dcb0f0a6f6d8154b1d331c2403d7c1143eb Mon Sep 17 00:00:00 2001
2From: Cristinel Panfir <cristinel.panfir@nxp.com>
3Date: Fri, 5 Feb 2021 19:27:00 +0200
4Subject: [PATCH] Makefile: Fix install to clear host-user-contaminated
5 warnings [HSM-483]
6
7WARNING: imx-seco-libs-git-r0 do_package_qa: QA Issue:
8imx-seco-libs: /usr/lib/hsm_lib.a is owned by uid 26292, which is the same as the user running bitbake. This may be due to host contamination
9imx-seco-libs: /usr/lib/she_lib.a is owned by uid 26292, which is the same as the user running bitbake. This may be due to host contamination
10imx-seco-libs: /usr/lib/seco_nvm_manager.a is owned by uid 26292, which is the same as the user running bitbake.
11This may be due to host contamination [host-user-contaminated]
12
13Upstream-Status: Pending
14
15Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
16---
17 Makefile | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/Makefile b/Makefile
21index 492d700..25ad333 100644
22--- a/Makefile
23+++ b/Makefile
24@@ -63,7 +63,7 @@ hsm_doc: include/hsm/hsm_api.h
25
26 install: hsm_test she_test she_lib.a seco_nvm_manager.a hsm_lib.a
27 mkdir -p $(DESTDIR)$(BINDIR) $(DESTDIR)$(LIBDIR) $(DESTDIR)$(INCLUDEDIR)
28- cp -a seco_nvm_manager.a hsm_lib.a she_lib.a $(DESTDIR)$(LIBDIR)
29+ cp seco_nvm_manager.a hsm_lib.a she_lib.a $(DESTDIR)$(LIBDIR)
30 cp hsm_test she_test $(DESTDIR)$(BINDIR)
31 cp -a include/* $(DESTDIR)$(INCLUDEDIR)
32
33--
342.25.1
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
index 69b60847..dc37cdfc 100644
--- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb
+++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb
@@ -9,7 +9,8 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=228c72f2a91452b8a03c4cab30f30ef9"
9DEPENDS = "zlib" 9DEPENDS = "zlib"
10 10
11SRCBRANCH = "imx_5.4.70_2.3.1" 11SRCBRANCH = "imx_5.4.70_2.3.1"
12SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH}" 12SRC_URI = "git://github.com/NXP/imx-seco-libs.git;protocol=https;branch=${SRCBRANCH} \
13 file://0002-Makefile-Fix-install-to-clear-host-user-contaminated.patch"
13SRCREV = "79e5fb5d096c61b1c3163c9fa8e42719509d95a0" 14SRCREV = "79e5fb5d096c61b1c3163c9fa8e42719509d95a0"
14 15
15S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"