diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2020-12-14 16:03:50 -0600 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2021-01-21 08:37:58 -0300 |
commit | 80345fbe89c5ac96975f9c7ef38e8dc8d2a36346 (patch) | |
tree | 52d536e34359afa72a864605af644e1614f38767 | |
parent | b57002ea344326e638e2c36be27fb37562f076f5 (diff) | |
download | meta-freescale-80345fbe89c5ac96975f9c7ef38e8dc8d2a36346.tar.gz |
imx8qxpmek: Update the i.MX 8QXP default build to rev C0
The current machine configuration support for 8QXP MEK is for rev B0 silicon.
Support for rev C0 is implemented using a machine override `mx8qxpc0`.
Update the default build to rev C0 silicon. Support for rev B0 is provided
with a new machine feature `soc-revb0`. The machine override is removed.
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | classes/use-imx-security-controller-firmware.bbclass | 5 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-boot_1.0.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/imx-mkimage/imx-mkimage_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco-libs_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/imx-seco/imx-seco_3.7.1.bb | 2 |
5 files changed, 11 insertions, 6 deletions
diff --git a/classes/use-imx-security-controller-firmware.bbclass b/classes/use-imx-security-controller-firmware.bbclass index 7b82bcaf..52b1bf37 100644 --- a/classes/use-imx-security-controller-firmware.bbclass +++ b/classes/use-imx-security-controller-firmware.bbclass | |||
@@ -19,8 +19,9 @@ | |||
19 | SECO_FIRMWARE_NAME ?= "" | 19 | SECO_FIRMWARE_NAME ?= "" |
20 | 20 | ||
21 | SECO_FIRMWARE_NAME_mx8qm = "mx8qmb0-ahab-container.img" | 21 | SECO_FIRMWARE_NAME_mx8qm = "mx8qmb0-ahab-container.img" |
22 | SECO_FIRMWARE_NAME_mx8qxp = "mx8qxb0-ahab-container.img" | 22 | SECO_FIRMWARE_NAME_mx8qxp = \ |
23 | SECO_FIRMWARE_NAME_mx8qxpc0 = "mx8qxc0-ahab-container.img" | 23 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'mx8qxb0-ahab-container.img', \ |
24 | 'mx8qxc0-ahab-container.img', d)}" | ||
24 | SECO_FIRMWARE_NAME_mx8phantomdxl = "mx8qxb0-ahab-container.img" | 25 | SECO_FIRMWARE_NAME_mx8phantomdxl = "mx8qxb0-ahab-container.img" |
25 | SECO_FIRMWARE_NAME_mx8dxl = "mx8dxla0-ahab-container.img" | 26 | SECO_FIRMWARE_NAME_mx8dxl = "mx8dxla0-ahab-container.img" |
26 | 27 | ||
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb index a5ec9d60..5ca817ae 100644 --- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb +++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb | |||
@@ -65,7 +65,9 @@ SOC_FAMILY_mx8m = "mx8m" | |||
65 | SOC_FAMILY_mx8x = "mx8x" | 65 | SOC_FAMILY_mx8x = "mx8x" |
66 | 66 | ||
67 | REV_OPTION ?= "" | 67 | REV_OPTION ?= "" |
68 | REV_OPTION_mx8qxpc0 = "REV=C0" | 68 | REV_OPTION_mx8qxp = \ |
69 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', '', \ | ||
70 | 'REV=C0', d)}" | ||
69 | 71 | ||
70 | compile_mx8m() { | 72 | compile_mx8m() { |
71 | bbnote 8MQ/8MM/8MN/8MP boot binary build | 73 | bbnote 8MQ/8MM/8MN/8MP boot binary build |
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb index ed15c6f8..a2188c82 100644 --- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb +++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb | |||
@@ -13,7 +13,9 @@ inherit native deploy | |||
13 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" | 13 | CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" |
14 | 14 | ||
15 | REV_CHIP ?= "B0" | 15 | REV_CHIP ?= "B0" |
16 | REV_CHIP_mx8qxpc0 = "C0" | 16 | REV_CHIP_mx8qxp = \ |
17 | "${@bb.utils.contains('MACHINE_FEATURES', 'soc-revb0', 'B0', \ | ||
18 | 'C0', d)}" | ||
17 | 19 | ||
18 | do_compile () { | 20 | do_compile () { |
19 | cd ${S} | 21 | cd ${S} |
diff --git a/recipes-bsp/imx-seco/imx-seco-libs_git.bb b/recipes-bsp/imx-seco/imx-seco-libs_git.bb index 8184b56a..0cc0187d 100644 --- a/recipes-bsp/imx-seco/imx-seco-libs_git.bb +++ b/recipes-bsp/imx-seco/imx-seco-libs_git.bb | |||
@@ -20,4 +20,4 @@ do_install () { | |||
20 | oe_runmake DESTDIR=${D} install | 20 | oe_runmake DESTDIR=${D} install |
21 | } | 21 | } |
22 | 22 | ||
23 | COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8qxpc0|mx8phantomdxl|mx8dxl)" | 23 | COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8phantomdxl|mx8dxl)" |
diff --git a/recipes-bsp/imx-seco/imx-seco_3.7.1.bb b/recipes-bsp/imx-seco/imx-seco_3.7.1.bb index 62c22dc2..28469390 100644 --- a/recipes-bsp/imx-seco/imx-seco_3.7.1.bb +++ b/recipes-bsp/imx-seco/imx-seco_3.7.1.bb | |||
@@ -23,4 +23,4 @@ do_deploy () { | |||
23 | install -m 0644 ${S}/firmware/seco/${SECO_FIRMWARE_NAME} ${DEPLOYDIR} | 23 | install -m 0644 ${S}/firmware/seco/${SECO_FIRMWARE_NAME} ${DEPLOYDIR} |
24 | } | 24 | } |
25 | 25 | ||
26 | COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8qxpc0|mx8phantomdxl|mx8dxl)" | 26 | COMPATIBLE_MACHINE = "(mx8qm|mx8qxp|mx8phantomdxl|mx8dxl)" |